Gnome Terminal not working in Cinnamon (New Install)

This is my own iso made today.

As /etc/locale.conf is now self generated, for reasons not known it adds all local info to this file.
Removing this local info and just leaving “LANG=en_GB.UTF-8” lets gnome-terminal work again.

The error could be calamares as that generates local but as far as I know this does not touch locale.conf only locale.gen.
@philm wrote With filesystem 2022.06.08-2, it will automatically restore /etc/locale.conf if it did not already exist. so perhaps this is the culprit? Perhaps putting one in the overlay will work?

No putting one in the overlay with just “LANG=en_GB.UTF-8” in it still got populated with locale info again.

It is a know issue that gnome-terminal is sensitive to the langauge in locale.conf and incorrect settings may cause the terminal to refuse to launch.

The additional info is just standard locale information

As reference - my locale.conf

 $ cat /etc/locale.conf
LANG=en_DK.UTF-8
LC_ADDRESS=da_DK.UTF-8
LC_IDENTIFICATION=da_DK.UTF-8
LC_MEASUREMENT=da_DK.UTF-8
LC_MONETARY=da_DK.UTF-8
LC_NAME=da_DK.UTF-8
LC_NUMERIC=da_DK.UTF-8
LC_PAPER=da_DK.UTF-8
LC_TELEPHONE=da_DK.UTF-8
LC_TIME=da_DK.UTF-8

If you rightclick a locale in MSM you have the option of setting the selected locale as locale for system and/or for other locale settings.

I cannot figure why these should cause gnome-terminal to fail.

Could you provide the content of the configuration which cause gnome-terminal to fail?

Calamares writes the selected locale to the end of locale.gen and calls locale-conf just like you would do on a manual install.

The file provided with the filesystem package only contains necessary initial values

LANG="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_COLLATE="C.UTF-8"

One could speculate why the string values are quoted as this is not standard (perhaps it has become standard) but it shouldn’t alter the meaning as the content is just a preset of environment variables.

Latest calamares

LANG=en_GB.UTF-8
LC_ADDRESS=en_GB.UTF-8/UTF-8 \
LC_IDENTIFICATION=en_GB.UTF-8/UTF-8 \
LC_MEASUREMENT=en_GB.UTF-8/UTF-8 \
LC_MONETARY=en_GB.UTF-8/UTF-8 \
LC_NAME=en_GB.UTF-8/UTF-8 \
LC_NUMERIC=en_GB.UTF-8/UTF-8 \
LC_PAPER=en_GB.UTF-8/UTF-8 \
LC_TELEPHONE=en_GB.UTF-8/UTF-8 \
LC_TIME=en_GB.UTF-8/UTF-8 \

The missing ones

LC_CTYPE="en_GB.UTF-8"
LC_COLLATE="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_ALL=

You can see no quotes extra /UTF-8 \ and its not complete, no wonder gnome terminal doesn’t like it

If that is the file content then no system will understand!

My experience tells me only the LANG= is required the rest are optional. If there is more settings defined the corresponding language must be uncommented in locale.gen and generated using the locale-gen script.

EDIT

There’s definately something fishy with the Calamares installer

Can Someone look at Calamares for what is happening I thought it only Touched /etc/locale.gen
Is it really touching /etc /locale.conf?
@philm

The question is more which install media was used to install Cinnamon. There is a known issue with Calamares: Locale setting problems immediately after installation · Issue #2053 · calamares/calamares · GitHub which is however in combination of a newer glibc package: FS#75894 : glibc SUPPORTED file not parsed The issue was introduced with improve locale handling as supposed by @codefiles · archlinux/svntogit-packages@3c537be · GitHub which is part of 2.36-4 package, which is only on testing and unstable branch. You can also install glibc-locales which has all locales generated.

I am on unstable and it is still broken, adding glibc-locales made no difference.

It made no difference to /etc/locale.conf but locale -a had all languages instead of

C C.UTF-8 en_GB.utf8 POSIX