Gnome-terminal forces lightest possible font weight

When choosing a font in gnome-terminal, it offers no choices for font weight but automatically chooses the lightest possible variant available for each font. For fonts with very light options like Inconsolata, this is completely unusable. Fonts that have no light variants work fine (like Hack, etc.)

gedit, for example, does not have this problem because you can choose which font weight you want.

Not a bug but a feature.

That is probably due to the nature of the terminal - you would probably expect a monospace font - which automaticially eliminate - other font properties which may be available for other applications.

Creating bold, flashing etc. texts are done completely different within the terminal vs. a text editor.

1 Like

Right, but the terminal is supposed to use the “regular” or “medium” font weight for normal text, not “light” or “extralight”.

That is your definition - probably not coherent with Gnome developers.

Just disable the Use system default and set your own preference.

If that is not to your satisfaction you should raise the issue with the Gnome developers as Manjaro is only supplying the Gnome applications - having no influence on the actual development - Gnome devs knows what is best for your computing needs even if you don’t agree.

This thread ranks high on a search for “gnome terminal font weight”, so I want to contribute a workaround.

Although the GNOME Terminal settings UI doesn’t allow setting a font weight, it internally does select a specific variant of the font, which we can change via dconf.

My profile here has the identifier 8d4b11d5-8eae-4259-8ac5-983095299f62 (this identifier is shown in the settings menu), so I run the following commands:

% dconf read /org/gnome/terminal/legacy/profiles:/:8d4b11d5-8eae-4259-8ac5-983095299f62/font
'Iosevka Term SS09 Thin Expanded 11'

Remove the “Thin Expanded” or whatever variant of your font was put there (note the double quoting):

% dconf write /org/gnome/terminal/legacy/profiles:/:8d4b11d5-8eae-4259-8ac5-983095299f62/font "'Iosevka Term SS09 11'"

Now it should use the regular variant again.


Thank you so much, that worked wonderfully.