gnome-shell RAM usage growing in few hours

Hello,
since the upgrade of gnome-shell 3.34, RAM usage of gnome-shell grow in a few hours ...
I disabled extensions and set Adwaita as GTK theme, but this not solve the problem.

inxi -Fxxxz
System:    Host:  Kernel: 4.19.84-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 Desktop: Gnome 3.34.1 
           wm: gnome-shell dm: GDM 3.34.1 Distro: Manjaro Linux 
Machine:   Type: Laptop System: HP product: HP EliteBook 820 G4 v: N/A serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: HP model: 8292 v: KBC Version 45.43 serial: <filter> UEFI: HP v: P78 Ver. 01.23 date: 07/17/2018 
Battery:   ID-1: BAT0 charge: 46.0 Wh condition: 47.9/47.9 Wh (100%) volts: 13.0/11.6 model: Hewlett-Packard Primary 
           type: Li-ion serial: <filter> status: Unknown 
CPU:       Topology: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP arch: Kaby Lake rev: 9 L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 21704 
           Speed: 800 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 
Graphics:  Device-1: Intel HD Graphics 620 vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5916 
           Display: wayland server: X.org 1.20.5 driver: i915 compositor: gnome-shell resolution: <xdpyinfo missing> 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2) v: 4.5 Mesa 19.2.4 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:9d71 
           Sound Server: ALSA v: k4.19.84-1-MANJARO 
Network:   Device-1: Intel Ethernet I219-V vendor: Hewlett-Packard driver: e1000e v: 3.2.6-k port: efa0 bus ID: 00:1f.6 
           chip ID: 8086:15d8 
           IF: enp0s31f6 state: up speed: 100 Mbps duplex: full mac: <filter> 
           Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: efa0 bus ID: 02:00.0 chip ID: 8086:24fd 
           IF: wlp2s0 state: down mac: <filter> 
Drives:    Local Storage: total: 238.47 GiB used: 84.45 GiB (35.4%) 
           ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKKF256G7H size: 238.47 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> 
           rev: HP01 scheme: GPT 
Partition: ID-1: / size: 24.48 GiB used: 17.85 GiB (72.9%) fs: ext4 dev: /dev/dm-0 
           ID-2: /home size: 75.29 GiB used: 66.60 GiB (88.5%) fs: ext4 dev: /dev/dm-1 
           ID-3: swap-1 size: 1.97 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/nvme0n1p6 
Sensors:   System Temperatures: cpu: 40.0 C mobo: 0.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 218 Uptime: 2h 39m Memory: 7.58 GiB used: 3.98 GiB (52.5%) Init: systemd v: 242 Compilers: gcc: 9.2.0 
           Shell: fish v: 3.0.2 running in: gnome-terminal inxi: 3.0.36
ps -eo pid,ppid,rss,stime,time,cmd --sort=-rss | head
  PID  PPID   RSS STIME     TIME CMD
 1930  1762 1494224 11:26 00:09:33 /usr/bin/gnome-shell
 2472  1930 409400 11:26 00:04:42 /usr/lib/firefox/firefox
 2770  2472 393484 11:26 00:01:00 /usr/lib/firefox/firefox -contentproc -childID 6 -isForBrowser -prefsLen 7156 -prefMapSize 213228 -parentBuildID 20191031132559 -greomni /usr/lib/firefox/omni.ja -appomni /usr/lib/firefox/browser/omni.ja -appdir /usr/lib/firefox/browser 2472 true tab
 4799  2472 381008 11:46 00:00:52 /usr/lib/firefox/firefox -contentproc -childID 8 -isForBrowser -prefsLen 7636 -prefMapSize 213228 -parentBuildID 20191031132559 -greomni /usr/lib/firefox/omni.ja -appomni /usr/lib/firefox/browser/omni.ja -appdir /usr/lib/firefox/browser 2472 true tab
 2589  2472 357992 11:26 00:01:27 /usr/lib/firefox/firefox -contentproc -childID 2 -isForBrowser -prefsLen 455 -prefMapSize 213228 -parentBuildID 20191031132559 -greomni /usr/lib/firefox/omni.ja -appomni /usr/lib/firefox/browser/omni.ja -appdir /usr/lib/firefox/browser 2472 true tab
 2380  1930 345612 11:26 00:03:18 evolution
 3269  3226 266664 11:28 00:03:20 /usr/lib/electron4/electron --type=renderer --no-sandbox --enable-experimental-web-platform-features --enable-features=SharedArrayBuffer --service-pipe-token=14290653920720449238 --lang=en-US --app-path=/usr/lib/atom --user-agent=Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Atom/1.41.0 Chrome/69.0.3497.128 Electron/4.2.12 Safari/537.36 --node-integration=true --webview-tag=true --no-sandbox --background-color=#fff --disable-blink-features=Auxclick --num-raster-threads=2 --enable-main-frame-before-activation --service-request-channel-token=14290653920720449238 --renderer-client-id=4 --shared-files=v8_context_snapshot_data:100,v8_natives_data:101
 2538  2472 251124 11:26 00:01:42 /usr/lib/firefox/firefox -contentproc -childID 1 -isForBrowser -prefsLen 1 -prefMapSize 213228 -parentBuildID 20191031132559 -greomni /usr/lib/firefox/omni.ja -appomni /usr/lib/firefox/browser/omni.ja -appdir /usr/lib/firefox/browser 2472 true tab
 2597  2472 248748 11:26 00:08:13 /usr/lib/firefox/firefox -contentproc -childID 3 -isForBrowser -prefsLen 455 -prefMapSize 213228 -parentBuildID 20191031132559 -greomni /usr/lib/firefox/omni.ja -appomni /usr/lib/firefox/browser/omni.ja -appdir /usr/lib/firefox/browser 2472 true tab

4 Gigs of used RAM is okay, because i expect that preload is active.
may you post the output of 'systemctl status preload' . if it's active the RAM usage is totally normal.

p.s.: with the standard settings of preload it will use always round about 3 GB-Ram to preload the most used applications. there is nothing to worry. if you are running applications that need a lot of RAM just upgrade your RAM-Size. But usually preload is working really fine.

Hi @olli , thanks for your reply.
I don't worry about 4G RAM used by the system but about 1.5G of RAM used by gnome-shell process in only 2h40 of uptime ... if i don't restart gnome-shell, it will grow taking all memory !

 PID  PPID   RSS STIME     TIME CMD
 1930  1762 1494224 11:26 00:09:33 /usr/bin/gnome-shell

that's curious. maybe someone else has a idea. i'm not using gnome so i can't give any advice.

Have you tested other kernels?

Rarely your internet driver is the cause of this.

Stop network manager, then rmmod both your network modules. Wait a few hours to see if things have improved.

I tested on Linux 4.9, 4.14, 4.19, 5.3 ...
This is my corporate pc so i will test network modules later in the late afternoon.

Thanks for help.

you may also try
gnome-shell-performance from aur.

hello,
what is this package and what kind of changes are on it compared to the extra/gnome-shell ?
can I break something ?
I am not very comfortable using this aur package on my production pc ...

Hi,
I tried your suggestion, stopped NetworkManager and removed network modules, but the problem remains, gnome-shell growing a lot in a short times ... :face_with_head_bandage:

may you post the output of 'systemctl status preload' or are you kidding ?
if it's active you can deactivate the service and test again.
and for god's sake why do you believe that removing the network manager would solve your problem ? Are you serious ?

WOW man ! Keep calm and go peacefully :crazy_face: !
I don't use preload and i don't removed NetworkManager but stopped it as suggested by tbg, that is a serious and veteran forum member.

thank you, likewise, for your good intentions :smiley:

Dude, I never said anything about removing network manager. I simply said to stop network manager. I certainly was serious because a bug in a network driver has been known to cause ram usage to increase gradually over time.

Rmodding the network modules (while a low percentage chance of being the culprit) is a perfectly valid trouble shooting step. If you'd take a look at my profile you'd realize I've more solves on the forum related to networking issues than any other user.

I know @pacop is an advanced user and therefore was easily capable of following my advice without instructions.

I realize you are also a competent user @olli, however as a newcomer on the forum you should perhaps familiarize yourself with the users that help on the forum regularly. Most users that have hundreds of solves on the forum tend to have a clue of what they speak.

I think being critical of long time forum helpers advice is not a good way to introduce yourself on any forum. Unless someone is giving dangerous advice there is little to be gained by being critical of others only trying to help.

3 Likes

Hi,
I have dug deeper and deeper, reinstalled all packages of gnome group, checked services and autostart files, analyzed gnome-shell memory leak with heaptrack but finally showing gnome-shell cgroup slice i noticed /usr/bin/appimagelauncherd and /usr/bin/appimagelauncherfs.

systemctl status 1156
● user@1000.service - User Manager for UID 1000
   Loaded: loaded (/usr/lib/systemd/system/user@.service; static; vendor preset: disabled)
   Active: active (running) since Thu 2019-11-21 11:51:34 CET; 13min ago
     Docs: man:user@.service(5)
 Main PID: 1068 (systemd)
   Status: "Startup finished in 55ms."
    Tasks: 416
   Memory: 1.9G
   CGroup: /user.slice/user-1000.slice/user@1000.service
           ├─appimagelauncherd.service
           │ └─1079 /usr/bin/appimagelauncherd
           ├─appimagelauncherfs.service
           │ └─1078 /usr/bin/appimagelauncherfs
           ├─at-spi-dbus-bus.service
           │ ├─1128 /usr/lib/at-spi-bus-launcher
           │ ├─1134 /usr/bin/dbus-daemon --config-file=/usr/share/defaults/at-spi2/accessibility.conf --nofork --print->
           │ └─1398 /usr/lib/at-spi2-registryd --use-gnome-session

Removing manually installed package appimagelauncher fix the memory leak. :sweat_smile:

1 Like

Nicely done. I knew you were too sharp not to figure out the solution. Good work.

1 Like

Forum kindly sponsored by