Gnome shell core dump breakage after gnome 41 update

I recently updated (stable channel) and got the gnome 40.1 update. After a reboot, GDM started crashing on startup (“oh no! something has gone wrong…”)

I installed plasma and switched to SDDM. Logging in to plasma worked. Logging in to gnome shell from SDDM produced the exact same error, but in gnome shell rather than GDM.

After grepping through journalctl for a bit, all I could find was:

Nov 23 23:25:26 mel gnome-shell[7376]: Running GNOME Shell (using mutter 41.0) as a X11 wind
ow and compositing manager
Nov 23 23:25:26 mel gnome-shell[7376]: Enabling experimental feature 'scale-monitor-framebuf
Nov 23 23:25:26 mel gnome-shell[7376]: ATK Bridge is disabled but a11y has already been enab
Nov 23 23:25:26 mel gnome-shell[7376]: Settings schema 'org.gnome.desktop.lockdown' does not contain a key named 'disable-show-password'
Nov 23 23:25:26 mel audit[7376]: ANOM_ABEND auid=1000 uid=1000 gid=1000 ses=3 pid=7376 comm="gnome-shell" exe="/usr/bin/gnome-shell" sig=5 res=1
Nov 23 23:25:26 mel gnome-shell[7376]: == Stack trace for context 0x561539e2b180 ==
Nov 23 23:25:27 mel systemd-coredump[7396]: Process 7376 (gnome-shell) of user 1000 dumped core.
                                            Found module with build-id: 0c937542cc359153908f6098d414c7414ed85230
                                            Found module with build-id: ccc1f98479959b88dbd13ea6513582be82aca7ef
                                            Found module gnome-shell with build-id: 3dadc6c6e5cfce2437308618946a1bcf670b57f7
                                            #1  0x0000561538975b09 n/a (gnome-shell + 0x2b09)
                                            #5  0x000056153897590c n/a (gnome-shell + 0x290c)
                                            #23 0x00007f7aac734f08 n/a ( + 0x35f08)
                                            #24 0x00007f7aac7201f5 n/a ( + 0x211f5)
                                            #27 0x000056153897545c n/a (gnome-shell + 0x245c)
                                            #29 0x000056153897572e n/a (gnome-shell + 0x272e)

Downgrading mutter, gnome-shell, and gdm back to 40.1 fixed the issue.

Anything else I could look for in order to find out why gnome shell core dumped? grepping for mutter or clutter in the logs did not show anything useful.
I run a pretty vanilla install of manjaro, so I am wondering if this is something I should report upstream.

Have you searched? Maybe there’s already an open issue. :wink:

I did google search, went through support/gnome in this forum (the last few weeks) and looked at gnome’s gitlab for “core dump” for anything younger than 1 month.

Let me know if I missed something!

It is also sort of hard to know what to look for when all I have been able to determine so far to be the cause is gnome 41. The crash does not happen under any particularly specific circumstances.

I know that most of the people post new issues without looking for old ones, but this attitude is not helpful and does nothing trying to solve @cottand 's issue.

Anyway, I’ve just experienced the same issue. I initially believe it was due to some mismatch among the video drives since I forced the update excluding the nvidia drivers. I then managed to install a LTS kernel (1.5.10) and again the nvidia drivers, without luck.

Following your example, I’ve installed Plasma and now I’m able to use my machine but I really would like to be able to log back on gnome as well.

@cottand how do you managed to downgrade the three packages? I tried by running

sudo pacman -U /var/cache/pacman/pkg/mutter-40.4-1-x86_64.pkg.tar.zst 

but this is what I got

loading packages...
resolving dependencies...
looking for conflicting packages...
:: mutter and mutter-x11-scaling are in conflict. Remove mutter-x11-scaling? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing mutter-x11-scaling breaks dependency '' required by gnome-shell

hey @temagno ! thanks for your reply and sorry for posting so late.

I managed to downgrade the packages with downgrade after I switched to the testing branch (I switched in hopes of finding a fix sooner from upstream but that did not help)

sudo downgrade gnome-shell mutter gdm

This of course is nothing but a temporary solution :frowning:

EDIT: I think your command should work too if you downgrade all 3 packages at once, rather than one by one.

Housekeeping …