Gnome Settings will not open

Spoke too soon when trying to open the Gnome Settings I get only a spinning cursor. When Using the terminal I get this.

[inkrypted@VOXX ~]$ gnome-control-center -v

(gnome-control-center:7873): Gtk-WARNING **: 02:15:54.932: Theme parsing error: gtk.css:63:28: The :prelight pseudo-class is deprecated. Use :hover instead.

(gnome-control-center:7873): Gtk-WARNING **: 02:15:54.932: Theme parsing error: gtk.css:73:35: The :prelight pseudo-class is deprecated. Use :hover instead.

** (gnome-control-center:7873): WARNING **: 02:15:55.252: Ignoring broken panel wifi (missing desktop file)
**
ERROR:../gnome-control-center/shell/cc-shell-model.c:458:cc_shell_model_set_panel_visibility: assertion failed: (valid)
Aborted (core dumped)
[inkrypted@VOXX ~]$

I have updated my theme that I was using and searched the forum. If anyone has any insight I would appreciate it. Oh I also tried going back to my old kernel 5.1 and changed to the default theme and icons and I get the same results.

A similar issue discussed in the Arch Forums:
https://bbs.archlinux.org/viewtopic.php?id=242686

The solution provided in the last post might help you. Make sure to backup the mentioned folders prior to removing them (especially the ~/.local directory).

2 Likes

Thank you for the quick reply and the reminder to back up what I delete or change. I will let everyone know if this is the solution.

1 Like

Something I just noticed about the suggested command in the page I linked: you don't need to run the command using sudo, either run it without sudo or remove the folders using your file manager.
(remember to backup the folders :slightly_smiling_face:)

1 Like

Very good advice about the backup @bill_t I did delete them using the File Manager after backing them up and was very glad because I had to restore them. But I am also sad to report that none of the fixes on that page or the links provided worked. I also noticed that I cannot open the settings for the network either. I will continue to Google and Cruise the Arch and Manjaro forums and if I do find a solution the fine folks here will be the first to know. Thank you all.

1 Like

I heard if the language and local not set in gnome that could cause issues. But it might be different problem.

Thank you for your input. I have checked in Manjaro Settings everything is set to English. Without being able to open the Gnome Settings. I used this command in a terminal.

[inkrypted@VOXX ~]$ locale -a
C
en_US.utf8
POSIX
[inkrypted@VOXX ~]$

So it looks like everything is set correctly.

This solution worked for me. I opened File Manager as root with gksudo nautilus in terminal and went to usr/share/applications and copied the file gnome-wifi-panel.desktop and then opened a second instance of File Manager as a regular user and enabled show hidden files and pasted it into .local/share/applications then set show hidden files to off again and closed all the open windows and now Gnome Settings has no problem at all it launches from the icon or terminal and taskbar. :grinning: I want to thank everyone in the forum who looked in and gave advice. I hope this also helps others with this issue who use the Gnome desktop.

2 Likes

The funny thing is that none of my desktop machines use wireless. :laughing:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.