GNOME screenlocking issues after update

gnome
update

#1

After update (August, not sure when exactly) I started having issues with lock screen on GNOME.

When I lock the screen the side panel stays on, although you cannot use it, and after you log in the desktop is messed up as shown in the pictures bellow.

I haven’t made any changes to the theme. And as you can see, this is not the default manjaro there.
Also next to Menu, there is “Activities”.
The side panel doesn’t work properly too and sometimes fails to show newly launched applications.

Another issue is when i close the lid on my laptop, which should lock the screen and enter sleep mode.
It does go into sleep mode, but doesn’t lock the screen properly. Upon waking the screen is in some failed locked mode or something, where it is not really locked, you can still see everything, but it’s still unusable. It’s not frozen, the icon react to cursor and are animated, but then nothings happen.

I thought it’ll get fixed by next update or the next one, but it has been ongoing issue for past few months. Anybody had similar issue or any ideas how to resolve it?
Or what should i check to discover what when wrong?


#2

This looks like a theme issue, that doesn’t follow the new GDM+Gnome-Shell …
My suggestion is to:
sudo pacman -R manjaro-gdm-18.0-theme-dev manjaro-gdm-theme
sudo pacman -S gnome-shell
reboot and see if things got better.


#3

Ok, I removed the GDM theme, but it didn’t help. Still having the same issue.


#4

In Tweaks, what theme have you set for Gnome-Shell ?


#5


#6

Hello!

I have exactly the same issue. I have tried almost everything. I removed gnome gnome-extras…and finally I took the decision of reinstalling again the OS from scratch. Today, same situation after locking.

I have checked several things and I realized that the problem have to be with Gnome Shell:

Everytime I get back from a Lock Screen User theme extension is disable and if you go to “Tweaks”, click on “Appearance” I can see an alert yellow icon next to Shell.

This started to happen after the last update to gnome 3.30.

Is there anything that we can do?


#7

You can check if this happens on Wayland or Xorg or both.
I can’t reproduce the issue.


#8

Hi!

Sorry for the delay in reply. I have been able of taking some screenshot this morning of the issue because as I said before this is happening randomly when suspending the computer. As you will see, after start again the computer from a suspension state are disable, gnome shell show an error and icon are hidden and mixed up with another theme.

I am quite sure that this is happening since the update to gnome 3.30. I am using Xorg.

Thanks!


#9

Your Shell Theme is not compatible with Gnome 3.30. You need to use a different theme that has support for Gnome 3.30.

If you have the Manjaro Gnome settings installed, you can not use the Default shell theme. You need to enable the “User Themes” extension. The Manjaro default is “Adapta-Nokto-Maia”. This is not the same as the Default Theme. This is a little bit weird. If you want the vanilla Gnome Shell theme, you need to remove the Manjaro Gnome settings package.

The override file for the default settings


Just noticed the theme on a the 18.0 live cd is “Adapta-Maia”. I’m not sure why there is a difference between the git version and the live cd.

The master branch is not the current one, it is the branch 18.0.


#10

Hi! Thanks for the reply.

Reading your answer I think that I am already using the configuration that you quoted. I have installed manjaro-gnome-settings-18.0 and I have as default “Adapta-Nokto-Maia” and enabled the “User Theme” extension.

The problem is coming after finish the suspension state. User theme extension appear as disable and default Manjaro theme missing. Is this make sense?

Thank you!


#11

It looks like the “User Themes” extension is disabled in your screenshots. If this “User Themes” extension is disabled you get the weird Default . Your screenshots look like this Default Shell Theme.

Did you tried to remove the Manjaro Gnome Settings? It overrides some other settings, but you can simply reinstall it. It might want to remove some other packages.


#12

I came to the conclusion that definitely the “User Extension” is causing the trouble. I reinstalled the entire OS from the scratch a week ago and still the issue persist.

I can try to reinstall Manjaro Gnome Settings but I think the root of the issue is coming from somewhere else.


#13

Yes, you can still got thru the journal to look for errors after the resume.

sudo journalctl -b -p3 

or p4 might show them. You can read thru the complete journal for the current boot by leaving the -p3/-p4 option out.


#14

This is the only message that I found related after Stopped target Suspend - Stopped TLP suspend/resume but I could not find nothing interested to help me to understand the issue:

gnome-shell[4117]: JS WARNING …local/share/gnome-shell/extensions/suspend-button@laserb/extension.js 202]: assignment to undeclared variable gnomeShellVersion


#15

JavaScript warning are normally not that interesting. The journal on a Gnome system is usually full of it.


#16

I can confirm on 3 laptops. My own laptop has custom theming, the other 2 laptops are simply Manjaro Gnome with default config. The symptoms are similar to what is reported above. The desktop is broken after lock or suspend. The only way to restore is to restart the shell.

EDIT: Hardware config in terms of graphic cardx. My laptop has dedicated Nvidia and PRIME is installed. The other 2 have Intel integrated graphic cards with stock free drivers from Manjaro installed.

EDIT2: It does not always happen, but most of the time. I am unsure what does or does not trigger it.


#17

From a few of my tests it seems to be the User Themes extension that comes pre-installed with Manjaro Gnome. When I deactivated it it seemed to work. Problem is, without the extension the shell looks broken.


#18

The only really good theme is the one i mentioned here:


Even the GDM binary theme can replace the original one, and has no funkiness.
The only “issue” i have with it is that some colors used are supersaturated …