Gnome on wayland for daily use?

gnome
wayland

#21

I guess its refered to the missing seperation between windows. Every application running can access every other window information and stuff like that on X.

By the way, right before after waking up from suspend to ram the lock screen was glitching bad, realy bad … wayland realy has its problems for sure.


#22

Yes. On X every Window can send und see all input. So keylocker are an easy thing. Also all windows can record the content of whatever they want. Both things are not possible on Wayland compositors


#23

Martin Stransky, Mozilla developer, is working on wayland and client-side decorations for Firefox. His repository can be found here. If you’re eager to try Wayland version of Firefox, good news: you can do it today. Two ways to go about this:

  1. flatpak (available here)
  2. build it yourself from AUR: (here)

#24

I’m definitely eager to try new things, that’s why I decided to stay in Manjaro, Arch being one of those heavy reasons.


#25

Just spent two days in GNOME 3.26 on Arch Testing. I very much like the changes from 3.24.

Wayland works a bit better than in previous iterations. It almost had me fooled, until I started wondering why some things did not work, then realized I had logged into a Wayland session. Logging into an X session straightened them all out, though. :wink:

But I’m glad Wayland is more secure. Especially when using it on a non-functional desktop. :wink:


#26

May I ask which things you noticed not working?


#27

The first one brought to my attention was single-click not working in Nautilus. The second was an interminable delay in multimedia keys. There were others, and I would assume some are hardware-specific, but I have an extremely generic system where everything works–and works well–with Linux, specifically Arch.

Some will probably be fixed in Arch Testing before they ever trickle down 4 more levels to Manjaro Stable, I would also assume. There are reasons it is still in Arch Testing. There are still quite a few former-GNOME users in Arch that are somewhat “gun shy” after 3.20/3.22/3.24 releases.

regards


#28

10++years of development needs to be ported to a new infrastructure. That’s not done in a few years. Most important is that you can use gnome Wayland on a daily basis and from there more and more developer will iron out things. And I think gnome is already at this point, and plasma follows next year.


#29

Edit – wrong assumption; Sorry. That problem was caused by /tmp beeing bursting full :persevere:


#30

Woah. How did that get past the testers?


#31

It is still in Arch Testing, so it has not.


#32

It was in gnome-unstable before that, about a week before it made it to testing. I’ve been using it since it entered testing and I never noticed the issue you had with Nautilus. Mouse 4 and 5 don’t function as back and forward if experimental views are enabled, bit that’s another issue.


#33

Individual hardware issues aside, I like the expanded Control Center settings and other ‘nods’ to user-demands. I’ll probably tweak my multimedia issues when it hits stable and use it as my DE for a while. I’ve never found a better DE for work-flow with minimal keyboard/mouse switching. I very much dislike needing to take my right hand from the mouse to use the keyboard, or for unneeded mouse-clicking.

regards


#34

I’ve assigned mouse side buttons to alt+[L,R] arrow, now I can enjoy the new experimental views too. My biggest peeve with 3.26 was improved tiling didn’t make it to the release.

Edit:
https://feaneron.com/2017/10/03/improved-half-tiling-available-in-mutter-3-26-1/

Well then. :+1:


#35

At last, I finished the last important job and I was able to install manjaro gnome 17.1-pre1.

I did change in the custom.conf file from false to true and restarted but it seems it’s not working.

WaylandEnable=true

[chazy@chazy-pc ~]$ echo $XDG_SESSION_TYPE
x11
[chazy@chazy-pc ~]$ ps -a | grep wayland
[chazy@chazy-pc ~]$

I did update and restart before enabling wayland, then restarted again.

Any idea why is not working?

Thanks.


#36

Wayland is a display server protocol, not a display server. Mutter, Gnome’s X WM and Wayland Compositor should be running. I assume the configuration you did did work. Try looking for an X server instead.


#37

Ok, and how do I do that? I’d like to know why it still says I’m running X11 and Xorg:

$ ps -a
  PID TTY          TIME CMD
  919 tty2     00:02:33 Xorg
  933 tty2     00:00:00 gnome-session-b
  986 tty2     00:07:13 gnome-shell
 1089 tty2     00:00:00 gsd-mouse
 1090 tty2     00:00:00 gsd-power
 1094 tty2     00:00:00 gsd-print-notif
 1095 tty2     00:00:00 gsd-rfkill
 1098 tty2     00:00:00 gsd-screensaver
 1099 tty2     00:00:00 gsd-sharing
 1105 tty2     00:00:00 gsd-smartcard
 1112 tty2     00:00:00 gsd-wacom
 1113 tty2     00:00:00 gsd-xsettings
 1116 tty2     00:00:00 gsd-sound
 1126 tty2     00:00:00 gsd-a11y-keyboa
 1128 tty2     00:00:00 gsd-a11y-settin
 1129 tty2     00:00:00 gsd-clipboard
 1132 tty2     00:00:00 gsd-color
 1133 tty2     00:00:00 gsd-datetime
 1138 tty2     00:00:00 gsd-housekeepin
 1142 tty2     00:00:00 gsd-keyboard
 1143 tty2     00:00:00 gsd-media-keys
 1155 tty2     00:00:00 gsd-printer
 1179 tty2     00:00:00 gsd-disk-utilit
 1191 tty2     00:00:01 nautilus-deskto
 1645 tty2     00:00:14 firefox
 1706 tty2     00:00:20 Web Content
 1790 pts/0    00:00:00 ps

#38

Just a very stupid thing, did you choose the wayland session on the login? when you change WaylandEnable=true it does not automatically become the default choice, you need to select it manually, at least o the first boot.

I was suffering from this yesterday myself, hence I thought could be helpful :slight_smile:


#39

You mean when you sign in, there’s a wheel with 3 options (Gnome, Gnome Classic and Gnome on Xorg)?

The thing is when I first sign in it works ok, but now after reading your message, I did log out to make sure the first option was the selected one and it was, but this time it did not sign in: after typing the password and pressing enter is just goes back again to the sign in screen, the second time it does work ok. Maybe is trying to start a wayland session but for some reason it cannot and it reverts to a xorg one?


#40

That exactly what I meant.

When you were on xorg (with WaylandEnable=false) the Gnome option under the wheel(gear) corresponds to Xorg, when you change to WaylandEnable=true Gnome corresponds to gnome on wayland and the Gnome on Xorg to xorg.

but after the change (at least in my case) although the Gnome option was the first one it logged in to xorg and after logging out and manually selecting the Gnome version it logged in on wayland. and afterwards it automatically logs in into wayland (already 1-2 days, with numerous restarts).

so yeah, if it fails to login, that could be there is a problem with wayland on your machine and it fails to initiate and reverts back to xorg. I can’t help much on this topic, maybe you can try to gnome classic as well, just to be sure that it can select the sessions and maybe try different kernel, Idk.