Gnome login loop

Ever since the most recent stable update (2020-10-01) I’ve been having a login loop problem on my gnome install. When I put my password in on the GDM screen the screen goes black for a moment and then returns to the login screen. Some things I’ve discovered:

  • I can TTY around it and login there and then start gnone just fine with startx (though it crashes if I let the laptop go to sleep).
  • I can create a new user, the login for which works fine (but I don’t want to port over all my settings, etc.).
  • I can login just fine if I switch to Wayland (though I don’t like using Wayland for various reasons).

So, it seems to be something to do with xorg and it must involve some user files somehow. I’ve found a bunch of stuff on gnome login loops, but nothing that’s solved it. I’ve tried reinstalling GDM to no effect. Any help?

1 Like

Usually when this happens, the best first step is to log in to console, disable all gnome extensions from command line, and then log in through gdm. Then re-enable your extensions one by one.

1 Like

Thanks. What’s the command for that? I did a search and found:

gsettings set disable-user-extensions true

I tried that but got a “No such schema” response.

Edit: actually, I think it worked the first time I ran it, since I just logged in under Wayland to turn all the extensions off via the Extensions app, and they were all turned off already. Unfortunately, logging in through xorg still doesn’t work.

One option is to reset all jour gnome settings by renaming ~/.config/dconf/user and restarting the session. Based on the new user account working, this should likely work, But you need to manually do all youru configurations again.

Another option is to hunt down the actual error you are getting and fixing it. You can read the logs with

journalctl /usr/bin/gnome-shell
journalctl /usr/bin/gnome-session
less /var/log/Xorg.0.log
1 Like


I had the same problem this summer, I ended up doing a new installation which resulted in … the same problem (so no extensions). Since the August update I didn’t have this problem anymore. It came back once last night, I had to restart the computer to open my session.

The only solution I found before the August update was to change the connection manager or the drivers (I usually use bumbleebe).

I never found the original problem :frowning: