Gnome is overriding my keymap

Hey people,

I’ve just installed Manjaro GNOME and I’m trying to set my RightAlt key to RightCtrl, as I always do.
I normally put this in my /etc/X11/xorg.conf.d/00-keyboard.conf:
# Read and parsed by systemd-localed. It’s probably wise not to edit this file
# manually too freely.
Section “InputClass”
Identifier “system-keyboard”
MatchIsKeyboard “on”
Option “XkbLayout” “us”
Option “XkbModel” “pc105”
Option “XkbVariant” “altgr-intl”
Option “XkbOptions” “ctrl:ralt_rctrl”

But it seems like Gnome is overriding this configuration. Then I open the Gnome tweaks tool and go to Keyboard and Mouse - Additional layouts options. And it seems like every XkbOptions is there except for the one I want… What could I do?
Thanks a lot on advance!


on XFCE you have to set “Use system defaults” in Keyboard settings. Maybe there is something similar on Gnome?

1 Like

Hey man, thanks a lot for the answer. Unfortunately, there’s nothing like this in Gnome, which is strange.

I am not 100% sure that Xorg options works when you run GNOME in Wayland.

What I do, is to set up USER level Xkb options at ~/.config/environment.d/xkb-options.conf

# Set keyboard layout  My example

So try something like


Then it wont affect other users + you will not have these settings work during GDM logins (which you might not care since you put only password)

P.S. relogin to take effect