Gnome Files, typing "smb://" in "Connect to Server" becomes red

Yesterday, I installed the “minimal version” of Manjaro Gnome that says “Minimal provides a basic desktop environment with no additional software packages pre-installed.”

If I run “Files”, click “Other Locations” and then start to type smb: in “Connect to Server”, the input text becomes red, and “Connect” does not get enabled. Typing other protocols like ftp:// does not show the same symptoms. I have tried manually installing “samba” and the “nautilus sharing” extension, but it did not fix the problem.

I probably need to install something that was not included in the “minimal” version, but I am not sure what. Files version 41.2, Gnome version 41.3. Everything is up to date.

Aren’t those to share from your Gnome to other machines? :slight_smile:
You need smbclient package i guess …

I just checked it ,and smbclient was already installed. Is there anything else that I need to install?

Ok, so what happens if you type the username and ip for the smb you want to connect to?

Or whatever port you might have enabled (if you have custom settings for your samba server).

Check this

and another helpful one

The ID address had no effect. As I said, Files seemed to think that there is a problem with the smb protocol itself, because as soon as I typed smb:, the text became red.

Anyway, I clicked one of your links and found that it was using “gvfs-smb”. I checked it and it was not installed. I installed it and restarted Files; no change. I rebooted the system, and then smb worked. In short, I think this is all caused by the absence of “gvfs-smb” in the “minimal version”. I wish Files were a little bit smarter and told the user to install it (or automatically install it) instead of only turning the address red, when it could not use smb.

1 Like

I had the same issue and this also helped for me. Thanks!

I had the same error on debian and the missing lib was “gvfs-backends”