Gnome-control-center empty categories

Some tabs of the gnome control center are empty since the upgrade to gnome 42.
I’ve tried some fixes and waited a couple updates, but the problem still remains.



The three categories are Network, Bluetooth and Appearance, shown above.

Here’s my system info:

System:
  Kernel: 5.15.49-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    Console: pty pts/0 Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: 20TA002CSP v: ThinkPad E14 Gen 2
    serial: <filter>
  Mobo: LENOVO model: 20TA002CSP v: SDK0J40697 WIN serial: <filter>
    UEFI: LENOVO v: R1EET47W(1.47 ) date: 01/21/2022
Battery:
  ID-1: BAT0 charge: 39.4 Wh (94.7%) condition: 41.6/45.0 Wh (92.5%)
    volts: 12.2 min: 11.1 model: Sunwoda 5B10X025 status: not charging
CPU:
  Info: quad core model: 11th Gen Intel Core i5-1135G7 bits: 64 type: MT MCP
    arch: Tiger Lake rev: 1 cache: L1: 320 KiB L2: 5 MiB L3: 8 MiB
  Speed (MHz): avg: 958 high: 1145 min/max: 400/4200 cores: 1: 734 2: 691
    3: 1010 4: 1145 5: 1117 6: 1081 7: 831 8: 1057 bogomips: 38720
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Lenovo
    driver: i915 v: kernel arch: Gen12.1 bus-ID: 00:02.0
  Device-2: Chicony Integrated Camera type: USB driver: uvcvideo
    bus-ID: 3-8:2
  Display: server: X.Org v: 22.1.2 with: Xwayland v: 22.1.2 driver: X:
    loaded: modesetting gpu: i915 resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 22.1.2
    direct render: Yes
Audio:
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Lenovo
    driver: sof-audio-pci-intel-tgl bus-ID: 00:1f.3
  Sound Server-1: ALSA v: k5.15.49-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.52 running: yes
Network:
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 00:14.3
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel port: 3000 bus-ID: 04:00.0
  IF: enp4s0 state: down mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
Bluetooth:
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-10:4
  Report: bt-adapter ID: hci0 rfk-id: 2 state: down
    bt-service: enabled,running rfk-block: hardware: no software: no
    address: <filter>
Drives:
  Local Storage: total: 1.14 TiB used: 607.53 GiB (51.9%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 1TB
    size: 931.51 GiB temp: 42.9 C
  ID-2: /dev/nvme1n1 vendor: Lenovo model: UMIS RPJTJ256MEE1OWX
    size: 238.47 GiB temp: 30.9 C
Partition:
  ID-1: / size: 86.27 GiB used: 61.78 GiB (71.6%) fs: ext4
    dev: /dev/nvme1n1p5
  ID-2: /boot/efi size: 259.8 MiB used: 45 MiB (17.3%) fs: vfat
    dev: /dev/nvme1n1p1
Swap:
  ID-1: swap-1 type: partition size: 7.81 GiB used: 0 KiB (0.0%)
    dev: /dev/nvme1n1p7
Sensors:
  System Temperatures: cpu: 49.0 C mobo: N/A
  Fan Speeds (RPM): fan-1: 0
Info:
  Processes: 301 Uptime: 6m Memory: 31.06 GiB used: 3.33 GiB (10.7%)
  Init: systemd Compilers: gcc: 12.1.0 clang: 13.0.1 Packages: 1829
  Shell: Zsh v: 5.9 inxi: 3.3.19

Gnome-shell --version gives 42.2

Things I’ve tried so far:
Reinstall gnome-control-center.
Install gnome-control-center-x11-scaling just in case, but nothing changed, so I reverted back to the original package.
Set the color scheme to default with:
gsettings set org.gnome.desktop.interface color-scheme default
Reset the desktop config with dconf:
dconf reset -f /org/gnome/

At this point I’m out of ideas.

Can you try running it in verbose mode?

gnome-control-center network --verbose

Did you switch between branches?

Try this command:

env XDG_CURRENT_DESKTOP=GNOME gnome-control-center

A GNOME desktop already has that variable set:

❯ echo $XDG_CURRENT_DESKTOP
GNOME

Thans for the reply, here’s what I got:

(gnome-control-center:19905): Gtk-WARNING **: 23:05:54.859: Unknown key gtk-button-images in /home/octo/.config/gtk-4.0/settings.ini

(gnome-control-center:19905): Gtk-WARNING **: 23:05:54.859: Unknown key gtk-menu-images in /home/octo/.config/gtk-4.0/settings.ini

(gnome-control-center:19905): Gtk-WARNING **: 23:05:54.859: Unknown key gtk-toolbar-style in /home/octo/.config/gtk-4.0/settings.ini

(gnome-control-center:19905): Gtk-WARNING **: 23:05:54.865: Theme parser error: gtk.css:4053:1-2: Expected a valid selector

(gnome-control-center:19905): Gtk-CRITICAL **: 23:05:55.074: Error building template class 'CcBackgroundPanel' for an instance of type 'CcBackgroundPanel': .:0:0 Invalid property: AdwPreferencesGroup.header-suffix

(gnome-control-center:19905): background-cc-panel-CRITICAL **: 23:05:55.076: cc_background_preview_set_item: assertion 'CC_IS_BACKGROUND_PREVIEW (self)' failed

(gnome-control-center:19905): background-cc-panel-CRITICAL **: 23:05:55.076: cc_background_preview_set_item: assertion 'CC_IS_BACKGROUND_PREVIEW (self)' failed

(gnome-control-center:19905): Gtk-CRITICAL **: 23:05:55.076: gtk_toggle_button_set_active: assertion 'GTK_IS_TOGGLE_BUTTON (toggle_button)' failed
23:05:55.0209                    (null):    DEBUG: No extra argument
(gnome-control-center:19905): dconf-DEBUG: 23:05:55.209: change_fast
(gnome-control-center:19905): dconf-DEBUG: 23:05:55.209: change_notify: /org/gnome/control-center/last-panel

(gnome-control-center:19905): Gtk-CRITICAL **: 23:05:55.210: Error building template class 'CcNetworkPanel' for an instance of type 'CcNetworkPanel': .:0:0 Invalid property: AdwPreferencesGroup.header-suffix
(gnome-control-center:19905): dconf-DEBUG: 23:05:55.214: watch_fast: "/system/proxy/" (establishing: 0, active: 0)
(gnome-control-center:19905): dconf-DEBUG: 23:05:55.215: watch_fast: "/system/proxy/http/" (establishing: 0, active: 0)
(gnome-control-center:19905): dconf-DEBUG: 23:05:55.215: watch_fast: "/system/proxy/https/" (establishing: 0, active: 0)
(gnome-control-center:19905): dconf-DEBUG: 23:05:55.215: watch_fast: "/system/proxy/ftp/" (establishing: 0, active: 0)
(gnome-control-center:19905): dconf-DEBUG: 23:05:55.215: watch_fast: "/system/proxy/socks/" (establishing: 0, active: 0)
(gnome-control-center:19905): dconf-DEBUG: 23:05:55.215: change_fast
23:05:55.0215                       Gtk: CRITICAL: gtk_box_append: assertion 'GTK_IS_BOX (box)' failed
(gnome-control-center:19905): dconf-DEBUG: 23:05:55.215: watch_established: "/system/proxy/" (establishing: 1)
(gnome-control-center:19905): dconf-DEBUG: 23:05:55.215: watch_established: "/system/proxy/http/" (establishing: 1)
(gnome-control-center:19905): dconf-DEBUG: 23:05:55.215: watch_established: "/system/proxy/https/" (establishing: 1)
(gnome-control-center:19905): dconf-DEBUG: 23:05:55.215: watch_established: "/system/proxy/ftp/" (establishing: 1)
(gnome-control-center:19905): dconf-DEBUG: 23:05:55.215: watch_established: "/system/proxy/socks/" (establishing: 1)
23:05:55.0216          network-cc-panel:    DEBUG: add 802-11-wireless/NMRemoteConnection remote connection: /org/freedesktop/NetworkManager/Settings/1
23:05:55.0216          network-cc-panel:    DEBUG: add 802-11-wireless/NMRemoteConnection remote connection: /org/freedesktop/NetworkManager/Settings/2
23:05:55.0216          network-cc-panel:    DEBUG: add 802-11-wireless/NMRemoteConnection remote connection: /org/freedesktop/NetworkManager/Settings/3
23:05:55.0216          network-cc-panel:    DEBUG: add 802-11-wireless/NMRemoteConnection remote connection: /org/freedesktop/NetworkManager/Settings/4
23:05:55.0216          network-cc-panel:    DEBUG: add 802-11-wireless/NMRemoteConnection remote connection: /org/freedesktop/NetworkManager/Settings/5
23:05:55.0216          network-cc-panel:    DEBUG: add 802-11-wireless/NMRemoteConnection remote connection: /org/freedesktop/NetworkManager/Settings/6
23:05:55.0216          network-cc-panel:    DEBUG: add 802-11-wireless/NMRemoteConnection remote connection: /org/freedesktop/NetworkManager/Settings/7
23:05:55.0216          network-cc-panel:    DEBUG: add 802-3-ethernet/NMRemoteConnection remote connection: /org/freedesktop/NetworkManager/Settings/8
23:05:55.0216          network-cc-panel:    DEBUG: add 802-11-wireless/NMRemoteConnection remote connection: /org/freedesktop/NetworkManager/Settings/9
23:05:55.0216          network-cc-panel:    DEBUG: add 802-11-wireless/NMRemoteConnection remote connection: /org/freedesktop/NetworkManager/Settings/10
23:05:55.0216          network-cc-panel:    DEBUG: add 802-11-wireless/NMRemoteConnection remote connection: /org/freedesktop/NetworkManager/Settings/11
23:05:55.0216          network-cc-panel:    DEBUG: add 802-11-wireless/NMRemoteConnection remote connection: /org/freedesktop/NetworkManager/Settings/12
23:05:55.0216          network-cc-panel:    DEBUG: add 802-11-wireless/NMRemoteConnection remote connection: /org/freedesktop/NetworkManager/Settings/13
23:05:55.0216          network-cc-panel:    DEBUG: add 802-11-wireless/NMRemoteConnection remote connection: /org/freedesktop/NetworkManager/Settings/14
23:05:55.0216          network-cc-panel:    DEBUG: add 802-11-wireless/NMRemoteConnection remote connection: /org/freedesktop/NetworkManager/Settings/15
23:05:55.0216          network-cc-panel:    DEBUG: Calling handle_argv() after cold-plugging connections
23:05:55.0216          network-cc-panel:    DEBUG: Invoked with operation (null)
23:05:55.0216          network-cc-panel:    DEBUG: Calling handle_argv() after setting property
23:05:55.0216          network-cc-panel:    DEBUG: coldplugging devices
23:05:55.0216          network-cc-panel:    DEBUG: New device added
23:05:55.0216          network-cc-panel:    DEBUG: New device added
23:05:55.0217          network-cc-panel:    DEBUG: device /sys/devices/pci0000:00/0000:00:1c.2/0000:04:00.0/net/enp4s0 type 1 path /org/freedesktop/NetworkManager/Devices/2

(gnome-control-center:19905): Gtk-CRITICAL **: 23:05:55.217: Error building template class 'NetDeviceEthernet' for an instance of type 'NetDeviceEthernet': .:0:0 Invalid property: NetDeviceEthernet.header-suffix
23:05:55.0217                       Gtk: CRITICAL: gtk_widget_set_sensitive: assertion 'GTK_IS_WIDGET (widget)' failed
23:05:55.0217                       Gtk: CRITICAL: gtk_switch_set_active: assertion 'GTK_IS_SWITCH (self)' failed
23:05:55.0217                   Adwaita: CRITICAL: adw_preferences_row_set_title: assertion 'ADW_IS_PREFERENCES_ROW (self)' failed
23:05:55.0217                       Gtk: CRITICAL: gtk_widget_get_first_child: assertion 'GTK_IS_WIDGET (widget)' failed
23:05:55.0218                       Gtk: CRITICAL: gtk_stack_set_visible_child: assertion 'GTK_IS_STACK (stack)' failed
23:05:55.0218              GLib-GObject: CRITICAL: g_object_set_data: assertion 'G_IS_OBJECT (object)' failed
23:05:55.0218              GLib-GObject: CRITICAL: g_object_set_data: assertion 'G_IS_OBJECT (object)' failed
23:05:55.0218                       Gtk: CRITICAL: gtk_widget_set_visible: assertion 'GTK_IS_WIDGET (widget)' failed
23:05:55.0218                       Gtk: CRITICAL: gtk_box_append: assertion 'GTK_IS_BOX (box)' failed
23:05:55.0218          network-cc-panel:    DEBUG: New device added
23:05:55.0218          network-cc-panel:    DEBUG: device /sys/devices/pci0000:00/0000:00:14.3/net/wlp0s20f3 type 2 path /org/freedesktop/NetworkManager/Devices/3
23:05:55.0218          network-cc-panel:    DEBUG: New device added
23:05:55.0218          network-cc-panel:    DEBUG: device /sys/devices/virtual/net/virbr0 type 13 path /org/freedesktop/NetworkManager/Devices/4
23:05:55.0218          network-cc-panel:    DEBUG: New device added
23:05:55.0218          network-cc-panel:    DEBUG: device /virtual/device/placeholder/5 type 30 path /org/freedesktop/NetworkManager/Devices/5
23:05:55.0218          network-cc-panel:    DEBUG: Calling handle_argv() after cold-plugging devices
23:05:55.0218                 cc-window:    DEBUG: Time to open panel 'Network': 0,008671s
23:05:55.0218                 cc-window:    DEBUG: Added 'background' to the previous panels
23:05:55.0221      diagnostics-cc-panel:    DEBUG: ABRT vanished
23:05:56.0383                       Gdk: CRITICAL: gdk_scroll_event_get_direction: assertion 'GDK_IS_EVENT_TYPE (event, GDK_SCROLL)' failed
23:05:56.0491                       Gdk: CRITICAL: gdk_scroll_event_get_direction: assertion 'GDK_IS_EVENT (event)' failed
23:05:56.0809                       Gdk: CRITICAL: gdk_scroll_event_get_direction: assertion 'GDK_IS_EVENT_TYPE (event, GDK_SCROLL)' failed
23:05:56.0889                       Gdk: CRITICAL: gdk_scroll_event_get_direction: assertion 'GDK_IS_EVENT (event)' failed

Looks like you modified this file:

Revert your modifications…

I didn’t change anything there by hand, so I don’t really know what should I revert to. Here’s what I got in that file:

[Settings]
gtk-application-prefer-dark-theme=0
gtk-button-images=true
gtk-cursor-theme-name=Vimix-dark
gtk-cursor-theme-size=24
gtk-decoration-layout=icon:minimize,maximize,close
gtk-enable-animations=true
gtk-font-name=Noto Sans,  10
gtk-icon-theme-name=Tela-circle-dark
gtk-menu-images=true
gtk-primary-button-warps-slider=false
gtk-theme-name=Breeze
gtk-toolbar-style=3

I also tried to delete all contents from that file (except for the line [Settings]) and restarted the machine, but nothing changed.
When launching the command gnome-control-center network --verbose I got the following (no more “unknown key” errors)

(gnome-control-center:23178): Gtk-WARNING **: 23:25:53.362: Theme parser error: gtk.css:4053:1-2: Expected a valid selector

(gnome-control-center:23178): Gtk-CRITICAL **: 23:25:53.541: Error building template class 'CcNetworkPanel' for an instance of type 'CcNetworkPanel': .:0:0 Invalid property: AdwPreferencesGroup.header-suffix

(gnome-control-center:23178): Gtk-CRITICAL **: 23:25:53.545: gtk_box_append: assertion 'GTK_IS_BOX (box)' failed
23:25:53.0711          network-cc-panel:    DEBUG: coldplugging devices
23:25:53.0711          network-cc-panel:    DEBUG: New device added
23:25:53.0711          network-cc-panel:    DEBUG: New device added
23:25:53.0711          network-cc-panel:    DEBUG: device /sys/devices/pci0000:00/0000:00:1c.2/0000:04:00.0/net/enp4s0 type 1 path /org/freedesktop/NetworkManager/Devices/2

(gnome-control-center:23178): Gtk-CRITICAL **: 23:25:53.712: Error building template class 'NetDeviceEthernet' for an instance of type 'NetDeviceEthernet': .:0:0 Invalid property: NetDeviceEthernet.header-suffix
23:25:53.0712                       Gtk: CRITICAL: gtk_widget_set_sensitive: assertion 'GTK_IS_WIDGET (widget)' failed
23:25:53.0712                       Gtk: CRITICAL: gtk_switch_set_active: assertion 'GTK_IS_SWITCH (self)' failed
23:25:53.0712                   Adwaita: CRITICAL: adw_preferences_row_set_title: assertion 'ADW_IS_PREFERENCES_ROW (self)' failed
23:25:53.0712                       Gtk: CRITICAL: gtk_widget_get_first_child: assertion 'GTK_IS_WIDGET (widget)' failed
23:25:53.0712                       Gtk: CRITICAL: gtk_stack_set_visible_child: assertion 'GTK_IS_STACK (stack)' failed
23:25:53.0712              GLib-GObject: CRITICAL: g_object_set_data: assertion 'G_IS_OBJECT (object)' failed
23:25:53.0712              GLib-GObject: CRITICAL: g_object_set_data: assertion 'G_IS_OBJECT (object)' failed
23:25:53.0712                       Gtk: CRITICAL: gtk_widget_set_visible: assertion 'GTK_IS_WIDGET (widget)' failed
23:25:53.0712                       Gtk: CRITICAL: gtk_box_append: assertion 'GTK_IS_BOX (box)' failed
23:25:53.0712          network-cc-panel:    DEBUG: New device added
23:25:53.0712          network-cc-panel:    DEBUG: device /sys/devices/pci0000:00/0000:00:14.3/net/wlp0s20f3 type 2 path /org/freedesktop/NetworkManager/Devices/3
23:25:53.0712          network-cc-panel:    DEBUG: New device added
23:25:53.0712          network-cc-panel:    DEBUG: device /sys/devices/virtual/net/virbr0 type 13 path /org/freedesktop/NetworkManager/Devices/4
23:25:53.0712          network-cc-panel:    DEBUG: New device added
23:25:53.0712          network-cc-panel:    DEBUG: device /virtual/device/placeholder/5 type 30 path /org/freedesktop/NetworkManager/Devices/5
23:25:53.0712          network-cc-panel:    DEBUG: Calling handle_argv() after cold-plugging devices
23:25:53.0718                    (null):    DEBUG: No extra argument
23:25:53.0718          network-cc-panel:    DEBUG: Invoked with operation (null)
23:25:53.0718          network-cc-panel:    DEBUG: Calling handle_argv() after setting property
23:25:53.0721      diagnostics-cc-panel:    DEBUG: ABRT vanished
23:25:55.0286                       Gdk: CRITICAL: gdk_scroll_event_get_direction: assertion 'GDK_IS_EVENT_TYPE (event, GDK_SCROLL)' failed
23:25:55.0353                       Gdk: CRITICAL: gdk_scroll_event_get_direction: assertion 'GDK_IS_EVENT (event)' failed
(gnome-control-center:23178): dconf-DEBUG: 23:25:55.968: change_fast
(gnome-control-center:23178): dconf-DEBUG: 23:25:55.973: unwatch_fast: "/org/gnome/control-center/" (active: 1, establishing: 0)
(gnome-control-center:23178): dconf-DEBUG: 23:25:55.974: sync
23:25:55.0974         cc-object-storage:    DEBUG: Destroying cached objects

[EDIT]

Maybe it has something to do with the gtk.css file? It’s got a lot of stuff in there. :face_with_spiral_eyes:

Looks like related to this one: Appearance page is blank due to a libadwaita API error (#1876) · Issues · GNOME / Settings · GitLab

Do you have an old libadwaita library installed? Did you install it from the AUR? Looks like there were custom themes enabled…

1 Like

Then you may have installed a custom theme that does. Backup ~/.config/gtk-4.0/, remove that folder then try again.

I checked it out and found out that I had libadwaita-git from the AUR installed.
Replaced it with libadwaita and the problem got solved. Thanks!!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.