Gnome clipboard issue

Hi everybody,

I'm on stable.
Anybody experiencing some fairly recent clipboard issues with gnome (1:3.34.1+5+g072a9a484-1)?
I have had difficulties with it, mostly under libreoffice or under office 2010 (wine), where I had to copy several time before a paste would work (which is very annoying when you have to scroll through files).

Somebody found a potential workaround but I have not tried it yet since it involves patching mutter: https://bugs.archlinux.org/task/63881#comment182271
Cheers,

Nobody else is experiencing this bug? I have it on two computers.
The bug persists with the new mutter update: 3.34.1+52+g403d8fcc6-1

I also can't paste via ctrl-c and after ctrl-v but not happen frequently. When this happen i use copyq cache... I m waiting for a gnome patch but seem not working for now. I won't disable clipboard feature by default how suggested in the arch bug report but maybe i need to do in Manjaro? Or maybe join in the party at gnome repo to ask what happen? :thinking:

The bug seems to have been reported elsewhere:


https://bugs.launchpad.net/ubuntu/+source/mutter/+bug/1852183

We should maybe join those groups.
I'll install copyq in the meanwhile.
Thanks!

Please check if the new mutter in unstable work.. for me yes now
Patched with a new MR in mutter's repo

1 Like

I have tested it, fairly rapidly, and it worked like a charm!
Wonderful. Thank you.
Which patch / commit did you apply?

:wink:

I have same issue on a latest stable version of Manjaro. Could you please guys explain how to fix this for noob?

1 Like

Bump, this problem still exists after last stable update. Any fix for this? This issue appears on my both computers, this is super annoying.

This problem was resolved for me by the installation of a new patched version of mutter. I currently have 3.34.2-1, the same version as in stable. They should be the same.
@Ste74 are you experiencing issues again? Is the version in stable the correct patched one?
Cheers,

For me all is ok same version..

Hello. Bug persists in my case. I'm keeping the system up-to-date as per pamac's notifications. I'm using:

LibreOffice
Version: 6.3.4.2.0+
Build ID: 6.3.4-2
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3;
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threadedVersion: 6.3.4.2.0+
Build ID: 6.3.4-2
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3;
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

mutter 3.34.3-1 (stable).

Are there any updates on this bug? Or any solutions? Where can I find the patched version?
I would greatly appreciate any help or information, since I am working a lot on LibreOffice. Thank you.

My issue is actually back with ms office under wine (I do not know about LO, although I would love using it instead!).
I also use mutter 3.34.3-1.
@Ste74 any ideas?

I apologize for bumping this thread again, but I'm really out of my depths on this one and it's not a minor issue either (Libreoffice Writer is an important application for anyone who's working for many hours on documents each day).

I did see an update for mutter (3.34.3+14+g59e9b073a-1), I was hopeful that this would have been a patch solving the issue, but unfortunately nothing has changed.

I have been prompted to install a newer kernel, too. Currently using 4.19.99-1 (LTS and recommended). Is there a possibility that a newer kernel would make a difference?

If there is a way around this problem, or a patch, I do not know how to proceed in making those kinds of modifications to my system. If there is any relevant documentation that I could read, I would appreciate it if someone could show me to a link.

Lastly, it may be useful to note that this issue did not exist when I first installed Manjaro 6 months ago.

Thank you and I wish to hear from someone more knowledgeable about this soon.

Edit: I tried using copyQ as d7rk mentioned to see if it is any better, but it makes the task way more time-consuming.
The copy-paste problem inside a LibreOffice Writer instance persists and essentially what I experience (even with copyQ uninstalled) is that the only way I can successfully paste a text is if I double-copy, meaning that I copy once and then one more time. Only then it appears to be "remembered" by clipboard.

@Ste74 (for notification)
It is indeed a fairly major problem into my work flow too. I suspect (many occurrences) that it even causes ms office apps in wine / crossover to crash.
As it is a gnome issue (most presumably), it should be reported upstream. Have you done so?

No, I haven't. What do you mean by "upstream" exactly? Could you direct me?

Honestly not .. if i m not wrong i think already users or gnome dev report this regression and tag the issue for the next Major Gnome release to solve ... Need to recheck..

1 Like

I had a quick look at the commits on gitlab but did not see anything (but it is fairly technical for me).
The latest version (3.34.3+30+g4959ae8bc-1), obtained today on stable, does not seem to solve the problem.

However, checking the bugs on gitlab, specifically :


which has been closed but has two recent commits (a few days ago): https://gitlab.gnome.org/GNOME/mutter/commit/2fbbf657d51f14bdcb75c045637e6ebf4df10063
and https://gitlab.gnome.org/GNOME/mutter/commit/0e0dae2774512ae0b0827a54df37dd0dd349eda5
Could it be possible to make those changes?

There is also https://gitlab.gnome.org/GNOME/mutter/issues/824
(opened) which I believe I have experienced as well.

I have also seen your action: https://gitlab.gnome.org/GNOME/mutter/merge_requests/939#note_649176 . Was this patch integrated into the newer versions?

Check if mutter-3.34.3+33+g2235629d2-0.1solve issue

After some testing with ms office 2010 and 365, it seems to work!
I will report after more testing on Monday.
Thanks a bunch! Do you know what did/might have done it?

Forum kindly sponsored by