GNOME apps taking forever to load

I am plagued with this issue where GNOME apps are taking forever to load, and I don’t know why it’s taking as long as it is to launch apps. If I launch gnome-calculator it takes about 30 seconds to load, this is too long just to open up a calculator , and it’s not just the calculator, it’s literally any GNOME app taking about 30 seconds to open.

I timed how long it takes to open up gnome-calculator and it takes about 27.183s, and file-roller takes about 28.368s to launch, this shouldn’t be normal to launch an application in such time. I can open Galculator and it only takes 1.754s to open in comparison, and it’s not even a GNOME application.

I currently use Cinnamon desktop, and it’s with LightDM. I don’t get any errors showing in Terminal when I launch these applications or when I close them, but something is making these applications open so slow when it really shouldn’t. CPU and RAM aren’t being maxed out when they’re started.

When all apps on a system is affected you have either configuration issue or a theme issue - or both.

Starting an application from the terminal often provide useful info about the application start - info which is not provided when launching using a desktop file.

I don’t think it is a configuration issue, or a theme issue, since this is only affecting GNOME apps, everything else that isn’t a GNOME app launch as soon as they’re called to launch.

I have searched around for answers to this issue, and it appears to be a common GNOME issue, and it’s supposedly an issue around one of the system service issue with GNOME because it’s trying to reach out to the Internet before launching. Which first of all, why would it need to do that in order to run? and second when launched from Terminal there are no errors printed to screen, so that’s out of the question. And thirdly how am I supposed to know what service with GNOME apps is being called when an GNOME app is being launched?

When you say Gnome apps - I assume are you referring the GTK toolkit and therefore I assume that Qt based applications does not exhibit the delay e.g. Manjaro Settings Manager?

If you are using a custom theme - switch to default theme.

If you are using a custom repo in pacman.conf - disable the repo by commenting the lines - then save the file

sudo nano /etc/pacman.conf

If you are using custom packages - create a list for later referral

pacman -Qqem > ~/custom-pkgs.txt

Then use the list to remove them

sudo pacman -Rns - < ~/custompkgs.txt

Do a full update of your system

sudo pacman-mirrors -c Global && sudo pacman -Syyu

Create a test user with a password

sudo useradd -mU test
sudo passwd test

Reboot and login with the test user


Test your system and comment on the result.