Gnome 42 - Workspace overview is gone

Since Gnome 42, the workspaces section is gone from the activities overview (press the “Super” key or hit “Activities” in the top-left corner) when the option “dynamic workspaces” is enabled:

I used to be able to drag a window from the overview to an empty workspace. This isn’t possible anymore.

Before I can move a window to a workspace, I have to go to the next free workspace first (Super+Alt+Right or scroll whell in the activities overview). But even that isn’t enough. I also have to open a new window on that workspace.
Only after doing all that the workspaces overview is back and can start moving windows between workspaces:

Is this a bug and where should this be reported?

I’ve read both first posts of the linked threads, but these posts seem to describe different problems?

“Activities overview missing” is about the open windows missing (which do work on my system, check my screenshots):

whenever I press super or the Activities hot corner, I can see the top bar, the workspaces thumbnails, and the dock at the bottom of my screen, however apart from that it just shows a grey screen and my windows are missing.

So the problem I have seems to be working fine for the user from the first linked thread (“I can see […] the workspaces thumbnails”).

The first post of the second linked thread is about the app icons not showing up in the activities overview, while what I’m observing is the absence of the workspaces overview (see my screenshots).

What connection do you see in these threads to the missing workspace overview?

Looks like this an unwanted feature…
Pressing “Super-key” results in “your first picture”
Pressing the "nine-dots results in “your second picture”.
Dangerous tool (?) ==> dconf-Editor (enter workspace as a search-item)

Why do you think it’s a feature? I haven’t seen this in the announcements for Gnome 42.

Pressing the "nine-dots results in “your second picture”.

What is the nine-dots?

I’ve looked into all dconf options that have the workspace in their name, but I didn’t find anything related to this behavior.
The weird thing is that only the dynamic workspace mode is affected by this. With a static workspace count, the workspace overview is always there.

Symbol “Applications”

(Tested on x-org and wayland) dconf-editor:
Looks similar to what you want?
I can move windows to other workspace then,
how to switch: superkey plus mousewheel…

in Gnome “Settings” → Multitasking there is a “warning”
“Dynamic Workspaces (removes empty workspaces automatic)”
Therefor dynamic workspaces are not usable at time…

Looks similar to what you want?

Alright, you’re talking about the app overview (Super+A). Functionally, it’s different because that just shows the workspace overview and not your open windows, so you can’t move a specific window to a workspace:

This shows the app overview. While this view does show the workspace overview, you cannot move a specific window like Thunderbird to the empty workspace, because the CLion window is visually blocking it like in the screenshot.

Before Gnome 42, I was able to press super and drag any open window to a new workspace in the workspace overview in dynamic mode, like this:

With Gnome 42, this is only possible after you have moved a window to a second workspace.

If this is intended as a feature with Gnome 42, it’s rendering the interaction with workspaces and open apps inconsistent because people have to remember different interaction mechanics depending on the amount of workspaces with open windows on them. Is there a feature ticket where this has been tracked as a deliberate design decision?

If this is a bug, is this something the Manjaro devs could report so it has more credibility to the Gnome devs?

The issue you linked to describes a different bug: moving a window to the next workspace via a key command simply fails in “dynamic mode” if the current workspace is the last. Differently phrased, dynamic mode wasn’t ensuring the existence of at least one empty workspace. That’s all fine on my system. I can move a window to a new workspace via key commands and there’s always a new empty workspace being added when I have all workspaces filled with at least one open window.

The bug I’m experiencing is a visual bug which prevents moving a window to a new workspace graphically (via mouse) if the open windows are only on the first workspace in dynamic mode.

O.K. this is a real bug.
I can do: Superkey and move the window to the right side (using the mouse)
instead of to the workspace-window under “search” area.

I can do: Superkey and move the window to the right side (using the mouse)

Can you do this in dynamic mode with open windows only on the first workspace?

Yes, but I am on unstable repo, maybe reason?
If I do so, a third workspace is created

I installed Fedora 36 (based on Gnome 42) into a VM.
This is how the activities overview looks when the open apps are only on the first workspace (note the absence of the workspace overview):

The workspace overview is there once you have an open window on more than one workspace:

So it looks like it’s a bug in Gnome 42.

My Manjaro unstable shows the same behavior as your Fedora, I wonder…
De-aktivating gnome extensions same, works.

I see, you can move a window with the mouse to the right or left edge on your screen in activities overview. That’s rather fiddly if you have multiple screens.

It’s also leads to inconsistent interactions. Say you want to move a window to the second workspace:

  • if you’re on workspace 1, you have to drag the window to the right edge in activities overview (you can’t drag it to the second workspace because the workspace overview is missing)
  • if you’re on workspace 3, you can drag the window to the left edge (note how you have to know how your current workspace position relates to the target workspace position) in activities overview or drag it to the second workspace in the workspace overview
  • if you’re on workspace 4, you can only drag it to the second workspace in the workspace overview

No approach works for all scenarios. You have to find out and remember both interactions and apply them differently depending on the workspace number you’re currently on and the workspace number you want to drag a window to. This adds unnecessary complexity to something that used to be plain and simple.

If this is a bug, can the Manjaro devs open a bug report for the Gnome team?

Do you mean you disabled a specific extension and that fixed it? Which extension are you talking about?

Yes, if @Yochanan were present → he knows?

No, same behavior with all extension activated and all de-activated…
Same result. Gnome-Shell 42.2

Since it’s happening in multiple distributions with Gnome 42, I’ve created a bug report in their issue tracker: Workspace overview is missing in dynamic mode (#5554) · Issues · GNOME / gnome-shell · GitLab


Turns out this was a deliberate design decision by the Gnome design team. See Have a minimum of 2 workspaces, and only show the workspace switcher when there's more than 2 active workspaces (#3739) · Issues · GNOME / gnome-shell · GitLab for details.

For anyone who wants the workspace selector present all the time so that moving windows between workspaces behaves consistently, the following extension does just that and is compatible with Gnome v42: Always Show Workspace Thumbnails - GNOME Shell Extensions


@Schroedingers-Cat is a model citizen. I wish all users were this proactive when they encounter an issue. :wink:


Thanks! :slight_smile:

I wonder if the issue tracker was the best place to share feedback with the Gnome dev team? OTOH, I didn’t know this wasn’t a bug until they told me.