Gnome 40 shell overview mode: any action freezes screen for 30s

Previous versions of Gnome worked great for me, but with the latest Manjaro updates to Gnome 40, entering, leaving, or interacting with any gnome-shell functions in the Activities overview (change desktop, launch application, search, etc.) freezes the screen for 20-30 seconds. Running a system monitor shows one of the two cores pegs at 100% during the delay; mem usage is flat. Nothing from X or gnome-shell in system log.

Activating & using the dock, in or out of the overview, is fine. Changing desktops with keyboard is ok; switching via mouse while in overview mode triggers the problem. Even hovering the mouse over the app thumbnails incurs a long delay before the decorations appear.

Google search so far turns up nothing, so it seems this is peculiar to my system (Dual Pentium @ 1.8GHz, 8Gb). Is the new Gnome shell normally that cpu-bound?

I’m working around it by just avoiding the overview, but absentmindedly hitting the hot corner or the Windows key is a right pain.

Suggestions? TIA

Try disabling all extensions individually, then logout and log back in. If you cannot reproduce the issue, re-enable extensions one by one to identify the culprit.

Don’t know how to do that, exactly, but I did

gsettings set disable-user-extensions true

then logged out/in. No joy.

It definitely worked, because, with the extensions disabled, the dock was only active through the “Activities” label in the top bar. Once re-enabled, it started responding to the mouse & window focus again.

Thanks for the suggestion.

Open Extensions from the application menu and toggle each extension off.

Those two statements contradict each other. It’s not clear what resolved the issue if it was.

Oops. I meant to say that the command definitely disabled the extensions, but it didn’t resolve the problem with gnome shell. So it doesn’t seem to be an issue with any of the extensions.

Here’s a list of the installed extensions:

gsettings get enabled-extensions

['', '', '', '', '']

Just updating to say that today’s stable release seems to have largely resolved the issue. Memory use (as reported by gnome-system-monitor) is down by about half (~50% vs. 100% of 4Gb) and the overview is usable, with just a second or two lag. I can’t say if the improvement is due to Gnome 41 or simply from being stingier with memory. Memory use does jump up when I activate the overview, but it only peaks for a few seconds.

PS: Thanks so much to everyone who contributed to this!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.