Gnome 3 Crashes On Boot

With all extensions turned off, and even between both the wayland and X11 session, Gnome seems to be unable to go without crashing. On X11, the crash will usually be instantaneous while Wayland will generally allow for a few minutes of use before eventually crashing back to the login screen. The problem seems to be unique to Gnome 3 as I am able to boot into both i3 and SwayWM without any technical problems.

My current system (as screenfetch'd on my Sway Boot):

 OS: Manjaro 18.1.1 Juhraya
 Kernel: x86_64 Linux 4.19.79-1-MANJARO
 Uptime: 13m
 Packages: 1456
 Shell: bash 5.0.11
 Resolution: 1920x1080
 WM: sway
 GTK Theme: Matcha-dark-sea [GTK2], Matcha-dark-azul [GTK3]
 Icon Theme: Adwaita
 Font: Cantarell 11
 Disk: 956G / 2.9T (33%)
 CPU: Intel Core i7-4770K @ 8x 3.9GHz [38.0°C]
 GPU: Radeon RX 590 Series (POLARIS10, DRM 3.27.0, 4.19.79-1-MANJARO, LLVM 9.0.0)
 RAM: 1658MiB / 11945MiB

I'm willing to look into finding a fix to this issue, but I'm not really sure exactly where to start. So far I checked the systemctl boot services and found no errors on any of the booting services (which I imagine is good). I've been having issues with journalctl when it comes to listing out the latest output (I get logs as far back as july) and I also don't know exactly what I should be looking for.

Lastly, I haven't tried switching from GDM to LightDM -- but I can try that if people think it will get me a step closer to finding out the cause of this crash.

Thanks for any assistance. This does make for a good excuse to try out Sway for a while. :slight_smile:

Have you tried kernel 5.3?

No I haven't yet.

Would updating the kernel be a wise way of going about trouble shooting though? I've noticed that 4.19 is the last LTS recommended but I suppose updating the kernel wouldn't be a bad way of making sure it's not a kernel-level system issue.

You'll still have 4.19 to fall back to if 5.3 doesn't work out.

I've tried updating and the system still boots abnormally. Having said that, trying to boot into X twice seems to have solved my problem.

It may be a Jack issue, so I will try to disable it from booting on start and see if it helps.

Forum kindly sponsored by