[Gnome 3.36] Apps in drawer disappeared + DE crash

Hi! Gnome 3.36 update just arrived -- and right after all app icons in app drawer are gone. Plus selecting "Frequent" option now crashes DE. Reboooted multiple times in a hope that it will start working properly.
Where to start troubleshooting? Thank you in advance :wink:

sys info:

  Host: xxxxxxxx Kernel: 5.5.11-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.3.0 Desktop: Gnome 3.36.0 wm: gnome-shell dm: GDM 3.34.1 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: LENOVO product: 80YW 
  v: Lenovo Legion Y920-17IKB Laptop serial: <filter> Chassis: type: 10 
  v: Lenovo Legion Y920-17IKB Laptop serial: <filter> 
  Mobo: LENOVO model: Hades v: SDK0J40709 WIN serial: <filter> 
  UEFI [Legacy]: LENOVO v: 5KCN17WW date: 10/18/2018 
Battery:
  ID-1: BAT0 charge: 93.4 Wh condition: 96.6/90.0 Wh (107%) volts: 12.4/11.1 
  model: SMP L14M6P21 type: Li-poly serial: <filter> status: Unknown 
CPU:
  Topology: Quad Core model: Intel Core i7-7820HK bits: 64 type: MT MCP 
  arch: Kaby Lake rev: 9 L2 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 46419 
  Speed: 1495 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 2753 2: 2849 
  3: 2930 4: 2712 5: 3023 6: 2799 7: 2426 8: 2910 
Graphics:
  Device-1: NVIDIA GP104BM [GeForce GTX 1070 Mobile] vendor: Lenovo 
  driver: nvidia v: 430.64 bus ID: 01:00.0 chip ID: 10de:1be1 
  Display: x11 server: X.Org 1.20.7 driver: nvidia compositor: gnome-shell 
  resolution: 1920x1080~75Hz 
  OpenGL: renderer: GeForce GTX 1070/PCIe/SSE2 v: 4.6.0 NVIDIA 430.64 
  direct render: Yes 
Audio:
  Device-1: Intel CM238 HD Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus ID: 00:1f.3 chip ID: 8086:a171 
  Device-2: NVIDIA GP104 High Definition Audio driver: snd_hda_intel 
  v: kernel bus ID: 01:00.1 chip ID: 10de:10f0 
  Sound Server: ALSA v: k5.5.11-1-MANJARO 
Network:
  Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter 
  vendor: Bigfoot Networks driver: ath10k_pci v: kernel port: 4000 
  bus ID: 6e:00.0 chip ID: 168c:003e 
  IF: wlp110s0 state: down mac: <filter> 
  Device-2: Qualcomm Atheros Killer E2500 Gigabit Ethernet vendor: Lenovo 
  driver: alx v: kernel port: 3000 bus ID: 6f:00.0 chip ID: 1969:e0b1 
  IF: enp111s0 state: down mac: <filter> 
  Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 1-5:4 
  chip ID: 0cf3:e300 
  Device-4: Ralink MT7601U Wireless Adapter type: USB driver: mt7601u 
  bus ID: 1-6:5 chip ID: 148f:7601 serial: <filter> 
  IF: wlp0s20f0u6 state: up mac: <filter> 
  IF-ID-1: ppp0 state: unknown speed: N/A duplex: N/A mac: N/A 
Drives:
  Local Storage: total: 1.38 TiB used: 182.02 GiB (12.9%) 
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVKW512HMJP-000L2 
  size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 5L0QCXA7 
  scheme: GPT 
  ID-2: /dev/nvme1n1 vendor: Samsung model: SSD 960 EVO 500GB 
  size: 465.76 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 2B7QCXE7 
  scheme: GPT 
  ID-3: /dev/sda vendor: Western Digital model: WD10SPCX-24HWST1 
  size: 931.51 GiB speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> 
  rev: 1A02 scheme: GPT 
Partition:
  ID-1: / size: 176.56 GiB used: 38.14 GiB (21.6%) fs: ext4 
  dev: /dev/nvme1n1p1 
  ID-2: /home size: 279.89 GiB used: 143.88 GiB (51.4%) fs: ext4 
  dev: /dev/nvme1n1p2 
Sensors:
  System Temperatures: cpu: 69.5 C mobo: N/A gpu: nvidia temp: 55 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 329 Uptime: 13m Memory: 47.01 GiB used: 3.04 GiB (6.5%) 
  Init: systemd v: 244 Compilers: gcc: 9.3.0 alt: 8 Shell: bash v: 5.0.16 
  running in: gnome-terminal inxi: 3.0.37 
1 Like

I reset Gnome to default after recent update, I do prefer Gnome Adwaita dark theme more then Manjaro so I removed everything Gnome related in /Home and remove all the Manjaro gnome settings and packages, there used to be Vanilla Gnome in repo, it is still there but does not work anymore.

Disabling UserTheme extension fixed this

1 Like

I had the same issue. I specifically had to disable dash-to-dock in Gnome Tweaks

It did not solve for me.

Disabling Appfolders Management extension solved it for me.

Forum kindly sponsored by