[GNOME 3.34.3] Unable to Lock: lock was blocked by an application

Hello Everyone,

I have two machines.. Both running Manjaro Gnome and one of them will not lock. Get an error saying "Unable to Lock: lock was blocked by an application". Even more to the point, in settings->Privacy->Screen Lock everything is greyed out and cannot make any modifications. Attaching screenshots
DeepinScreenshot_Navigator_20200125090218
And also, on the top right drop down, the lock screen icon is gone. See attached:
DeepinScreenshot_select-area_20200125090119
Thanks for any help.
Axel

inxi -Fxxxza

System:
  Host: axel-linux Kernel: 5.5.0-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.2.0 
  Desktop: Gnome 3.34.3 wm: gnome-shell dm: GDM 3.34.1 Distro: Manjaro Linux 
Machine:
  Type: Desktop System: Gigabyte product: X570 I AORUS PRO WIFI v: -CF 
  serial: <filter> 
  Mobo: Gigabyte model: X570 I AORUS PRO WIFI v: x.x serial: <filter> 
  UEFI: American Megatrends v: F11 date: 12/06/2019 
CPU:
  Topology: 12-Core model: AMD Ryzen 9 3900X bits: 64 type: MT MCP arch: Zen 
  family: 17 (23) model-id: 71 (113) stepping: N/A microcode: 8701013 
  L2 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 182126 
  Speed: 4436 MHz min/max: 2200/3800 MHz boost: enabled Core speeds (MHz): 
  1: 3446 2: 2098 3: 2196 4: 2196 5: 3243 6: 2066 7: 2029 8: 4506 9: 2003 
  10: 2005 11: 2195 12: 2196 13: 2102 14: 2195 15: 2195 16: 2195 17: 2195 
  18: 3833 19: 2029 20: 2027 21: 2195 22: 2196 23: 2221 24: 2194 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  conditional, RSB filling 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: AMD Navi 10 [Radeon RX 5700 / 5700 XT] vendor: Tul 
  driver: amdgpu v: kernel bus ID: 0b:00.0 chip ID: 1002:731f 
  Display: x11 server: X.org 1.20.7 driver: amdgpu compositor: gnome-shell 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: AMD NAVI10 (DRM 3.36.0 5.5.0-1-MANJARO LLVM 9.0.1) 
  v: 4.5 Mesa 19.3.2 direct render: Yes 
Audio:
  Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel 
  bus ID: 0b:00.1 chip ID: 1002:ab38 
  Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus ID: 0d:00.4 chip ID: 1022:1487 
  Sound Server: ALSA v: k5.5.0-1-MANJARO 
Network:
  Device-1: Intel I211 Gigabit Network vendor: Gigabyte driver: igb 
  v: 5.6.0-k port: f000 bus ID: 04:00.0 chip ID: 8086:1539 
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: f000 
  bus ID: 05:00.0 chip ID: 8086:2723 
  IF: wlp5s0 state: down mac: <filter> 
Drives:
  Local Storage: total: 9.56 TiB used: 2.04 TiB (21.4%) 
  ID-1: /dev/nvme0n1 model: Sabrent Rocket 4.0 1TB size: 931.51 GiB 
  block size: physical: 512 B logical: 512 B speed: 63.2 Gb/s lanes: 4 
  serial: <filter> rev: RKT401.1 scheme: GPT 
Partition:
  ID-1: / raw size: 896.70 GiB size: 881.63 GiB (98.32%) 
  used: 353.02 GiB (40.0%) fs: ext4 dev: /dev/dm-0 
  ID-2: swap-1 size: 34.51 GiB used: 0 KiB (0.0%) fs: swap 
  swappiness: 60 (default) cache pressure: 100 (default) dev: /dev/dm-1 
Sensors:
  System Temperatures: cpu: 50.5 C mobo: 16.8 C gpu: amdgpu temp: 42 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 0 
Info:
  Processes: 508 Uptime: 13h 58m Memory: 31.37 GiB used: 7.15 GiB (22.8%) 
  Init: systemd v: 242 Compilers: gcc: 9.2.0 Shell: bash v: 5.0.11 
  running in: gnome-terminal inxi: 3.0.37 

Maybe you just need to re-enable it
gsettings set org.gnome.desktop.lockdown disable-lock-screen 'false'
would be the terminal command.
Or if you use DConfEditor, go to /org/gnome/desktop/lockdown/disable-lock-screen and set ti to false and make it default.

gnome-screensaver-command -l
will lock the screen from terminal and if it fails it might show the error ...

Hello bogdancovaciu,

This solved it. Thank you very very much!!!!!
Regards,
Axel

1 Like

Forum kindly sponsored by