Gmic_krita_qt for Krita 3.2 installed from Manjaro repos (or other)

gmic
krita

#1

I know that many that use Krita don’t like it as appimage. Is a bit slower but is perfectly fine. Anyway, the latest Krita 3.2 installed version does not come with gmic_krita_qt enabled, and there is no way to find it. Using the ones provided by the http://gmic.eu/download.shtml (whatever build - debian or other interfaces) will not work or will display an error related to /usr/lib/libcurl.so.4: version `CURL_OPENSSL_3' not found (required by gmic_krita_qt)
The workaround is to download the Krita appimage (just for a brief time we need it) from https://krita.org/en/download/krita-desktop/
Once is downloaded it must be set as executable, but don’t open it yet. Rename your kritarc from .config folder from your home directory to something else (just to keep other settings still available - kritarc_BCK - for instance). Open krita-3.2.0-x86_64.appimage go to Settings > Configure Krita and down to G’Mic-Qt Integration. You will see a path to the binary file. Copy that path to clipboard. From Terminal do:
cp <paste the path> ~/Desktop/gmic_krita_qt
You can move it later in a safer place. Quit krita-3.2.0-x86_64.appimage , restore kritarc_BCK to kritarc. Open your installed Krita and in Settings > Configure Krita and down to G’Mic-Qt Integration set the path to where you saved gmic_krita_qt.

EDIT:
Better open the krita-3.2.0-x86_64.appimage with Ark and inside the bin folder there is the gmic_krita_qt

Another EDIT: You will have to install libpng12 from community
:slight_smile:
Done!
Happy drawing/editing/creating :slight_smile:


#2

Should this plugin come pre-installed with Krita 3.2?

Maybe contact the Arch maintainer for its inclusion.


#3

I think they separated some stuff regarding this, so Krita install doesn’t come with the plugin, only the appimage that comes directly from krita.org. The only releases G’mic has are not as good as the one that comes with the krita.appimage. Not sure how to deal with this, but is fine for me that there is a workaround (funny that initially i was complicating things so badly :smiley: )