Glitches with new Kernel? (I think) Kernel >5.4

Get colorful staggered stripes.


This is a new installation. With Kernel >5.4 . inxi with Kernel 5.9.
Everything works with Kernel 5.4.
Is there any way to fix this?

inxi -Fazy

  Kernel  5.9.16-1-MANJARO x86_64 bits  64 compiler  gcc v  10.2.1 
  parameters  BOOT_IMAGE= boot vmlinuz-5.9-x86_64 
  root=UUID=4e65ae95-a710-4770-a32c-08c9c256b5dc rw quiet 
  cryptdevice=UUID=212b9ddd-d34e-4d83-8815-b57334c7a81d luks-212b9ddd-d34e-4d83-8815-b57334c7a81d 
  root= dev mapper luks-212b9ddd-d34e-4d83-8815-b57334c7a81d apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop  Cinnamon 4.8.6 tk  GTK 3.24.24 dm  LightDM 1.30.0 
  Distro  Manjaro Linux 
  Type  Laptop System  LENOVO product  20RA001LGE v  ThinkPad E14 
  serial  <filter> Chassis  type  10 serial  <filter> 
  Mobo  LENOVO model  20RA001LGE v  SDK0J40697 WIN serial  <filter> 
  UEFI  LENOVO v  R16ET28W (1.14 ) date  09 14 2020 
  ID-1  BAT0 charge  20.2 Wh condition  43.7 45.0 Wh (97%) volts  11.2 11.1 
  model  LGC 5B10W138 type  Li-poly serial  <filter> status  Discharging 
  cycles  70 
  Info  Quad Core model  Intel Core i7-10510U bits  64 type  MT MCP 
  arch  Kaby Lake note  check family  6 model-id  8E (142) stepping  C (12) 
  microcode  DE L2 cache  8 MiB 
  flags  avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips  36812 
  Speed  900 MHz min max  400 4900 MHz Core speeds (MHz)  1  900 2  900 3  900 
  4  900 5  900 6  900 7  900 8  900 
  Vulnerabilities  Type  itlb_multihit status  KVM  VMX disabled 
  Type  l1tf status  Not affected 
  Type  mds status  Not affected 
  Type  meltdown status  Not affected 
  Type  spec_store_bypass 
  mitigation  Speculative Store Bypass disabled via prctl and seccomp 
  Type  spectre_v1 
  mitigation  usercopy swapgs barriers and __user pointer sanitization 
  Type  spectre_v2 mitigation  Enhanced IBRS, IBPB  conditional, RSB filling 
  Type  srbds mitigation  TSX disabled 
  Type  tsx_async_abort status  Not affected 
  Device-1  Intel UHD Graphics vendor  Lenovo driver  i915 v  kernel 
  bus ID  00 02.0 chip ID  8086 9b41 
  Device-2  AMD Lexa [Radeon 540X 550X 630   RX 640   E9171 MCM] 
  vendor  Lenovo driver  amdgpu v  kernel bus ID  03 00.0 chip ID  1002 6987 
  Device-3  Chicony Integrated Camera type  USB driver  uvcvideo bus ID  1-8 2 
  chip ID  04f2 b6d9 serial  <filter> 
  Display  x11 server  X.Org 1.20.10 driver  loaded  amdgpu,ati,intel 
  unloaded  modesetting alternate  fbdev,vesa display ID   0 screens  1 
  Screen-1  0 s-res  1920x1080 s-dpi  96 s-size  508x285mm (20.0x11.2") 
  s-diag  582mm (22.9") 
  Monitor-1  eDP1 res  1920x1080 hz  60 dpi  163 size  300x170mm (11.8x6.7") 
  diag  345mm (13.6") 
  OpenGL  renderer  Mesa Intel UHD Graphics (CML GT2) v  4.6 Mesa 20.3.3 
  direct render  Yes 
  Device-1  Intel vendor  Lenovo driver  snd_hda_intel v  kernel 
  alternate  snd_soc_skl,snd_sof_pci bus ID  00 1f.3 chip ID  8086 02c8 
  Sound Server  ALSA v  k5.9.16-1-MANJARO 
  Device-1  Intel Wireless-AC 9462 driver  iwlwifi v  kernel port  4000 
  bus ID  00 14.3 chip ID  8086 02f0 
  IF  wlp0s20f3 state  up mac  <filter> 
  Device-2  Realtek RTL8111 8168 8411 PCI Express Gigabit Ethernet 
  vendor  Lenovo driver  r8169 v  kernel port  2000 bus ID  04 00.0 
  chip ID  10ec 8168 
  IF  enp4s0 state  down mac  <filter> 
  Local Storage  total  2.73 TiB used  199.7 GiB (7.1%) 
  SMART Message  Unable to run smartctl. Root privileges required. 
  ID-1   dev nvme0n1 maj-min  259 0 vendor  Samsung 
  model  SSD 970 EVO Plus 1TB size  931.51 GiB block size  physical  512 B 
  logical  512 B speed  31.6 Gb s lanes  4 serial  <filter> rev  2B2QEXM7 
  temp  29.9 C 
  ID-2   dev sda maj-min  8 0 vendor  SanDisk model  SDSSDH3 2T00 
  size  1.82 TiB block size  physical  512 B logical  512 B speed  6.0 Gb s 
  serial  <filter> rev  40RL 
  ID-1    raw size  1.82 TiB size  1.79 TiB (98.38%) used  199.7 GiB (10.9%) 
  fs  ext4 dev   dev dm-0 maj-min  254 0 
  mapped  luks-212b9ddd-d34e-4d83-8815-b57334c7a81d 
  ID-2   boot efi raw size  300 MiB size  299.4 MiB (99.80%) 
  used  480 KiB (0.2%) fs  vfat dev   dev sda1 maj-min  8 1 
  Alert  No Swap data was found. 
  System Temperatures  cpu  42.0 C mobo  0.0 C gpu  amdgpu temp  37.0 C 
  Fan Speeds (RPM)  cpu  0 
  Processes  280 Uptime  N A wakeups  2 Memory  15.32 GiB 
  used  1.15 GiB (7.5%) Init  systemd v  247 Compilers  gcc  10.2.0 
  Packages  1392 pacman  1390 lib  406 flatpak  0 snap  2 Shell  Bash v  5.1.0 
  running in  gnome-terminal inxi  3.2.02

Have you tried Kernel 5.10 yet? Just to see if it works better.

I assume you mean 5.4 :slight_smile:

yes sry

Same with 5.10

I am having the same issue.
Intel Corporation Iris Plus Graphics 640

Tried logging out and back in, no help.
Sometimes rebooting completely “fixes” it, i.e. it comes back up normal.
But not predictable how, just random.

On a different machine, same kernel, when I first time boot I get the same (even before logging into i3, just lightdm).
Then I login, exit and it fixes itself.
This machine has
VGA compatible controller: Intel Corporation Device 9bca (rev 04).

In fact I created a related ticket a while ago, but not sure why there is no activity/fix for that…

Something “helped”.
After installing video-vesa driver → lightdm crashes at reboot
uninstalling video-vesa and systemctl restart lightdm
it worked suddenly. No Glitches atm.
Don’t know why. Kernel 5.11

Only when lightdm crashes and you restart the service, the gliches go away for the session.

All fine with kernel 5.12

Good I checked back in here too.
Updating to 5.12 finally seems to have addressed my own issue as well.

Currently though my screen is very lagging and even typing seems delayed.
I might try resetting my X11 conf for this

Yep resetting some of my xorg.d/20-intel.conf addressed this too. So finally I am good. At last!