Glances stopped working

My glances stopped working in my tmux after the latest stable update.

  File "/usr/lib/python3.7/site-packages/glances/__init__.py", line 109, in start
                                   mode.serve_forever()
                                                         File "/usr/lib/python3.7/site-packages/glances/standalone.py", line 144, in serve_forever
                                                                                                                                                      loop = self.__serve_forever()
                       File "/usr/lib/python3.7/site-packages/glances/standalone.py", line 114, in __serve_forever
                                                                                                                      self.stats.update()
                                                                                                                                           File "/usr/lib/python3.7/site-packages/glances/stats.py", line 222, in update
                                                              self._plugins[p].update()
                                                                                         File "/usr/lib/python3.7/site-packages/glances/plugins/glances_plugin.py", line 911, in wrapper
                              ret = fct(self, *args, **kw)
                                                            File "/usr/lib/python3.7/site-packages/glances/plugins/glances_plugin.py", line 920, in wrapper
                                                                                                                                                               ret = fct(*args, **kw)
                         File "/usr/lib/python3.7/site-packages/glances/plugins/glances_network.py", line 133, in update
                                                                                                                            netstat['is_up'] = netstatus[net].isup
    KeyError: 'enp1s0'

The above appears where Glances should be.
Looks like it could be due to python.

Any (quick) fix?

I just tried it on a ssh/screen session, works without problems.

Do you use a config in /etc or ~./config ? Because the problem seems to be relate to the network plugin and something that looks like a network device.

A quick fix might be to start glances without the network plugin.

glances --disable-plugin network
2 Likes

Yes that is it. This lap is on wireless so enp1s0 is simply wrong!
What I do not get is how it could change since I have not touched the config file for ages (actually: not at all).

In any case

glances --disable-plugin network

works just fine - thanks!

There is a Bug report that sounds very similar to your Problem

It is fixed but there is no new release yet.

1 Like

Ah! That is good news because this has to be that bug. Now it will be fixed! Meanwhile I can use your workaround. Life is good :slight_smile:


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.