GitHub Actions Custom ISO build

Recently, my two-and-a-half-year-old manjaro gnome install has been acting strangely (delayed custom shortcuts, thread errors in a program I use a lot(?!), etc.), and I have decided it’s time I should make a fresh install.

However, I want to start fresh in a way that is more put-together than what I usually do. I followed Philip Müller’s guide for creating a custom manjaro ISO using GitHub Actions. My goal is to add and remove some packages that I normally add and remove anyway, with the hope being that I have a more stable system as a result.

Unfortunately, the action I have created does not work, and it fails every time I run it. Would someone be willing to take a look at it and tell me if they can see why it’s broken?


Here is the action:
Here are the failed runs:
And here is the line in the log of the most troublesome failure:

The file I have modified to add packages to the ISO is at manjaro/gnome/Packages-Desktop

I tried removing my modified iso-profiles, and it didn’t finish this time either. What I’m doing in my action is not dissimilar from what spins do in their own github actions, so I’m really not really sure what’s going wrong.

Here is the line of the most recent failure.

The url for the release fails.
It appears you cannot upload a new release if there is previous release already uploaded.

You can try this action and change the branch to stable. It uses a date and time-stamp so the release number is not the same. Just point the action to use your custom iso-profiles repo.

Thanks for your replies, @philm and @robin0800. I tried what you suggested, and it errored at the end:
/usr/share/manjaro-tools/iso-profiles is not a valid iso profiles directory!

Could it be that something is wrong with my iso-profiles repo? I’ll scan through what I have to make sure there aren’t any glaring problems, but I don’t know if I will be able to find any.

I tried running it a second time but without my iso-profiles repo, and it failed again, seemingly right before it was about to upload the iso. It got further than it did with my iso-profiles, but it seems it couldn’t upload it to the repo’s releases page.


First failure:
Second failure (default iso-profiles):