GhostNET no longer working

Hi guys,

I got manjaro and endeavourOS in VirtualBox.
GhostNET was working fine before. Now it always throws the same error.
Tried in both manjaro and endeavourOS. Same result.
Are you able to run the script successfully?
To those of you more experienced, what is the error exactly pointing to?
What possible fixes can you recommend?

After i issue ghostnet start the internet connectivity is cut off.
When i do [anon ~]# ghostnet status
The following error Traceback is thrown.

Traceback (most recent call last):
  File "/usr/lib/python3.10/urllib/", line 1348, in do_open
    h.request(req.get_method(), req.selector,, headers,
  File "/usr/lib/python3.10/http/", line 1282, in request
    self._send_request(method, url, body, headers, encode_chunked)
  File "/usr/lib/python3.10/http/", line 1328, in _send_request
    self.endheaders(body, encode_chunked=encode_chunked)
  File "/usr/lib/python3.10/http/", line 1277, in endheaders
    self._send_output(message_body, encode_chunked=encode_chunked)
  File "/usr/lib/python3.10/http/", line 1037, in _send_output
  File "/usr/lib/python3.10/http/", line 975, in send
  File "/usr/lib/python3.10/http/", line 941, in connect
    self.sock = self._create_connection(
  File "/usr/lib/python3.10/", line 824, in create_connection
    for res in getaddrinfo(host, port, 0, SOCK_STREAM):
  File "/usr/lib/python3.10/", line 955, in getaddrinfo
    for res in _socket.getaddrinfo(host, port, family, type, proto, flags):
socket.gaierror: [Errno -3] Temporary failure in name resolution

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/bin/ghostnet", line 463, in <module>
  File "/usr/bin/ghostnet", line 446, in check
  File "/usr/bin/ghostnet", line 460, in main
  File "/usr/bin/ghostnet", line 137, in __init__
  File "/usr/bin/ghostnet", line 178, in status
  File "/usr/bin/ghostnet", line 117, in check_status
    getip = urlopen('').read()
  File "/usr/lib/python3.10/urllib/", line 216, in urlopen
    return, data, timeout)
  File "/usr/lib/python3.10/urllib/", line 519, in open
    response = self._open(req, data)
  File "/usr/lib/python3.10/urllib/", line 536, in _open
    result = self._call_chain(self.handle_open, protocol, protocol +
  File "/usr/lib/python3.10/urllib/", line 496, in _call_chain
    result = func(*args)
  File "/usr/lib/python3.10/urllib/", line 1377, in http_open
    return self.do_open(http.client.HTTPConnection, req)
  File "/usr/lib/python3.10/urllib/", line 1351, in do_open
    raise URLError(err)
urllib.error.URLError: <urlopen error [Errno -3] Temporary failure in name resolution>

DNS is not working - this can be deducted from error message - and this is why your script is failing.

Hi @linux-aarhus

Thanks for chiming in.
Yes i also understood it’s a DNS issue.

Parrot OS anonsurf works fine.
Could my ISP be blocking the script from running?
It was working before…

I don’t have a VPN service right now cos if i did i could test if it’s the ISP blocking it.

Should i analyze the script carefully and see if i can conclude what’s wrong?