Getting "unable to satisfy dependency 'gcc-libs>=13.1.1' required by megacmd"

Cannot update the megacmd package from 1.6.1-1 to 1.6.3-3 (installed from DEB_Arch_Extra) due to:

:: Starting full system upgrade...
resolving dependencies...
warning: cannot resolve "gcc-libs>=13.1.1", a dependency of "megacmd"
:: The following package cannot be upgraded due to unresolvable dependencies:

Please advise what to do in such case. Wait? Fix somehow?

Another thing that I’m having trouble to understand is why although I’m trying to install a different package, pamac still throws an error about the dependency of megacmd?

pamac install schismtracker                                                                                  ✔  23s  
==== AUTHENTICATING FOR org.manjaro.pamac.commit ====
Authentication is required to install, update, or remove packages
Synchronizing package databases...
Refreshing DEB_Arch_Extra.db...                                                                                                     
Resolving dependencies...                                                                                                           
Warning: cannot resolve "gcc-libs>=13.1.1", a dependency of "megacmd"
Error: Failed to prepare transaction:
could not satisfy dependencies:
- unable to satisfy dependency 'gcc-libs>=13.1.1' required by megacmd

Thank you for your help in advance!

You’re using a third-party repository that is not compatible with Manjaro’s own repositories in terms of package versions — and which is not supported by Manjaro — so this sort of thing is always going to be a “hit and miss”. Furthermore, the use of third-party repositories can break your system.


Your ability to build from AUR scripts may depend on your current Manjaro branch.

The same is true for packages provided by third-party repositories - like the mega repo DEB_Arch_Extra.

If you are using stable branch - switch to unstable or testing - and retry.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.