Getting stuck while trying to boot from the OpenBox Edition


#1

hi! :slight_smile:
I’m trying to boot a brand new Lenovo Ideapad 320 (AMD A9) with a usb key with Manjaro OpenBox edition.
However I always get stuck with either this error message (please forgive eventual typos):

ERROR: '/dev/disk/by-label/ ' device did not show up after 30 seconds...
Falling back to interactive prompt
You can try to fix the problem manually, log out when you're finished
sh: can't access tty; job control turned off
[roottfs]#

or (if I select “Boot: Manjaro_X86-64 openbox --class=Manjaro.x86_64 $ti” instead of “Default” (or “true” or “$d $d” at the UNetbootin stage):

end Kernel panic - not syncing: VFS: unable to mount root fs on unknown-block (2,0)

Any idea/solution?
Thanks!
:slight_smile:


#2

Yes, use Etcher or Rufus in DD mode to create the media install from iso, then do the install.


#3

thanks, having lunch stop now, I’ll come back later with an update :slight_smile:


#4

it did work, and now it boots from the usb key… unfortunately then Manjaro OpenBox is completely unresponsive from the live :frowning:
Thanks anyway for the help and having solved my original question :slight_smile:


#5

That doesn’t sound good. Did you try with free or nonfree drivers from the live media boot menu? AFAIK it should be the free. Did you disable fast boot and secure boot from BIOS, and also set the SATA operation to AHCI?


#6

I did try the free drivers, both fast and secure boots are disabled, done nothing to the the sata and unsure how it’s set. I’ll check and report later :slight_smile:
Thanks again.


#7

You can always make use of another iso with another DE. Sometimes that helps. Then gather all the information you can about your system, and open a new post so se can focus on that. :wink:


#8

ok, I’m back.
I’ve checked and yes, SATA was already set to AHCI, I’ve also tried to set it as compatible/IDE and it was quite the same.
This is how the screen looks when i booted with SATA set to IDE:


With AHCI is basically the same, pointer moves around the screen but then nothing seems to be working, or when it does it’s very very slow… in this case I’ve been able to close the “Manjaro Hello” window, then after clicking everywhere the Package Manager sort of opened (it stayed that way, no change for at least a couple of minutes, then I manually switched the laptop off).
I then booted with the Bunsenlabs live, it looks definitely better and the welcome windows opened perfectly… however the pointer is completely stuck!

The laptop is a Lenovo ideapad 320-15AST, AMD A9-9420, Radeon R5 & 8 GB Ram, 1 T HD (not SSD).

Yes, if this doesn’t work I’ll try another iso, it’s just that I’d prefer one without a de and OpenBox only (and building one from the Architect edition seems a bit too much for my skills…).

Thanks :slight_smile:


#9

back just to show how the live of Manjaro xfce edtion looks on this machine:


Sorry for Manjaro, but I’ll try my luck with Antergos now, its live seems to work fine here…


#10

That’s quite interesting.

If is not much trouble for you and you can share the inxi -Fxz so maybe @philm can identify the issue on the Manjaro install related to your hardware :slight_smile:


#11

by the way also the Cinnamon edition didn’t work.
I’ll boot once more with xfce and post the results.


#12

sorry, just realized something: how do I enter that inxi -Fxz if the screen is frozen like that?
:open_mouth:


#13

AFAIK the inxi -Fxz is available in Antergos too, and since there you don’t experience this issue with the screen, is much easier :slight_smile:


#14

eh, the usb is flashed with Manjaro now… I’ll do it but it will take a bit longer, inch’allah.


#15

command not found :frowning:


#16

Oh, probably they decided to not include it in the install media :thinking:
It can be installed tho …


#17

here we are, with the Linux Mint live.

System:
  Host: mint Kernel: 4.15.0-20-generic x86_64 bits: 64 compiler: gcc 
  v: 7.3.0 Desktop: Cinnamon 4.0.8 Distro: Linux Mint 19.1 Tessa 
  base: Ubuntu 18.04 bionic 
Machine:
  Type: Laptop System: LENOVO product: 80XV v: Lenovo ideapad 320-15AST 
  serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40700WIN serial: <filter> 
  UEFI [Legacy]: LENOVO v: 5PCN17WW date: 07/13/2017 
Battery:
  ID-1: BAT0 charge: 25.9 Wh condition: 31.2/30.6 Wh (102%) 
  model: CPT-COS L16C2PB2 status: Discharging 
CPU:
  Topology: Dual Core model: AMD A9-9420 RADEON R5 5 COMPUTE CORES 2C+3G 
  bits: 64 type: MCP arch: Excavator L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 11977 
  Speed: 1397 MHz min/max: 1400/3000 MHz Core speeds (MHz): 1: 1397 2: 1397 
Graphics:
  Device-1: AMD vendor: Lenovo driver: amdgpu v: kernel bus ID: 00:01.0 
  Display: x11 server: X.Org 1.19.6 driver: amdgpu,ati 
  unloaded: fbdev,modesetting,radeon,vesa resolution: 1366x768~60Hz 
  OpenGL: renderer: AMD STONEY (DRM 3.23.0 / 4.15.0-20-generic LLVM 6.0.0) 
  v: 4.5 Mesa 18.0.5 direct render: Yes 
Audio:
  Device-1: AMD vendor: Lenovo driver: snd_hda_intel v: kernel 
  bus ID: 00:01.1 
  Device-2: AMD vendor: Lenovo driver: snd_hda_intel v: kernel 
  bus ID: 00:09.2 
  Sound Server: ALSA v: k4.15.0-20-generic 
Network:
  Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter 
  vendor: Lenovo driver: ath10k_pci v: kernel port: 2100 bus ID: 01:00.0 
  IF: wlp1s0 state: up mac: <filter> 
  Device-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet 
  vendor: Lenovo RTL810xE driver: r8169 v: 2.3LK-NAPI port: 1000 
  bus ID: 02:00.0 
  IF: enp2s0 state: down mac: <filter> 
  Device-3: Atheros type: USB driver: btusb bus ID: 1-1.2:3 
Drives:
  Local Storage: total: 935.23 GiB used: 34.1 MiB (0.0%) 
  ID-1: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB 
  temp: 18 C 
  ID-2: /dev/sdb type: USB vendor: TDK model: Media Trans-It Drive 
  size: 3.72 GiB 
Partition:
  ID-1: / size: 3.49 GiB used: 34.1 MiB (1.0%) fs: overlay source: ERR-102 
Sensors:
  Message: No sensors data was found. Is sensors configured? 
Info:
  Processes: 186 Uptime: 2m Memory: 6.98 GiB used: 612.0 MiB (8.6%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.3.0 Shell: bash v: 4.4.19 
  inxi: 3.0.27