Getting started (Manjaro-Arm)


#1
  • What device are you using?
    RPi3B
  • What edition of Manjaro-ARM is installed? (eg minimal, server, etc.)
    [RPI2/3] Manjaro-ARM 18.05 (from 4 days ago).
    (I see that new images have appeared during the time I spent on this post.)
  • When did you last run updates and reboot?
    Never
  • What package contains the bug?
    The homepage - http://manjaro-arm.org
  • Describe the bug the best you can. What where you doing when the bug happened?
    All functionality and information needed to get started seems to be hidden under a veil of obscurity.
  1. The actual website: http://manjaro-arm.org should be more prominent and not needed to be searched for within the topics.

  2. Once this has been found, the ‘Download’ button for the Minimum.img must be working.
    [ Found another path to image at @Strit Nextcloud mentioned inside another topic.]

  3. Once downloaded, what now?
    [ I tried, as su (#)

dd if=Manaro-Arm...img of=/dev/sdx bs=4M

This seemed to have worked.]

  1. There is some talk about a script that now needs to be run to reclaim lost space on the SD card. What is the script called? Where to find?
    [Still outstanding.]

  2. I tried to login as user: manjaro , passw: manjaro. This worked. Where did I get the information? Lucky I guess.

  3. Now I am stuck.
    Cannot get the network up because ‘manjaro’ is not in the sudoers file.
    (Why is the network (ethernet cable) not up?)
    Cannot login as root because I do not know the root password.
    Cannot shutdown because of the previous two ‘bugs’.
    [Still outstanding.]

  4. Maybe more. I shall know when 6. is solved.

  • Any workarounds or known fixes?
    Please just make vital information to get started more easily available. A short description on the initial steps to perform would help a lot. Also, what is the root password? Why hide it? Anybody should, as a first step, change it in any case. The wiki has been no help, so far. I think this is where the information should be placed (the wiki), and directly referenced in the Manjaro Arm forum category where newbies like me can start-off from.
    [ I have installed Arch on my RPi3B so I have an idea on how to proceed after the minimum installation.]

#2

Thanks for the detailed report.
The image you downloaded from my nextcloud, was probably my very first image, that has quite a few errors, as you have outlined.

The download buttons on the website have been fixed. Was a symlinking error.

We use the same passwords as the regular manjaro versions does for the users. So that’s manjaro for the manjaro user and root for the root user. These should be changed when you are in the system.

Network not working, is indeed a serious error. Which is also fixed in the new test images in the “test images” folder on Nextcloud.

The script to reclaim space on the SD card is called resize-sd but it is not working in the new releases yet. (I’m working on it)

Guides on how to install and use Manjaro-ARM is being worked on. They will be on the wiki when done.

Again, thanks for reporting. Documentation is still very early, but we will make sure it’s some of the first that gets done.