Getting output only on one specific monitor, when all three are connected

Hi everyone, my first post here. It hasn’t been awfully long since I switched to Linux at all, less than a year I think. My first distro has been the XeroLinux. I liked it, but had a couple of issues so moved to Manjaro Plasma a few months back to be able to set it up similarly and have a distro with a better support.

But the problem that made me finally move from XeroLinux to Manjaro (and which the move fixed) came back now, and just as before, I have no idea how to fix it. I run 3 monitors:
1x ASUS MG278Q - my main monitor
2x Dell U2415b - as additional monitors.

When all three are connected - I get output only on one of the Dell monitors, and it’s always the same exact one. Dells are usually connected to my PC via a single DP cable and then daisychained together, but I tried plugging in all monitors directly to the GPU and switch them around different ports and the effect is still the same, only this one specific monitor has output. When I switch to the terminal (Ctrl+alt+F2) I get output on all three monitors, and when the system is starting I can even see the splash screen on all of them, but after a few seconds I loose output on two of them.

Now as I said, I’m a fairly new Linux user and the whole NVIDIA drivers situation is still quite confusing to me, so I’m not really sure what details about the drivers, or logs, or anything I should attach to make the troubleshooting easier, but I’ll be more than happy to provide any additional information that may help.

You should try kernel 5.15 (LTS) or 6.2 (still RC). I have the same problem with kernel 6.0 and 6.1.

I tried both kernel 5.15 as well as the 6.2. Unfortunately the Plasma won’t start when I boot with any of them, I only have access to the terminal.

//EDIT: here’s my Xorg log when I try to start the KDE when on kernel 5.15 or 6.2:

[    16.638] 
X.Org X Server
X Protocol Version 11, Revision 0
[    16.638] Current Operating System: Linux base-m 5.15.94-1-MANJARO #1 SMP PREEMPT Tue Feb 14 19:45:58 UTC 2023 x86_64
[    16.638] Kernel command line: BOOT_IMAGE=/@/boot/vmlinuz-5.15-x86_64 root=UUID=d6ec74b3-b5c8-48f3-8f8e-cf6616dead93 rw rootflags=subvol=@ quiet splash udev.log_priority=3 acpi_enforce_resources=lax
[    16.638]  
[    16.638] Current version of pixman: 0.42.2
[    16.638] 	Before reporting problems, check
	to make sure that you have the latest version.
[    16.638] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    16.638] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Mar  1 21:57:30 2023
[    16.639] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    16.639] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    16.639] (==) ServerLayout "layout"
[    16.639] (**) |-->Screen "Screen0" (0)
[    16.639] (**) |   |-->Monitor "Monitor0"
[    16.639] (**) |   |-->Device "Device0"
[    16.639] (==) Automatically adding devices
[    16.639] (==) Automatically enabling devices
[    16.639] (==) Automatically adding GPU devices
[    16.639] (==) Automatically binding GPU devices
[    16.639] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    16.640] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[    16.640] 	Entry deleted from font path.
[    16.640] (WW) The directory "/usr/share/fonts/100dpi" does not exist.
[    16.640] 	Entry deleted from font path.
[    16.640] (WW) The directory "/usr/share/fonts/75dpi" does not exist.
[    16.640] 	Entry deleted from font path.
[    16.640] (==) FontPath set to:
[    16.640] (==) ModulePath set to "/usr/lib/xorg/modules"
[    16.640] (**) Extension "COMPOSITE" is enabled
[    16.640] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[    16.640] (II) Module ABI versions:
[    16.640] 	X.Org ANSI C Emulation: 0.4
[    16.640] 	X.Org Video Driver: 25.2
[    16.640] 	X.Org XInput driver : 24.4
[    16.640] 	X.Org Server Extension : 10.0
[    16.640] (++) using VT number 2

[    16.641] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_31
[    16.644] (--) PCI:*(9@0:0:0) 10de:2216:1458:404b rev 161, Mem @ 0xfb000000/16777216, 0xf800000000/17179869184, 0xfc00000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[    16.644] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    16.644] (II) LoadModule: "glx"
[    16.644] (II) Loading /usr/lib/xorg/modules/extensions/
[    16.648] (II) Module glx: vendor="X.Org Foundation"
[    16.648] 	compiled for, module version = 1.0.0
[    16.648] 	ABI class: X.Org Server Extension, version 10.0
[    16.648] (II) LoadModule: "nvidia"
[    16.648] (II) Loading /usr/lib/xorg/modules/drivers/
[    16.652] (II) Module nvidia: vendor="NVIDIA Corporation"
[    16.652] 	compiled for, module version = 1.0.0
[    16.652] 	Module class: X.Org Video Driver
[    16.652] (II) NVIDIA dlloader X Driver  525.89.02  Wed Feb  1 23:14:37 UTC 2023
[    16.652] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    16.652] (II) Loading sub module "fb"
[    16.652] (II) LoadModule: "fb"
[    16.652] (II) Module "fb" already built-in
[    16.652] (II) Loading sub module "wfb"
[    16.652] (II) LoadModule: "wfb"
[    16.652] (II) Loading /usr/lib/xorg/modules/
[    16.653] (II) Module wfb: vendor="X.Org Foundation"
[    16.653] 	compiled for, module version = 1.0.0
[    16.653] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    16.653] (II) Loading sub module "ramdac"
[    16.653] (II) LoadModule: "ramdac"
[    16.653] (II) Module "ramdac" already built-in
[    16.656] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
[    16.656] (EE) NVIDIA:     system's kernel log for additional error messages and
[    16.656] (EE) NVIDIA:     consult the NVIDIA README for details.
[    16.656] (EE) No devices detected.
[    16.656] (EE) 
Fatal server error:
[    16.656] (EE) no screens found(EE) 
[    16.656] (EE) 
Please consult the The X.Org Foundation support 
 for help. 
[    16.656] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    16.656] (EE) 
[    16.657] (EE) Server terminated with error (1). Closing log file.

That’s obviously related to nvidia. I’m sorry, but I’m using built in graphics only.
Please ask someone with nvidia knowledge.

I have managed to switch to the kernel 5.15, but it didn’t fix the issue. So I still only have output on one of my displays.

I fixed the issue. It was my Nvidia X Server configuration. I tinkered with it for a good while, managed to get all my screens working but by connecting them directly to the GPU, without daisychaining the two Dells, then daisychained them and the monitor that was the only one getting output now was the only one that the X Server had trouble recognizing. I renamed my /etc/X11/xorg.conf so that a new one got generated, but that didn’t help as well. After that I used timeshift and went back to a restore point form a few hours back, restarted and everything worked as intended somehow. Mind you, restoring form a restore point from over a month before the issue was the first thing I tried initially and it didn’t work. Case solved I guess, although I wouldn’t be able to give concrete instructions on how to fix it in the future.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.