Getting org-protocol (xdg-open) to work with i3wm

Hi,

is there somebody that has gotten emacs org-protocol to work on the Manjaro i3 Edition?

I have already spend days on this and tried all the guides I could find online, that all seem to differ slightly but none seemed to work so far, and I think listen all these steps would be more confusing than it would help. The problem appears to be with xdg-open and mimetypes and not having a desktop environment, because of using i3wm.

Just some things I tried:

  • creating an org-protocol.desktop file
  • modifying mimeapps.list
  • using xdg-mime default
  • installing perl-file-mimeinfo and trying mimeopen -d
  • invoking org-protocol from the command line, the org-capture extension, the ultimate-org-capture extension, and via javascript bookmarklet
  • calling org-protocol with varying amounts of slashes / // in the address
  • trying it with chromium (default browser) and firefox

Some results:

  • chromium doing nothing
  • chromium opening a new chromium tab
  • chromium opening a firefox tab
  • command line saying waiting for emacs but opening a firefox tab (while firefox is not the default browser) and also displaying "/usr/bin/xdg-open: line 881: x-www-browser: command not found"
  • at some point a folder called org-protocol: was created in my home directory

So at this point I'm really hoping, that somebody here has a working org-protocol configuration, specifically on Manjaro i3, at the very least by copying that, it should help me to narrow down trouble shooting, since a lot of existing guides, seem to be outdated or only work with a desktop environment.

If anyone has the same problem, I've gotten a solution to this problem on reddit:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by