Getting "failed to prepare transaction) ... nautilus-admin dependency" error


#1

Am trying to update to latest manjaro changes: executed sudo pacman -Syyu … it proceeds normally but terminates with

:: Starting full system upgrade…
warning: chrome-gnome-shell: local (20170421-1) is newer than extra (9-1)
resolving dependencies…
looking for conflicting packages…
error: failed to prepare transaction (could not satisfy dependencies)
:: nautilus-admin: installing python2-nautilus (1.2.1-2) breaks dependency ‘python-nautilus’

I can’t seem to get past this point. Thank you! I’ve tried to ignore python-nautilus in the pacman.conf file, but to no avail. I feel it best not try to remove too many things without possibly corrupting my machine. Any help will be appreciated.


#2

That’s already mentioned but its easiest to remove nautilus-admin before the update; Than the update should work, afterwards you should be able to install it again (in case you need it, if your not using “open as root” from nautilus context menu you dont need it anyhow.

At the end of that post in the update notes the exact way is described!


#3

Cannot update nautilus-admin

error: failed to prepare transaction (could not satisfy dependencies)
:: nautilus-admin: installing python2-nautilus (1.2.1-2) breaks dependency 'python-nautilus'

Solution:
Remove nautilus-admin and python2-nautilus by

sudo pacman -Rs nautilus-admin

and then install nautilus-admin again.


#4

Also, https://forum.manjaro.org/search?q=nautilus-admin


#5

Thank you all for your input. This cleared up the problems! Thanks again!


#6

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.