Getting back to Manjaro


#1

In this post, I said I was going to try to install the KDE RC3 on a new laptop my company sent me. This is a Dell Precision 5520.

To make a long story short, I tried several times to get Manjaro installed on this bad boy and failed. The RC3 failed to boot, because systemd was waiting forever for the completion of one of the LiveMedia scripts. I couldn’t get it going via either the free or non-free option (I’m using EFI boot).

I then tried the Manjaro Architect installer. That resulted in an installed system, but that also failed to boot, hanging somewhere after the kernel initialized.

So now I’m on Arch, where I could go step by step and enable things to see where the hangup was coming from. It turns out it’s got to do with the NVIDIA card in this machine. This is listed on Dell’s site as:

Nvidia Quadro M1200 w/4GB GDDR5 10

When I enabled bbswitch in Arch, it hung on boot just like Manjaro did, so I’ve uninstalled it and all the NVIDIA drivers and am running on Intel/Nouveau without bbswitch.

Right now, I could continue (and indeed, I’m currently copying all my files to the machine), but I don’t want to be on Arch; I want to be on Manjaro. Can anybody think of a way to get over to Manjaro without installing all the automatic Bumblebee stuff until this card is fully supported?

Thanks for your help!


Several users get hang during install at MHWD config
Kernel patch needed for Dell Precision 5520
#2

Current versions of architect installer let you choose your drivers with mhwd or skip driver installation entirely. There is a iso for it, and it updates the installer before launching it, so you only need to download it once.

The installer is already in somewhat usable state, but in a few weeks it should reach stable state


#3

Hi. If you can disable one of the two GPUs in computer setup utility you might be able to install Manjaro.


#4

You could also just disable mhwd with a kernel parameter to boot any manjaro iso, and manually install drivers:


#5

Thanks for your help! I’ll poke around in the Manjaro-Architect installer again (I have it on a USB, but didn’t know how to get past the automatic bbswitch stuff). Unfortunately, I don’t see a way to disable the card in the BIOS.

I’ve been following the progress of Manjaro-Architect on the other thread. When that settles down a bit (I tried it today but had problems, probably due to the de-recursion stuff that’s being done to it), I’ll give it another go.

Thanks!


#6

Tried this today and that kernel parameter doesnt work. It still hangs when booting the live USB:

 A start job is running for LiveMedia MHWD script

This just keeps counting up forever (I’ve let it go for as long as 10 minutes).


Live media without Bumblebee
#7

Downloading the release ISO now; will try again later today. Still running on Arch at the moment (still gotta get work done).


Kernel patch needed for Dell Precision 5520
#8

@Chrysostomus That advice is no good for UEFI systems. xdriver=vesa does not work, instead systemd.mask=mhwd-live.service should be used. Should probably add this to wiki somewhere as I’m the only one who seemed to figure that out(judging by search results of posts here as well as many Manjaro dev/maintainer responses). It’s very useful to avoid MHWD problems on UEFI.