Getting 4K working on OC2

xfce
xorg
odroid

#21

I tried add this lines to /boot/boot.txt and nothing.

setenv m “2160p30hz”
setenv m_bpp “24”
setenv hpd “true”


#22

Hmmm, nothing stands out to me, so I’m guessing it’s simply a matter of the resolution not being detected, a not uncommon problem with X’s no config files needed approach. Thankfully they weren’t stupid enough to eliminate config files in their entirety, so you might try creating a config file. I can’t say I’m familiar with the command you used, but to get the information the config file needs, run $ cvt 1280 1024 substitution your desired resolution of course.


#23

Seems you are not the only one with this issue:
https://archlinuxarm.org/forum/viewtopic.php?f=65&t=11511

https://forum.odroid.com/viewtopic.php?f=141&t=29370

Seems LibreELEC can do 4K on the C2. They might have some fancy trick?


#24

Today I installed clear Arch OC2 form tutorial https://archlinuxarm.org/platforms/armv8/amlogic/odroid-c2 and set 4K in boot.ini and I have 4K in console, now I will try install other stuff.


#25

Yeah. I think it’s either the DM or the DE that you used that does not support 4K resolutions.


#26

With original Arch OC2 + lightdm + xfce I have all 4K just by set in boot.ini resolution.
With Manjaro OC2 + lightdm + xfce I can’t, no boot.ini only boot.txt but without any effect, no lower and no higher only 1080.


#27

Very odd, since we get the packages used in /boot/ directly from Arch Linux ARM. We don’t alter them in any way.

Can you please run these commands then:
On Arch:

pacman -Qo /boot/boot.ini

On Manjaro:

pacman -Qo /boot/boot.txt

And give the output of each.


#28

I actually think now what the issue might be.

I switched to using the mainline aarch64 kernel on the C2, instead of the regular linux-odroid-c2 kernel that Arch uses.
So I had to switch u-boot aswell, so that might be you have a boot.ini on Arch and a boot.txt on Manjaro.


#29

Yes, but how to change resolution in boot.txt?


#30

I don’t think you do it in boot.txt.

Pretty sure it uses the GPU to get and set the resolution. I’m not sure though, I only have 1080p displays.


#31

So I think this get and set is not working with my 4K TV, it needs manual settings like in Arch boot.ini, LibreELEC also works ok with my 4K but it is only for Kodi.


#32

I tried also Armabian with kernels 4.18 and 3.16 and 4K is working only with 3.16.