Getting 4K working on OC2

xfce
xorg
odroid

#1

Hi,

I have some question, how to install xfce on minimal? I have xorg and xfce packages but startx stops with errors, unable to connect to X server…
What is missing?


Manjaro-ARM 18.09 released!
#2

The following packages are needed from the 18.09 Minimal image to get xfce working.

  • xorg-server
  • xorg-xinit
  • xfce4 (group)

Start it with startxfce4


#3

I have both but startxfce4 still same error, unable to connetc…


#4

You sure you are using the 18.09 image?


#5

yes I’m sure Minimal Edition 18.09


#6

Please verify that the following packages are installed (post output of following commands:
pacman -Q xorg-server
pacman -Q xorg-xinit
pacman -Q xf86-video-fbturbo-git

What image did you download exactly?


#7

ODROID C2 Minimal Edition 18.09


#8

xorg-server 1.20.1-1
xorg-xinit 1.4.0-3
xf86-video-fbturbo-git 199.f9a6ed7-4


#9

And you do have CLO output on the screen that’s connected?


#10

yes, I’m using it direct via hdmi.


Manjaro-ARM 18.09 released!
#11

Not quite sure then.
It’s what I needed to do, to get LXQT working on it.


#12

It looks like xorg problem not xfce, maybe something is still missing? or some modules not loading?


#13

Here’s what I install on the LXQT edition, except the device GPU driver, which is handles in the devices section.

Not really anything xorg related missing…


#14

[ 44.650] compiled for 1.20.1, module version = 0.0.2
[ 44.650] ABI class: X.Org Video Driver, version 24.0
[ 44.650] (EE) open /dev/fb0: Permission denied
[ 44.651] (WW) Falling back to old probe method for fbturbo
[ 44.651] (II) Loading sub module “fbdevhw”
[ 44.651] (II) LoadModule: “fbdevhw”
[ 44.651] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[ 44.651] (II) Module fbdevhw: vendor=“X.Org Foundation”
[ 44.651] compiled for 1.20.1, module version = 0.0.2
[ 44.651] ABI class: X.Org Video Driver, version 24.0
[ 44.651] (EE) open /dev/fb0: Permission denied
[ 44.651] (EE) No devices detected.


#15

I have some news, it start with sudo startxfce4


#16

Don’t use sudo to start the GUI directly.
Use a display manager instead.

sudo pacman -S lightdm lightdm-gtk-greeter
sudo systemctl enable lightdm
Reboot.


#17

Yes with lighdm is working ok :slight_smile:


#18

But I have another problem, I cant’t select 4K resolution, It will be hard way to get all working.


#19

I might be able to help with this, having had monitor problems of my own. Let’s see…

1• Can we get some system info (there’s a thread for that, Inxi… something like that)?
2• Anything special about the monitor? HdMI, DVI or something else?
3• Any manner of error messages?


#20
System:    Host: manjaro-arm Kernel: 4.18.5-1-MANJARO-ARM aarch64 bits: 64 Console: tty 0 Distro: Manjaro ARM 
Machine:   Type: ARM Device System: Hardkernel ODROID-C2 details: N/A serial: HKC213254DFD7813 
CPU:       Topology: Quad Core model: N/A variant: cortex-a53 bits: 64 type: MCP 
           Speed: N/A min/max: N/A Core speeds (MHz): No speed data found for 4 cores. 
Graphics:  Device-1: meson-gxbb-mali driver: N/A 
           Display: server: N/A driver: fbturbo tty: 238x67 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:     ARM: No ARM data found for this feature. 
           Sound Server: ALSA v: k4.18.5-1-MANJARO-ARM 
Network:   Device-1: meson-gx-dwmac driver: meson8b_dwmac 
           IF: eth0 state: up speed: 1000 Mbps duplex: full mac: 00:1e:xx:xx:c4:93 
Drives:    Local Storage: total: 3.71 GiB used: 2.24 GiB (60.3%) 
           ID-1: /dev/mmcblk1 model: SD04G size: 3.71 GiB 
Partition: ID-1: / size: 3.62 GiB used: 2.24 GiB (61.8%) fs: ext4 dev: /dev/mmcblk1p1 
Sensors:   Message: No sensors data was found. Is sensors configured? 
Info:      Processes: 130 Uptime: 13m Memory: 1.92 GiB used: 292.7 MiB (14.9%) Init: systemd Shell: bash 
           inxi: 3.0.21

this is 4K TV with HDMI, 4K was tested with NVIDIA graphic card and working.
About errors? I’m checking…
Now I have only one resolution available in XFCE config panel 1929x1080, no higher and no lower.