Get rid of password protection for Samba?

Hi all. I’ve installed Manjaro kde on a little htpc. But I’m running into the same problem that I had in windows: There’s some kind of password protection (that i never set up) that won’t allow me to trade files from one machine to another. It asks me for a username and password, when I go to the network folder and try to get into the other manjaro machine.

I just want to click and drag files out of that folder and onto my htpc desktop. I’ll watch the video file, then I’ll trash it. All very simple and easy and quick. Both machines are running Manjaro kde. But I need to somehow dispense with this password protection, as I do not need it. I tried just making an icon on the desktop to that folder, and it says “Access denied”. I have searched through the settings but unless I’m blind, there doesn’t appear to be any way to simply turn off the password protection. Anyone know how?

An afterthought: Please bear in mind that I’m quite new to linux so any command line instructions will need to be explained in greater detail that you normally would. Thanks!

Ok after doing some searching, I found this:

The config can be shorter:

Create unix user jonnie

useradd jonnie -s /usr/sbin/nologin

Create smbuser

smbpasswd -a jonnie

Create the Linux directory to share

mkdir /mysmbshare

Change the owner of the directory to jonnie

chown /mysmbshare jonnie


  workgroup = MyWorkGroup
  server string = Hello, use me
  security = share
  guest account = jonnie
  passdb backend = tdbsam

   path = /mysmbshare
   writable = yes
   printable = no
   public = yes

All files are owned by jonnie and everyone has rw access to the files.

Can anyone confirm if that actually works? I’m hesitant to go making all these changes, I don’t want to bork my install. I know that messing around in there without knowing what you’re doing or being sure that it won’t hurt anything, is a bad idea.

There are multiple ways of solving the same problem and this looks like a viable one.

Generic tip: If you’re unsure about something, copy the current config to a .bak file so you can still revert back.

In your specific case:

cp /etc/smb.conf /etc/smb.bak


and when editing files, have your editor create a backup file as well. E.G. sudo nano --backup /etc/smb.conf

The (newer) Samba protocol used nowerdays does not allow password-less access…
So you always need to provide username+password to be able to access files that are shared over the Samba (Windows share) protocol…

1 Like

Any way to gut out that function? I don’t that particular security layer, it’s just at my house. There’s already a password in place via my router.

[justin@Linux-Rig ~]$ useradd jonnie -s /usr/sbin/nologin
useradd: Permission denied.
useradd: cannot lock /etc/passwd; try again later.
[justin@Linux-Rig ~]$

Here’s the output from that attempt. I always feel like I’m missing the first few steps or something, when it comes to the command line. I have very little knowledge of it or how it actually works.



“user jonnie already exists”

wtf wtf what the actual f!

Manjaro likes to troll me I think

Good! Move to the next step then! (I.E.: I don’t know if you’re “jonnie”)


Yeah I was just following that guy’s guide lol! Figured I’d change it later, just copy and pasting.

Anyone happen to know what the default Samba password is? Or does it randomly generate one?

Whatever you set to be jonnie’s password will be the password.


Hopefully it won’t make me enter it each time. I’ll try it out. But man it would be cool if there was a gui for all this. Or if it was built in and you didn’t need samba

Well, then don’t use a username/password and use SMB1 and guest read/write access!

Oddly, the settings won’t stick. It just changes the selection for me when I click “Ok” at the bottom. (using kde) Makes it so as I selected that option instead.

You’re referring to opening the shared folder via the “Network” tab on the left in the Dolphin browser, correct?

Edit: Hmm, it doesn’t even accept jonnie and the password that I set via those terminal commands. The terminal said all was well, password changed or whatever. Now it just… does nothing. “Access denied”. I’m starting to wonder if somehow, my problem is KDE.

I don’t know which guide you’re following but you need this:
and then this:

Sorry, it turns out I’ve been asking the wrong question all along. But such is the fate of a newbie like me! My apologies