Genesis Seaborg 400 racing wheel not working

Yesterday I tried setting up this wheel from title, and it actually showed up in system “game controller” settings the first time, buttons were registered when pressed, but today i plug it in, it doesn’t even show at all in system settings, the lamp on wheel just lights up for few seconds and then it turns off, but still when i check LSUSB it shows “Bus 003 Device 002: ID 11ff:0511 . Wired Wheel”, i tried it on windows now and everything is ok, i also have regular gamepad from Genesis and that one works in linux normally, showing up as xbox360 controller, any help would be great…

Link to the wheel website: Seaborg 400 | Genesis

This is from dmesg when wheel is connected to usb

[ +7.294663] usb 3-2: new full-speed USB device number 6 using xhci_hcd

[ +0.159486] usb 3-2: New USB device found, idVendor=0079, idProduct=1864, bcdDevice= 1.08

[ +0.000006] usb 3-2: New USB device strings: Mfr=0, Product=2, SerialNumber=0

[ +0.000003] usb 3-2: Product: Wired Wheel

[ +0.029160] input: Wired Wheel as /devices/pci0000:00/0000:00:08.1/0000:06:00.4/usb3/3-2/3-2:1.0/0003:0079:1864.0008/input/input30

[ +0.000142] hid-generic 0003:0079:1864.0008: input,hidraw5: USB HID v1.11 Gamepad [Wired Wheel] on usb-0000:06:00.4-2/input0

[ +0.994008] usb 3-2: USB disconnect, device number 6

[ +0.330518] usb 3-2: new full-speed USB device number 7 using xhci_hcd

[ +0.165180] usb 3-2: New USB device found, idVendor=11ff, idProduct=0511, bcdDevice= 1.01

[ +0.000009] usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3

[ +0.000004] usb 3-2: Product: Wired Wheel

[ +0.000003] usb 3-2: Manufacturer: .

[ +0.000002] usb 3-2: SerialNumber: 54340000831E4C02

Well to answer my own question, it works now without any special libaries or udev rules, it seems!

  1. The reason why wheel was not powering on was some setting for TLP power management, inside /etc/tlp.conf , option “USB_AUTOSUSPEND” should be set to 0
  2. After that although it was still showing up in lsusb, it wasn’t recognized as wheel in settings, on the wheel itself there is MODE button, i randomly tried holding it down for few seconds until it blinks, then it showed as wheel in options, tried it for some windows games in Lutris, and although controls had to be set up from scratch inside the game, it works great! Finally