[gelöst]X Startet nicht / ssh key


#1

Hallo zusammen,

ich habe ssh-keys für meine Raspis eingerichtet. Irgendwo muss ich was falsch gemacht haben, denn jetzt bootet Manjaro nicht mehr richtig. Es erscheint noch der Text mit der Anzahl der Dateien und Ordner und der Mauszeiger.
Wenn ich dann mit Alt+F2 wechsle, dann kann ich meinen Nutzernamen eingeben, gefolgt von meinem Passwort, dann dauert es kurz und ich muss das Passwort für den SSH-Key eingeben. Dann kann ich mit startx weiter machen. Wie bekomme ich diese verkehrte SSH-Key Abfrage wieder weg?


#2

Scheint so, als hättest du SSH für deine lokale Maschine (localhost oder 127.0.0.1) eingerichtet, prüfe deine SSH-Konfiguration, ob du irgendwas derartiges eingetragen hast.


#3

Hallo Photon, wo soll da was sein? In /etc/ssh/ssh.config und sshd.config finde ich nichts derartiges. Eine authorized_keys File gibt es nichts und in known_hosts ist localhost nicht drin.


#4

Ich habe gehofft, du wüsstest, welche Dateien du alles bearbeitet hast. :wink:

Laut Bauchgefühl würde ich solche Konfigurationen in ~/.bashrc oder ~/.bash_profile erwarten, dort stehen Befehle, die nach dem Einloggen ausgeführt werden.


#5

:smiley: Das hoffe ich auch jedesmal, dass ich mich später noch dran erinnern kann.
Habs aber mittlerweile hinbekommen, ich habe erstmal den ssh-agent zurückgesetzt bzw. alles Keys entfernt, dann /etc/profile und .bashrc bearbeitet und die keychain.sh gelöscht. Letzteres hat das Problem verursacht bzw. war evtl. einfach von mir falsch eingerichtet…


#6

Super, dass du die Lösung so schnell finden konntest! :slight_smile: Wenn das Problem nun behoben ist, denk dran den Thread als gelöst zu markieren!


#7

Noch ein Tipp für die Zukunft, das Forum hier bietet die Option Threads als gelöst zu markieren, indem man den Checkbox-Button unter dem Post markiert, der zur Lösung geführt hat, dann muss man den Titel nicht editieren. :wink:


#8

Ah ok, danke! :smiley: