GeForce RTX 2060 Blinking Screen Problem

Hello everyone!

I just brought a new GeForce RTX 2060 (12GB VRAM) and I fresh installed the latest versions of Manjaro GNOME and KDE Plasma and I have the same problem: My screen is blinking almost all the time, making it difficult to work with.

My PC specs:

  • Intel Core i5-9600K
  • Nvidia GeForce RTX 2060 (12GB VRAM)
  • Corsair Vengeance LPX 48GB DDR4 RAM
  • Samsung 970 Evo Plus SSD 500GB M.2 NVMe PCI Express 3.0
  • Xiaomi Mi Curved 34" 4K (Screen)

Btw I’ve tried with both Proprietary & Open-Source drivers and didn’t make any difference. But what I’ve notice is that if I lower the screen Hz the blinking is reduced a lot but moving, opening, or closing windows and apps is a bit laggy… For example, with 144hz I have screen blinking while in 50hz I don’t have so much blinking but I gets kinda laggy. Any idea what may be the problem or something to try out?

Please provide the content of /etc/X11/mhwd.d/nvidia.conf

I also recommend to enable early kms with one of the methods described here

Thanks for the quick reply, it’s much appriciated!!

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 530.41.03

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"

Section "Files"

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
	Option "NoLogo" "1"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24

Section "Extensions"
    Option         "COMPOSITE" "Enable"

Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"

Edit: I’ve followed your instructions and the problem still persists.

This is not the way it should. The HorizSync and VertRefresh are missing. Might want to open Nvidia Settings and get that information, and replace the missing lines in the Section "Monitor".
Here is an example on how it looks on my end.

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "LG Electronics"
    ModelName      "LG Electronics W2253"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"

Do not use this, but the one you get on your system!

After you do that, you can try to see if things get better next reboot. If not, then i can also recommend to replace this Section in the config:

With this one:

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option         "TripleBuffer"  "On"
    Option  "ConnectToAcpid"    "Off"
    Option "metamodes" "nvidia-auto-select +0+0 {ForceFullCompositionPipeline=On}"

But also remember to enable early kms by one of the methods i mentioned in the previous comment.

I can’t find HorizonSync & VertRefresh in my NVIDIA settings. Any idea where I could find them?

Well, is not so straight forward … You go to X Server Display Configuration and make sure the values are the correct ones

Then lower that window you have some buttons. You click on Save to X Configuration File


But you are not doing so, because you click on Preview in the popup window


Make that popup window larger so you can read, and you copy the entire Section "Monitor"

Then you open up the /etc/X11/mhwd.d/nvidia.conf with Kate and paste that in place of the current Section "Monitor"

Hope this helps.

1 Like

Thank you for the detailed steps, very helpful! I followed the instructions, and while the screen flickering has been reduced a lot, it’s still happening. Is there anything else I could try?

Maybe give the ol ‘forcefullcompositionpipeline’ thing a try?

nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"

One thing that may help is making sure your monitor color is set to Native in your monitor settings menu.

@cscs I’ve followed your instructions but what it did was to lower my screen’s Hz to 50Hz from 144Hz, which doesn’t really fix the problem.

@Yochanan Just used all the different colors, modes, and changes in my Xiaomi screen and it didn’t fix the problem (I’ve also made a few restarts just to make sure).

I’ve also fresh installed the latest version of Manjaro XFCE and I get the same problem there too. Going to install KDE again, anything to try while installing it that may help? Although fresh install didn’t helped the last time.

Update: Looks like the problem on occurring with Manjaro Linux. Ubuntu, Linux Mint, Fedora, and EndeavourOS are working like a charm, with no screen flickering whatsoever. And I haven’t done any changes either. It’s such a shame I had to replace Manjaro with another Distro so I can keep working.

You never mentioned what Kernel you had installed and in use compared to the other distributions that are working …

Maybe you should have searched a little in the forum, i had created a topic related to Screen Flickering just few weeks bevor you had this issue.

All these distros use the same infrastructure for graphics. Which is basically Linux Kernel, Vendor Driver and Xorg. So it must be a configuration problem. If you installed Manjaro again and saw the problem, I suggest going on with EndeavourOS as it is also Arch based.

[edit] Try not to compromise your screen refresh rate. Keep it at the highest level possible.