Geeqie no longer works after the last update

Geeqie no longer works after the last update in a gnome desktop. Geeqie itself was not updated but probably a dependency.

  • Geeqie will start from terminal without the -r parameter and it will be usable
  • Geeqie will start when opening an image from “files” (nautilus) but will freeze immediately and can only be force closed.

While looking for a replacment for gwenview/kde on XFCE (I chose gThumb), I briefly installed Geeqie, tried it, and uninstalled it. I thought the UI was broken. Your post caught my attention, so I reinstalled. I agree with your findings regarding Geeqie. This seems to have been reported at Arch (which reported it to Geeqie, which reported it to Gnome/glib).

Fascinating.
I recommend qimgv, whilst not a full featured viewer it is blindingly fast and ideal for the default click-open image viewer.

Despite being blindingly fast it still has a context menu with some features and settings.

gThumb and gwenview are great - but more featured/heavy if you need to do more.

Yep! There are more alternatives, but nothing compares to Geeqie. Also, I will try to avoid QT5 apps in my GTK desktop. But thanks anyway for the tip.

When I searched for alternatives, Geeqie was towards the top which is why I tried it. Besides moving away from KDE, QT, and connecting to Social Media, gwenview on KDE 4 had way too many features that I never used. I might have used rotate, but the main two features I wanted was the ability to easly view resizable thumbnails (a contact sheet) and open with gimp.

What are a few of the features of Geeqie that you really like?

If the problem resides in glib2 2.66.6-1, I suppose we keep our eye on glib2 in Manjaro’s Branch compare.

Superfast browsing. Compact thumbnails. Easily open in Gimp or other. Simple modifications to images, great settings for “delete” handling. Render settings. Keyboard shortcuts (/ and *) for viewing all images scaled to either 1:1 or fit screen. Even enlarge smaller images to fit screen. Mousewheel browsing… Clean full screen by the letter f. etc etc etc…

As a temporary work around until GLIB is updated, you could modify /usr/share/appplications/geeqie.desktop and remove the -r option in de command line on line 54. You do loose some functionality when opening geeqie while it already open…

Thread not relevant anymore. Geeqie was last rebuilt on May 16, 2021. See below:

~ >>> pacman -Si geeqie                                                                                                                                                                                             
Repository      : extra
Name            : geeqie
Version         : 1.6-6
Description     : Lightweight image viewer
Architecture    : x86_64
URL             : http://www.geeqie.org/
Licenses        : GPL2
Groups          : None
Provides        : None
Depends On      : exiv2  gtk3  ffmpegthumbnailer  djvulibre  libheif  libchamplain  poppler-glib
Optional Deps   : librsvg: SVG rendering
                  fbida: for jpeg rotation
                  gawk: to use the geo-decode function
                  perl-image-exiftool: for the jpeg extraction plugin
                  gphoto2: command-line tools for various (plugin) operations
                  imagemagick: command-line tools for various (plugin) operations
Conflicts With  : None
Replaces        : None
Download Size   : 1571.40 KiB
Installed Size  : 19200.40 KiB
Packager        : Andreas Radke <andyrtr@archlinux.org>
Build Date      : Sun 16 May 2021 05:41:45 AM CDT
Validated By    : MD5 Sum  SHA-256 Sum  Signature