GDM does not display user on fresh installation of Manjaro 21.2.1 with Gnome

I have recently done the switch to Manjaro (with Gnome environment). Ever since first booting it after installation, I’ve been having this same issue where it will boot, progress past the Manjaro bootsplash and open a blank Gnome login page. I say blank because there are no options for users, even though I can still see the date and time at the top as well as other options for volume, shut down etc.

Usually around 3 times after turning the computer off and on again it will work, but I just figured out an easier workaround which is to select the option to suspend from the options that are visible on the top of the login page and then turn the computer on again, which will then show a proper login page with my user account where I can then enter my password and log in.

I’ve seen similar issues discussed on the forum being solved by opening and closing a TTY or passing certain commands on a TTY, but none of the ctrl+alt+f keys command work, thet only stop the cursor from moving until I click ctrl+alt+f1 (which I suppose is the command to exit from tty?).

I have already researched this issue throughout the forum for many hours in the last three days and tried various solutions in the past few days. My latest attempt has been to simply reinstall the OS from a live USB, but the issue is still present. Normally I would just go to a different OS because this is an extraordinary level of effort for fixing an OS I have not committed to, but I feel it is worth it, because so far I have liked all other aspects of Manjaro :slight_smile:

This is my first time posting here, so please let me know if there are additional informations I should provide to help solve this issue.

Thanks in advance

  Kernel: 5.15.12-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-5.15-x86_64
    root=UUID=f8057430-ac2b-4bcf-85ca-31153e1737bf rw rootflags=subvol=@ quiet
    splash apparmor=1 security=apparmor
    resume=UUID=5b7f731b-fe5c-4b32-b26a-946eff42a200 udev.log_priority=3
  Desktop: GNOME 41.2 tk: GTK 3.24.31 wm: gnome-shell dm: GDM 41.0
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: ASUSTeK product: X555LB v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: X555LB v: 1.0 serial: <superuser required>
    UEFI: American Megatrends v: X555LB.505 date: 08/24/2015
  ID-1: BAT0 charge: 24.8 Wh (97.6%) condition: 25.4/37.3 Wh (68.1%)
    volts: 7.5 min: 7.5 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
    status: Charging cycles: 1258
  RAM: total: 7.67 GiB used: 3.16 GiB (41.3%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i5-5200U bits: 64 type: MT MCP arch: Broadwell
    family: 6 model-id: 0x3D (61) stepping: 4 microcode: 0x2F
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1221 high: 2197 min/max: 500/2700 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 800 2: 800 3: 1090
    4: 2197 bogomips: 17580
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon
    avx avx2 bmi1 bmi2 bts clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8
    de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority
    flush_l1d fma fpu fsgsbase fxsr ht ibpb ibrs ida intel_pt invpcid
    invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe msr mtrr
    nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln
    pni popcnt pse pse36 pti pts rdrand rdseed rdtscp rep_good sdbg sep smap
    smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow
    tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xsave xsaveopt
    xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel HD Graphics 5500 vendor: ASUSTeK driver: i915 v: kernel
    bus-ID: 00:02.0 chip-ID: 8086:1616 class-ID: 0300
  Device-2: NVIDIA GM108M [GeForce 940M] vendor: ASUSTeK driver: nvidia
    v: 495.44 alternate: nouveau,nvidia_drm bus-ID: 04:00.0 chip-ID: 10de:1347
    class-ID: 0302
  Display: x11 server: compositor: gnome-shell driver:
    loaded: modesetting,nvidia unloaded: nouveau alternate: fbdev,nv,vesa
    resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel Broadwell-U Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c class-ID: 0403
  Device-2: Intel Wildcat Point-LP High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9ca0
    class-ID: 0403
  Sound Server-1: ALSA v: k5.15.12-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.42 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK driver: r8169 v: kernel port: 4000 bus-ID: 02:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  Device-2: Intel Wireless 7260 driver: iwlwifi v: kernel bus-ID: 03:00.0
    chip-ID: 8086:08b1 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-6:6 chip-ID: 8087:07dc class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 223.57 GiB used: 10.08 GiB (4.5%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37240G
    size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 0102 scheme: GPT
  Optical-1: /dev/sr0 vendor: HL-DT-ST model: DVDRAM GUC0N rev: AS01
    dev-links: cdrom
  Features: speed: 24 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  ID-1: / raw-size: 60.55 GiB size: 60.55 GiB (100.00%) used: 9.05 GiB (15.0%)
    fs: btrfs dev: /dev/sda3 maj-min: 8:3 label: N/A
    uuid: f8057430-ac2b-4bcf-85ca-31153e1737bf
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 568 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: NO_LABEL
    uuid: 43DB-4469
  ID-3: /home raw-size: 158.51 GiB size: 158.51 GiB (100.00%)
    used: 1.03 GiB (0.6%) fs: btrfs dev: /dev/sda4 maj-min: 8:4 label: N/A
    uuid: e6d907b4-3079-45ab-9ada-87add3b18099
  ID-4: /var/cache raw-size: 60.55 GiB size: 60.55 GiB (100.00%)
    used: 9.05 GiB (15.0%) fs: btrfs dev: /dev/sda3 maj-min: 8:3 label: N/A
    uuid: f8057430-ac2b-4bcf-85ca-31153e1737bf
  ID-5: /var/log raw-size: 60.55 GiB size: 60.55 GiB (100.00%)
    used: 9.05 GiB (15.0%) fs: btrfs dev: /dev/sda3 maj-min: 8:3 label: N/A
    uuid: f8057430-ac2b-4bcf-85ca-31153e1737bf
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 4 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sda2 maj-min: 8:2 label: N/A
    uuid: 5b7f731b-fe5c-4b32-b26a-946eff42a200
  ID-1: /dev/sda5 maj-min: 8:5 size: 8.6 MiB fs: <superuser required>
    label: N/A uuid: N/A
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 11 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-6:6 info: Intel Bluetooth wireless interface type: Bluetooth
    driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 8087:07dc class-ID: e001
  Device-2: 1-8:7 info: Realtek RTS5129 Card Reader Controller
    type: <vendor specific> driver: rtsx_usb,rtsx_usb_ms,rtsx_usb_sdmmc
    interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 0bda:0129
    class-ID: ff00 serial: <filter>
  Hub-2: 2-0:1 info: Super-speed hub ports: 4 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 50.0 C pch: 49.5 C mobo: N/A
  Fan Speeds (RPM): cpu: 3200
  Processes: 280 Uptime: 18m wakeups: 1 Init: systemd v: 250 tool: systemctl
  Compilers: gcc: N/A Packages: pacman: 1152 lib: 309 flatpak: 0 Shell: Zsh
  v: 5.8 running-in: gnome-terminal inxi: 3.3.11

Did you spot this post already? It sounds like there are a few people having similar problems…

It occurs to me that if ctrl+alt+F keys don’t work, it may be worth trying ctrl + alt + fn + F key – I do believe that a number of keyboards treat the function keys differently in terms of whether you press the ‘Fn’ to get F-key functions, or if that gives you other things associated with the keys like volume or brightness up/down, media playback controls, etc.

1 Like

Thanks for pointing me to that post! Yeah, it’s pretty much the same problem, going to close this post. Shame the solution to that post did not work for me as it did to OP.

As to the tty, my laptop is not one of those where you need to do fn+f key, but just in case I tried as well and it didn’t work.

I’ve decided to not mark this as resolved since the solution pointed by @lukewhite did not work on mine (for more info why that solution did not work, see my comment on that post).

I’ll also update the original post to include more information to help you help me.