Gcolor3 not picking colors

Hi everyone! I use Gcolor 3 on xfce to pick colors and it was working well but today I wasn’t able to pick anything, then i ran the program on terminal and it dropped me this:

[joser@JERO1 ~]$ gcolor3

** (gcolor3:54311): WARNING **: 12:37:30.396: Cannot count number of items: The keyfile does not have the group «Colors»


** (gcolor3:54311): WARNING **: 12:37:30.396: Cannot count number of items: The keyfile does not have the group «Colors»


** (gcolor3:54311): WARNING **: 12:58:33.231: Failed to pick color: Screenshot failed

This part was translated with google translate “The keyfile does not have the group”

Thank you very much for your time and help.

Edit 1: WPSOffice isn’t piking colors either (fails launching the tool), Gcolor2 and Gimp working as intended.
Edit 2: Flatpak version has the same behavior.

me: there is a gcolor3? :exploding_head:

Also - just tested and it works here (KDE//Unstable).

1 Like

yeah, it was working for me… until it wasn’t :smile:

I have the same messages, but it does work here. (KDE)

Except the

Failed to pick color

There are some upstream bug reports that seem to be related:

The second bug report mentions something about xdg-desktop-portal implementation, which is available only for GNOME Shell, KWin and wlroots (?).
I’m not sure if that’s the reason that the application is working under KDE.

1 Like

Here:

$ gcolor3

** (gcolor3:45981): WARNING **: 09:10:22.978: Error opening file: No such file or directory. Colors likely won't be saved, unless this is the first run

** (gcolor3:45981): WARNING **: 09:10:23.409: Cannot count number of items: Key file does not have group “Colors”


** (gcolor3:45981): WARNING **: 09:10:23.409: Cannot count number of items: Key file does not have group “Colors”

Worth noting it operated fine, and it was the first run so the first message was quite normal.

That’s why I don’t like programs tide to DE’s :confused:, should I wait for a fix or install the flatpak version?
Also I believe this is causing WPS not piking colors too.

Yeah, it was working for me and I don’t know how to fix the “color group” thing

I found the same some update ago, and since I needed a color picker, I found Picket: GitHub - rajter/picket: Native linux screen color picker with custom format output which, in my humble opinion, works much better; it also has a more magnified/bigger/precise preview where to pick a color.

PIcket2

2 Likes

Does this also happen with Gimp? After these issues, also Gimp, for me, lost the ability to pick colors.
To be more precise: with Gimp has become hit and miss; most of the time fails to pick/grab colors, not always.

No issues with Gimp or Gcolor2

As @bill_t mentioned in the links he sent, the problem seems to be in xfce and other DE’s not in KDE or Gnome.

1 Like

Thanks man. Picket looks great!