Gamma support on Gnome Wayland?


is there another way than using Night Light to set the Gamma ?

I tried other solutions but it doesn’t work (wl-gammactl or redshift-wayland).


Gammastep should work

@anon88624618: I don’t think that GammaStep can work.

Here is what I found on gammastep github

Why doesn’t this work with Wayland compositors like Mutter, KWin, Mir, and Enlightenment?

This program supports the wlroots protocol for gamma adjustments, but several Wayland compositors do not support this protocol. GNOME and KDE have their own built-in mechanisms for adjusting color temperature on Wayland.

Manjaro Gnome seems to use mutter as Wayland compositor.

1 Like

Ah, ok. What’s wrong with gnome’s built-in solution, anyway?

I would like to use another solution that night light to set the gamma but I don’t find anything else to do that under Wayland. Under xorg, I used xgamma but it doesn’t work under Wayland because it was made for xorg. And for now, I use Wayland by default.

Maybe give sway a try if you like/don’t mind tiling. It’s i3 config compatible and works fine alongside gnome and with gammastep :man_shrugging:

Are you saying Night Light isn’t working either?

You could try Gammy AUR or Clight GUI AUR.

@Yochanan: Night Light works but I don’t like it to set the gamma or adjust the temperature of the screen.

For your information, Gammy works with X11 only, and Clight require a specific compositor on Wayland. See it. And the compositor seems to need: wlr-gamma-control-unstable-v1 protocol who is not implemented in Manjaro Gnome. wl-gammactl need also this protocol.

Wl-gammactl is what I’m looking for but I can’t use it under Manjaro Gnome. I guess that Gnome/mutter doesn’t support that protocol (wlr-gamma-control-unstable-v1).


I come back to you.

I tried Gammastep but I’ve go these errors:

Error: Could not control gamma, exiting. Error: Failed to start adjustment method: wayland

Is there a way to make gammastep work on Manjaro Gnome ?


I’m afraid you’ve already answered your own question - unless you wanna run gnome under xorg…

Been trying to find a working gamma solution myself for Plasma-wayland and came up against similar issues.

I think I’ll fall back to X11 until one day someone gets the idea of building in gamma control to the desktop window manager instead of needing all these odd apps that only work if you stand on your head and jump up and down. lol

I’m using Manjaro Gnome on a 2-in-1 laptop (tablet/PC)and Wayland is more suitable than X11 for that kind of machine. Especially for autoration feature of the screen. That’s why I keep Wayland. For now, night light option seems to be the only way to set the color temperature (and so the gamma). I installed redshift-wayland from AUR (it is a version of redshift for Wayland), but it is a little complicated to set the gamma with it under Wayland.

You could create a config file for redshift and set the gamma value there. See manpages for details.

(It’s probably similar to gammastep, where the config.ini resides in ~/.config/gammastep with e.g. gamma=0.8, respectively gamma-day/gamma-night=)

I will look it later.

Unfortunately I only want to adjust gamma not color of my screen. Not interested in making screen brown or blue, just want traditional gamma controls… Back to Xorg.