Games on Manjaro - CPU Problem

I was playing csgo in deepin os for 3 months and i never had an error or crash
but i moved to manjaro & when i run it my cpu go up to 100 and the os stop working
so i need to reboot to work again any fix for that
not only csgo but also alot of games

intel x64
asus 6gb ram

System:    Kernel: 5.13.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64 root=UUID=b3e19e5b-d68b-43c0-9ac3-e9a3b8aea8c2 rw quiet apparmor=1
           security=apparmor udev.log_priority=3
           Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux
Machine:   Type: Laptop System: ASUSTeK product: X555LAB v: 1.0 serial: <superuser required>
           Mobo: ASUSTeK model: X555LAB v: 1.0 serial: <superuser required> UEFI: American Megatrends v: X555LAB.307
           date: 04/23/2015
Battery:   ID-1: BAT0 charge: 13.3 Wh (100.0%) condition: 13.3/37.3 Wh (35.7%) volts: 7.6 min: 7.6 model: ASUSTeK X555-50
           type: Li-ion serial: N/A status: Not charging cycles: 149
CPU:       Info: Dual Core model: Intel Core i5-5200U bits: 64 type: MT MCP arch: Broadwell family: 6 model-id: 3D (61)
           stepping: 4 microcode: 2F cache: L1: 128 KiB L2: 512 KiB L3: 3 MiB
           flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 17581
           Speed: 2318 MHz min/max: 500/2700 MHz Core speeds (MHz): 1: 2318 2: 2163 3: 2339 4: 2289
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable
           Type: meltdown mitigation: PTI
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
           Type: srbds mitigation: Microcode
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel HD Graphics 5500 vendor: ASUSTeK driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:1616
           class-ID: 0300
           Device-2: Realtek USB Camera type: USB driver: uvcvideo bus-ID: 1-5:3 chip-ID: 0bda:57b5 class-ID: 0e02
           serial: <filter>
           Display: x11 server: X.Org compositor: kwin_x11 driver: loaded: modesetting alternate: fbdev,vesa
           display-ID: :0 screens: 1
           Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3")
           Monitor-1: eDP-1 res: 1366x768 hz: 60 dpi: 101 size: 344x194mm (13.5x7.6") diag: 395mm (15.5")
           OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2) v: 4.6 Mesa 21.2.5 direct render: Yes
Audio:     Device-1: Intel Broadwell-U Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 00:03.0
           chip-ID: 8086:160c class-ID: 0403
           Device-2: Intel Wildcat Point-LP High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
           bus-ID: 00:1b.0 chip-ID: 8086:9ca0 class-ID: 0403
           Sound Server-1: ALSA v: k5.13.19-2-MANJARO running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 v: kernel port: e000
           bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
           IF: enp2s0 state: down mac: <filter>
           Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter vendor: AzureWave driver: ath9k v: kernel
           bus-ID: 03:00.0 chip-ID: 168c:0036 class-ID: 0280
           IF: wlp3s0 state: up mac: <filter>
Bluetooth: Device-1: IMC Networks type: USB driver: btusb v: 0.8 bus-ID: 1-6:6 chip-ID: 13d3:3423 class-ID: e001
           Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
Drives:    Local Storage: total: 476.94 GiB used: 45.51 GiB (9.5%)
           SMART Message: Unable to run smartctl. Root privileges required.
           ID-1: /dev/sda maj-min: 8:0 vendor: Kingfast model: N/A size: 476.94 GiB block-size: physical: 512 B logical: 512 B
           speed: 6.0 Gb/s type: SSD serial: <filter> rev: 8B0 scheme: GPT
Partition: ID-1: / raw-size: 476.64 GiB size: 468.09 GiB (98.21%) used: 45.51 GiB (9.7%) fs: ext4 dev: /dev/sda2 maj-min: 8:2
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 288 KiB (0.1%) fs: vfat dev: /dev/sda1
           maj-min: 8:1
Swap:      Alert: No swap data was found.
Sensors:   System Temperatures: cpu: 39.0 C pch: 36.5 C mobo: 27.8 C
           Fan Speeds (RPM): cpu: 2300
Info:      Processes: 200 Uptime: 5m wakeups: 1 Memory: 5.72 GiB used: 2.12 GiB (37.0%) Init: systemd v: 249 tool: systemctl
           Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: 1270 pacman: 1267 lib: 340 flatpak: 0 snap: 3 Shell: Zsh v: 5.8
           default: Bash v: 5.1.8 running-in: yakuake inxi: 3.3.09

Between the deepin comment and the age of your hardware and your current running kernel …
First shot is to try other LTS kernels … specifically 5.4 or maybe 5.10

And it also looks like you have a BIOS update.

And oh yeah.
Also based on the deepin comment … I wonder if they employ by default the option
Which will remove all protections for spectre and similar vulnerabilities … such security patches have been known to have possibly severe performance impact on certain hardware, especially older intels.

i have changed to 5.10 & i add mitigations=off
but i did not update the bios. is it safe to do that ?

hey man its just worked i changed to 5.4 as you said

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.