Games freeze my machine and sometimes just crash, more often hard reset needed

I did the mhwd -li and it said:

> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
    video-nvidia-435xx            2019.10.25               false            PCI


Warning: No installed USB configs!

Also trying to remove the 435xx it says:

> Removing video-nvidia-435xx...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/local/pci/video-nvidia-435xx/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
Prüfe Abhängigkeiten...
Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: Entfernen von linux419-nvidia-435xx verletzt Abhängigkeit 'linux419-nvidia-435xx', benötigt von linux-lts-nvidia-435xx
Error: pacman failed!
Error: script failed!

I have the 435.xx installed so yeah kinda makes sense that it wont let me uninstall that mhwd.

Forgot to mention: After the reinstall of the drivers i now have in other games like LoL microstuttering although they ran flawless before.

I'm kind of tired of all of that not working. Should I try to reset my whole system with a fresh install and then post back once thats done to see if everything runs? I think that would be a better way to start from then trying to figure out what exactly i destroyed in my system. What are your thoughts about this @dglt?

your drivers didnt reinstall, you have linux-lts-nvidia-435xx installed so it didnt do anything.

run these

sudo pacman -R linux-lts-nvidia-435xx
sudo mhwd -r pci video-nvidia-435xx
sudo mhwd -i pci video-nvidia-430xx

Okay will do that once im back home at sunday. Until then have a great time and thank you for the help!

1 Like

Ok so its sunday and I came back home like 20 min ago and was eager to test it out :smiley:

Sadly it didn't went so well. I was able to reinstall the drivers and then the game started without problems. But it sadly still crashes after amount x of time.

I also kept the temperatures in check, on my CPU it didnt go higher as 46°C/Core and my GPU only went up to 67°C, sometimes peaked at 69°C (mostly when there were cut szenes). So yeah i don't think its temperature related either.

I'm somewhat out of ideas what it could be. Last thing to check of wich i can think is a list of all packages that should be installed in a fresh install of manjaro. It really is the last thing i could imagine why it would crash. Before i read about what "orphan" means in pacman i just went ahead and deleted everything that popped up there until the list was empty so i can imagine that i deleted packages there wich shouldnt have been removed. Is there a way to check that?

Edit: @dglt ok im on a freshly installed system now and it still keeps hapening :expressionless:

what kernel/drivers are currently installed on this clean setup?

new setup, new outputs

inxi -Fxxxza --no-host
mhwd-kernel -li
mhwd -li
pacman -Qs nvidia

and since lockups are happening, power down > re- seat ram or move to other slots if available, do the same for the GPU. is the power supply adequate for your setup?

System:
  Kernel: 5.4.6-2-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=e4520c89-6dcf-485a-a109-81e9d724e1a8 rw quiet apparmor=1 
  security=apparmor resume=UUID=0f3b28e8-1146-4f15-a267-bd4172c699f1 
  udev.log_priority=3 
  Desktop: Xfce 4.14.1 tk: Gtk 3.24.12 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: MSI model: Z87-G45 GAMING (MS-7821) v: 1.0 
  serial: <filter> UEFI: American Megatrends v: 1.2 date: 05/17/2013 
CPU:
  Topology: Quad Core model: Intel Core i5-4670K bits: 64 type: MCP 
  arch: Haswell family: 6 model-id: 3C (60) stepping: 3 microcode: 27 
  L2 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 27215 
  Speed: 1645 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 1135 2: 1144 
  3: 1153 4: 1187 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: NVIDIA GP104 [GeForce GTX 1080] vendor: ZOTAC driver: nvidia 
  v: 418.113 bus ID: 01:00.0 chip ID: 10de:1b80 
  Display: x11 server: X.Org 1.20.6 driver: nvidia 
  resolution: 1680x1050~60Hz, 2560x1080~60Hz 
  OpenGL: renderer: GeForce GTX 1080/PCIe/SSE2 v: 4.6.0 NVIDIA 418.113 
  direct render: Yes 
Audio:
  Device-1: Intel 8 Series/C220 Series High Definition Audio 
  vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:8c20 
  Device-2: NVIDIA GP104 High Definition Audio vendor: ZOTAC 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:10f0 
  Sound Server: ALSA v: k5.4.6-2-MANJARO 
Network:
  Device-1: Qualcomm Atheros Killer E220x Gigabit Ethernet 
  vendor: Micro-Star MSI driver: alx v: kernel port: d000 bus ID: 03:00.0 
  chip ID: 1969:e091 
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 1.85 TiB used: 391.94 GiB (20.7%) 
  ID-1: /dev/sda vendor: Transcend model: TS512GSSD320 size: 476.94 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> scheme: GPT 
  ID-2: /dev/sdb vendor: Samsung model: SSD 860 PRO 1TB size: 953.87 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 1B6Q scheme: GPT 
  ID-3: /dev/sdc vendor: Samsung model: HD502IJ size: 465.76 GiB block size: 
  physical: 512 B logical: 512 B speed: 3.0 Gb/s serial: <filter> rev: 1112 
  scheme: GPT 
Partition:
  ID-1: / raw size: 467.84 GiB size: 459.50 GiB (98.22%) 
  used: 12.01 GiB (2.6%) fs: ext4 dev: /dev/sda2 
  ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap 
  swappiness: 60 (default) cache pressure: 100 (default) dev: /dev/sda3 
Sensors:
  System Temperatures: cpu: 37.0 C mobo: N/A gpu: nvidia temp: 49 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
Info:
  Processes: 232 Uptime: 2m Memory: 15.58 GiB used: 2.31 GiB (14.8%) 
  Init: systemd v: 242 Compilers: gcc: 9.2.0 Shell: bash v: 5.0.11 
  running in: xfce4-terminal inxi: 3.0.37
Currently running: 5.4.6-2-MANJARO (linux54)
The following kernels are installed in your system:
   * linux54
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
    video-nvidia-418xx            2019.10.25               false            PCI


Warning: No installed USB configs!
local/lib32-libvdpau 1.3-1
    Nvidia VDPAU library
local/lib32-nvidia-418xx-utils 418.113-1
    NVIDIA drivers utilities (32-bit)
local/libvdpau 1.3-1
    Nvidia VDPAU library
local/linux54-nvidia-418xx 418.113-9 (linux54-extramodules)
    NVIDIA drivers for linux.
local/mhwd-nvidia-340xx 340.108-1
    MHWD module-ids for nvidia 340.108
local/mhwd-nvidia-390xx 390.132-1
    MHWD module-ids for nvidia 390.132
local/mhwd-nvidia-418xx 418.113-1
    MHWD module-ids for nvidia-418xx 418.113
local/mhwd-nvidia-430xx 430.64-1
    MHWD module-ids for nvidia-430xx 430.64
local/mhwd-nvidia-435xx 435.21-1
    MHWD module-ids for nvidia 435.21
local/mhwd-nvidia-440xx 440.44-1
    MHWD module-ids for nvidia 440.44
local/nvidia-418xx-utils 418.113-1
    NVIDIA drivers utilities

Also I got it running on proton... somewhat. Without WHINEDLLOVERRIDES="dxgi=n" %command% which i found here(at the very bottom the second last post) it doesn't even start. Ingame it still crashes. I only got into the very first cut szene which was a complete mess (not synchron, laggy) and then it crashed during playing the szene right before the end of it. Sadly it completely froze my system so there was no error message :frowning:

Try Nvidia 440 on this new install

start by updating your bios, your about 7 versions behind. current is 1.9
https://www.msi.com/Motherboard/support/Z87-G45-GAMING.html

you shouldnt need this at all unless a certain game requires it to work, also you misspelled wine with an H. `

Cant that ■■■■ is bugged on my PC. If you read further into this then you will find out that their BIOS Flash is buggy as hell and fried a lot of boards. There is a way to do it with a DOS based patch but it only worked for the Version that was installed anyway on my machine.

Yeah my bad... But in the correctly written version its the only way to get the game started in Proton. When i start the game it pops a message stating : "Attention! No Display-Adapter installed. Do you wish to continue?"and if i press OK then it launches the launcher in a kind of fallback way (there are some pictures of it in the thread i linked in my post before). If i dont have the DLL override then it does absolutely nothing when i press play. If its on then it starts flawlessly. It was posted by an admin of the proton development team on that thread, so i think he was testing something out. Sadly the admin didnt comment any further on this so I'm not sure if they investigated it further and are going to apply a patch or sth.

OK will try that now. I'll edit this once I've done that and tested it. :slight_smile:

Edit 1: During uninstall of MHWD it said:

'/etc/X11/xorg.conf.d/90-mhwd.conf' symlink is invalid!

is this troublesome?

Edit 2: Still crashing with same error as before.

you dont uninstall MHWD. to switch drivers

sudo mhwd -r pci video-nvidia-418xx
sudo mhwd -r pci video-nvidia-440xx

but i dont think the drivers are your problem. you've tried other kernels? other distros behave the same? windows?

I have tried neither. Kernels yes thanks to your advices. But as you know to no success.

I don't have any other distros installed, especially not windows. I was very happy to find out that linux was finally on its way to be way better then windows and honestly so far it has been way better with Manjaro then windows.

They recommend using Ubuntu but I have had really terrible experiences with it because so many things werent preinstalled. It happend that I had to reinstall ubuntu pretty much every week because things i installed that i needed just kept crashing my distro. Even doing updates in the package manager crashed my system so yeah.

1 Like

Have you gamed on this computer before on other operating systems? Because honestly this is very weird, and given how it only happens during load, it is possible it is a hardware issue

Yes i have gamed on this setup for 6 years on windows. I only had trouble there with xcom2 but that was because of an dlc error which was confirmed by community. Also TWWH and TWWHII both worked flawless on windows.

@Danielsuarez369 @dglt:

Okay so after wanting to punch my screen multiple times because ubuntu is such a trash distro i was finally able to run that game over there. And: no luck. Still crashes.

i only asked about other distro's to rule out manjaro's configuration being the cause and it's not.

yeah, im not crazy about ubuntu/mint and both were far less stable and broke often compared to manjaro/arch. i know you have your concerns about the BIOS update, i dont understand why though. if your referring to warnings that bios updates can cause problems then thats something most bios warn of, thats no reason not to update IMO. bios updates are released on necessity to fix known issues and seeing how your 7 versions behind.... i think you get my point. :wink:

I absolutely understand your point and I'm with you on that. But its as i stated above: their BIOS update (M-Flash or what its called) literally fries boards. I also fried one of those boards, because i didnt search the internet first. Luckily it was still in warranty time so i got a new one.
There is a second way to flash the BIOS which is (also mentioned above) using a tool the community wrote to have a way to flash the BIOS. But for some weird reason I can't create a bootable FreeDOS version of any other BIOS than the one im currently using. I tried to create one of every version but yeah. It only booted on the one that is currently installed. And since that doesn't work I don't want to give M-Flash another go, because I don't have the money lying around to build a new one (it totally is a plan of mine to build a new one, but if im doing that then I'll go full scale and buy legit everything new and at high end so we talking like 2k min here).

That being said: I also believe something IS wrong with the BIOS, but it shouldn't impact the Games, since everything worked before. The reason why I think that something is wrong with the BIOS is because, i think QEMU was it, stated that it couldn't enable the hardware visualisation because the BIOS is borked (Something alon those lines). I was trying to setup a kernel based Windows VM so I could play the mentioned games. But since that didn't work I started to look for solutions, since i was sure there need to be some (since the games worked on windows).

So yeah, thats why I'm not really into upgrading my BIOS atm.

maybe they did before but what your explaining points to something more being wrong. you can try kernel parameters to tell linux how to interact with acpi, this is done on a lot of optimus laptops but i see no reason why a desktop couldnt benefit from it.

edit /etc/default/grub
copy/paste this exactly acpi_osi=! acpi_osi='Windows 2009'
on this line. make sure there is a single space between each paramter

GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_osi=! acpi_osi='Windows 2009' <other parameters>"

save/exit and sudo update-grub

also try reseating all the MB components like gpu and ram and if available move them to different slots.

Before i change sth in GRUB: The Feral Support wrote that they checked their tickets if there has been a similar problem recently and found someone with a similar problem. His got resolved by using 418.56. Is there any way to install that one? Haven't found it in repos only the 418.113 packages.

i highly doubt your problem is only resolved with a single version of the 418.xx drivers. you already tried the 418, 430, and 440 series from manjaro right?

Forum kindly sponsored by