Games are using Intel's integrated graphics instead of my dedicated AMD GPU

Hey guys I've just installed Manjaro xfce in my main rig, it has:

I7 6700
AMD Radeon Rx 480
16 gigs of ram
With a z170 mobo.

My setup is quite complicated (I think) I have 2 monitors one is using Intel's integrated graphics through mobo's VGA port and the other is using the DVI port of my rx 480.

When I first tried to launch a game CSGO performance was about 30fps and also low performance in all games, then I tried disabling the integrated GPU in the BIOS menu and then they performed as they should. Bad part is that I can't use my second monitor as usual.

Is there a way to tell the OS to use an specific GPU when running a game??
That way I could run games with my AMD card while using Intel's just for the second monitor.

Thanks in advanced, I'm kind of a newbie in the recent Linux gaming ecosystem but thanks to the community I have already solved a lot of issues I had.


Start with

$ inxi -Fxxxz

and

Important knowledge

When posting output do not use pictures. Pictures is a very last resort.

Please select the text in the terminal
Paste the text into a the post
Select the newly pasted text in the post
Click the </> icon in the post toolbar

This creates nicely formatted text which is readable and searchable for other users after you.

(Text was copied from @ linux-aarhus)

For helpful answers, just click on the heart ...
grafik

4 Likes

Try this

DRI_PRIME=1 [command]
2 Likes

And if posting pictures, please use another service instead of the forums to upload pictures. Bandwidth is costly :stuck_out_tongue:

for steam games it's

DRI_PRIME=1 %command%

in the steam launch options (%command% will stay that way, you really type in %command%, this is not a placeholder for something)

3 Likes

Forum kindly sponsored by