Game randomly shuts off monitor, but pc is still on

Months ago I had an old placeholder monitor (VGA) and was able to run gta v perfectly fine. But now when i’m playing Portal, my monitor randomly shuts off and I hear the game’s sfx on a loop from my headphones. I tried blindly clicking, pressing keys etc. but I can’t do anything but turn off my pc from the button. I haven’t recognized a pattern but id say it generally took about 20~30 mins for it to shut off my pc. I doubt its an overheating problem because i checked the temp for mobo, cpu and gpu right after it shut down. I can’t tell whether this is a hardware problem or something else?

I found a line of code on a steam forum as i was looking around (GLIBC_TUNABLES=glibc.tune.hwcaps=-SSE4_2 steam) and when I launched the game with this line, i was able to play for a bit longer. I haven’t ran any other games besides Portal since I got my new monitor.

My monitor model is VP248QG

inxi -Fazy output:

  Kernel: 5.8.18-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=60fe6756-469a-4df1-8e23-bfb9d193f49f rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.20.2 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Desktop Mobo: ASUSTeK model: TUF B450-PRO GAMING v: Rev X.0x 
  serial: <filter> UEFI: American Megatrends v: 2202 date: 07/14/2020 
  Info: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 
  family: 17 (23) model-id: 71 (113) stepping: N/A microcode: 8701021 
  L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 86270 
  Speed: 2794 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 
  1: 2717 2: 1892 3: 2190 4: 2196 5: 1921 6: 2194 7: 2196 8: 2196 9: 2618 
  10: 1876 11: 1872 12: 2190 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] 
  vendor: ASUSTeK driver: amdgpu v: kernel bus ID: 08:00.0 chip ID: 1002:67df 
  Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: amdgpu 
  FAILED: ati unloaded: modesetting alternate: fbdev,vesa display ID: :0 
  screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: DisplayPort-0 res: 1920x1080 hz: 60 dpi: 92 
  size: 531x299mm (20.9x11.8") diag: 609mm (24") 
  OpenGL: renderer: Radeon RX 580 Series (POLARIS10 DRM 3.38.0 
  5.8.18-1-MANJARO LLVM 10.0.1) 
  v: 4.6 Mesa 20.2.1 direct render: Yes 
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] 
  vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 08:00.1 
  chip ID: 1002:aaf0 
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 0a:00.4 chip ID: 1022:1487 
  Sound Server: ALSA v: k5.8.18-1-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8168 v: 8.048.03-NAPI modules: r8169 port: f000 
  bus ID: 03:00.0 chip ID: 10ec:8168 
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Local Storage: total: 2.04 TiB used: 110.62 GiB (5.3%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda vendor: Seagate model: ST2000DM008-2FR102 size: 1.82 TiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: 0001 scheme: MBR 
  ID-2: /dev/sdb vendor: Western Digital model: WDS240G2G0A-00JH30 
  size: 223.57 GiB block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 0400 scheme: GPT 
  ID-1: / raw size: 223.27 GiB size: 218.77 GiB (97.98%) 
  used: 110.62 GiB (50.6%) fs: ext4 dev: /dev/sdb2 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 52.1 C mobo: N/A gpu: amdgpu temp: 31.0 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1217 
  Processes: 291 Uptime: 18m Memory: 15.63 GiB used: 1.83 GiB (11.7%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1497 lib: 475 
  flatpak: 0 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.08

Thanks in advance :slight_smile:


Have you tried to boot with amdgpu.dc=0 kernel boot parameter and test if the issue persists? Also, are you using the line to: MODULES="amdgpu" inside /etc/mkinitcpio.conf ?

When booting with amdgpu.dc=0 it works well :slight_smile: What should I do to keep this change permanent so I won’t have to type it everytime I open it? And no I don’t have that MODULES="amdgpu" in the config file]

Thanks for your reply

Okay i found out how to make the grub change permanent, but i just played CS:GO with my friend and the same exact problem happened. I could still hear him talking when my monitor shut off. He said that it could be related to the Portal problem because theyre both source engine games.

Is there any way to tell what the problem might be? Vsync is not on on csgo and the settings seem correct. I also tried playing in windowed mode and that didnt do anything either

Thanks in advance!

Just gonna leave this here.

Also you might be able to get some more info with journalctl -p 3 or journalctl -p 4.

1 Like