Game crashes after installing an in-game theme

theme
games

#1

Hello, newb here. So i was playing this game Dofus, its a native game (needs to be installed through the AUR because of adobe air). I tried installing a theme for in-game interfaces (officially supported), and my game crashed and does not start anymore. Any tips how to approach this?

I’ve tried “pacman -Rns” but i feel like it doesnt delete the actual game data, just the louncher files.


#2

Ask the game developers?

(moved from #general-discussion to #technical-issues-and-assistance:aur , OP is looking for help with an AUR package)


#3

wouldnt they tell me to just switch to an officially supported OS? as Adobe AIR does not actually “support” pacman-based installation.

I imagine a complete reinstall of the application would fix the problem, but as i said “pacman -Rns” still does not remove the game files, just the louncher (just like “pacaur -S dofus” only installs the louncher).


#5

I don’t know; you’d have to ask them.

I suspect that AIR isn’t a great thing to be using anyway as it hasn’t been supported by Adobe since 2012.


As this is an AUR package the first port of call will be the AUR package page: https://aur.archlinux.org/packages/dofus


#6

Thanks a lot for your help! Before you leave, maybe you know of a way how to COMPLETELY remove the application? As in, all the files downloaded by the launcher, and not just the launcher. Because, like, if i use the “pacman -Rns” command, and then install it again, the louncher is immediately ready to play and does not download the actual game files.


#7

Dude, I’m reading through the package files now.

As an AUR package it’s not part of Manjaro and so doesn’t necessarily comply with proper packaging methods. You also can’t expect someone to answer the question in a ten-minute window.


It looks like the AUR package simply installs the launcher to /opt/ankama/dofus, then when you launch the game it downloads the game files. When you uninstall the package, pacman only removes the files installed by the package, not those downloaded afterwards.

Hence, the package leaves files present on the system after removal. This is a bad package. You should be able to remove all files after uninstalling the package by e.g. sudo rm -fr /opt/ankama/dofus.

There may be other traces left elsewhere I haven’t spotted, but if you’re having an issue here you should post a comment on the AUR page so the package maintainer can fix it for everyone.


#8

They have their own support forums. You can ask there. It’s the perfect place since anyone in there will have the application installed and that’s also where support folks will be crawling. Not here on the Manjaro forums.


#9

Hello Snakemonger,

I can’t help you for your problem but I got a problem installing Dofus on Manjaro with Adobe AIR. If you could help me installing it that would be awesome.

Thank you .


#10

You should not be using anything on Linux that uses Adobe AIR. It has not been updated since 2012 and is known to be full of security holes.

If you’re not going to ask the software authors for help, given they’re the ones who can do something about that, run Windows in a VM and play it there.


#11

Ok thanks for your advice jonathon. Windows VM is not running really well on my laptop, I guess he’s not powerfull enough but that’s not a big deal, I won’t play it on my laptop.


#12

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.