Fyi today's unstable updates broke my falkon cannot open shared object file no such file or directory

Not a big deal for me as I have other browsers to use but I bet it messes up kde a big t more? I use mate so no way for me to know but I’m guessing so.

1 Like

I was looking for unstable. Didn’t look at testing

We usually don’t make announcement posts about unstable updates, because we update unstable at least once per day.

1 Like

Yes. I noticed that too, kinda like that. I wasn’t going to mention it at all because I figured it would get fixed B4 long.

Do you also update linux-rc daily? I noticed today the pkgrel is at 6.

Its been on 7 for a while


I just started using it, and I think there has been an update each day.
Currently, I have 5.16.rc2-6-MANJARO-ARM installed.
Maybe it is different for mobile, I am using a rpi4.

1 Like

I’m on unstable branch and am looking in pamac and see 5.15 not 5.16

Are you really talking about the pi 4? Because I’m not seeing it

Ah, I am referring to linux-rc (vanilla), you are referring to linux-rpi4-rc.

1 Like

You said you’re using rpi4in a previous post? How are you using linux-rc?

Linux-rc is aarch64

Linux-rpi4 is raspberry pi4 64 bit kernel?

What the what?

Which is better?

Both kernels will boot and run. But with the vanilla kernel, currently v3d and headphones do not work. The rpi4 kernels are better all-around, but the linux-rc runs pretty well and has use cases.


Yah but now I tried aarch64 one and my system doesn’t boot… Staring at a blank screen… I don’t have a backup

Ah there we go. Manjaro on the sdcard to the rescue

So if I just open the config.text and mute the dtovetlay with a hashtag to disable fkms- v3d it will boot aarch64?

OK remind me again what I install to get manjaro-chroot on my xfce sdcard install?

Well linux-rc didn’t boot for me but I’ll get my desktop back in a little while I suppose. I’m using my pi4 as a desktop got general purposes I don’t need use cases of aarch64 of linux-rc

The interesting thing is that I was on 5.15 rc but never upgraded to 5.15 non rc when 5.15 went out of rc.

I update linux-rc in unstable branch, when there is either an update or a change I want to put in it. That is pretty often inj the RC cycle.

1 Like

@thesesocalledflowers The linux-rc upstream kernel will boot just fine with the pi4 but it requires some config adjustments after installing it and before rebooting.

Disable all fkms/kms overlays in config.txt. Upstream does not have V3D support or overlays. Also in config.txt specify the path to upstream’s kernel and it’s devicetree. You need to set the gpu_mem= in config.txt. Most important you will have to have xf86-video-fbdev installed if you do not.

sudo pacman -S xf86-video-fbdev



The cmdline.txt also needs to be a little different (make a backup of your original) Get the PARTUUID below from your original cmdline.txt:

[ray@pi4 ~]$ cat /boot/cmdline.txt
root=PARTUUID=your-drive-partuuid-here rw rootwait console=ttyS1,115200 console=tty0 snd_bcm2835.enable_headphones=1 usbhid.mousepoll=8 audit=0

I have not released the latest linux-rpi4-rc yet as kms/fkms is broke. You can install the latest linux-rpi4 or latest linux-rpi4 to be current. The linux-rpi4-5.15-rc7 kernel is very old in the repo. You can keep up with what is what with the latest pi kernels here:

Notice the cmdline.txt I posted above (snd_bcm2835.enable_headphones=1). The headhones does not get picked up for some reason with the upstream kernel in inxi but it will be there in aplay -l and Pulse Audio Settings. It may be a little flaky hot switching back and forth but the headphones will work.

I have noticed that pulseaudio was not working in the past with the upstream kernel but uninstalling it and installing piprwire seems to be ok.

All in all everything is working including bluetooth with the upstream kernel except V3D which it does not support. Of course some pi specific proprietary add on devices will not work also.

1 Like

Thanks, I see the headphones now when booting with firmware, but still not seeing it via uefi.

When you boot into linux-rc next time, would you try running sudo i2cdetect -y 1
When booting via firmware and the linux-rc .dtb, I get this mess:

     0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00:                         08 09 0a 0b 0c 0d 0e 0f 
10: 10 11 12 13 14 15 16 17 18 19 1a 1b 1c 1d 1e 1f 
20: 20 21 22 23 24 25 26 27 28 29 2a 2b 2c 2d 2e 2f 
30: -- -- -- -- -- -- -- -- 38 39 3a 3b 3c 3d 3e 3f 
40: 40 41 42 43 44 45 46 47 48 49 4a 4b 4c 4d 4e 4f 
50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
60: 60 61 62 63 64 65 66 67 68 69 6a 6b 6c 6d 6e 6f 
70: 70 71 72 73 74 75 76 77
1 Like

I get the exact same thing.

1 Like

Ah, well I guess that is both good news and bad news. It means gpio is indeed broken and not just some config issue on my end.

So no dtoverlays use at all. Not even with case fans?

Overlays work, but none are supplied with the linux-rc kernel.

1 Like