Function keys not working

Having the same issue.

I checked with showkey --scancodes and neither the fn key nor fn key plus function keys produce anything. Weirdly, I did manage to configure media keys. But they are always in media key mode.

So e.g. fn+F6 does the same as pressing F6.

Scankeys does not pick up F11, FN, or FN+F11. These keys do nothing, Oddly, I can fullscreen the terminal application by pressing CTRL+F11. Which is not a documented short cut (should be just F11).

I have a Samsung laptop but it seems for Apple keyboards, there is a thing called fnmode, which has 3 settings; one of which is ‘disabled’. I’m wondering if there’s something similar going on here. I don’t have an Apple keyboard of course but the problem seems similar.

I’ve also found some really outdated repository from samsung with some supposed fixes: There seems to be no documentation. Likewise there’s an outdated samsung-tools AUR that has not been updated in years.

My bios has no keyboard related settings (I checked). I’ve randomly tried a few of the generic keyboard settings (including the Apple layout) but that seems to have no effect either. The fn key is effectively dead, always. As are several of the other keys.

I would appreciate suggestions for other things to try. Otherwise this is actually a really nice Linux laptop. Even the touchpad is not half bad.

inxi -Fx:

  Host: jilles-galaxy-book Kernel: 5.13.19-2-MANJARO x86_64 bits: 64
    compiler: gcc v: 11.1.0 Desktop: GNOME 41.3 Distro: Manjaro Linux
    base: Arch Linux
  Type: Laptop System: SAMSUNG product: 750XDA v: P08CFD
    serial: <superuser required>
  Mobo: SAMSUNG model: NP750XDA-KD9DE v: SAMSUNG_SW_REVISION_12345+0.0.0000
    serial: <superuser required> UEFI: American Megatrends LLC.
    v: P08CFD.030.210520.HQ date: 05/20/2021
  ID-1: BAT1 charge: 54.9 Wh (98.0%) condition: 56.0/54.4 Wh (103.0%)
    volts: 17.3 min: 15.4 model: SAMSUNG Electronics SR Real Battery
    status: N/A
  Info: quad core model: 11th Gen Intel Core i5-1135G7 bits: 64 type: MT MCP
    arch: Tiger Lake rev: 1 cache: L1: 320 KiB L2: 5 MiB L3: 8 MiB
  Speed (MHz): avg: 1267 high: 3512 min/max: 400/4200 cores: 1: 1385 2: 489
    3: 481 4: 1604 5: 1014 6: 481 7: 1171 8: 3512 bogomips: 38720
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Samsung Co
    driver: i915 v: kernel bus-ID: 00:02.0
  Device-2: SunplusIT 720p HD Camera type: USB driver: uvcvideo
    bus-ID: 3-7:3
  Display: wayland server: compositor: gnome-shell driver:
    loaded: modesetting resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Samsung Co
    driver: sof-audio-pci-intel-tgl bus-ID: 00:1f.3
  Sound Server-1: ALSA v: k5.13.19-2-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.43 running: no
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 00:14.3
  IF: wlo1 state: up mac: e0:2b:e9:e3:b5:f2
  IF-ID-1: docker0 state: down mac: 02:42:d5:49:06:97
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-10:4
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Local Storage: total: 476.94 GiB used: 122.3 GiB (25.6%)
  ID-1: /dev/nvme0n1 vendor: SSSTC model: CL1-8D512 size: 476.94 GiB
    temp: 30.9 C
  ID-1: / size: 476.64 GiB used: 122.3 GiB (25.7%) fs: btrfs dev: /dev/dm-0
    mapped: luks-443412f3-7aeb-4c4a-99ce-66db2a5a132d
  ID-2: /boot/efi size: 299.4 MiB used: 712 KiB (0.2%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-3: /home size: 476.64 GiB used: 122.3 GiB (25.7%) fs: btrfs
    dev: /dev/dm-0 mapped: luks-443412f3-7aeb-4c4a-99ce-66db2a5a132d
  ID-4: /var/log size: 476.64 GiB used: 122.3 GiB (25.7%) fs: btrfs
    dev: /dev/dm-0 mapped: luks-443412f3-7aeb-4c4a-99ce-66db2a5a132d
  ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%)
    file: /swap/swapfile
  System Temperatures: cpu: 40.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 304 Uptime: 2m Memory: 15.36 GiB used: 3.13 GiB (20.3%)
  Init: systemd Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: 1164
  Shell: Zsh v: 5.8 inxi: 3.3.12

5.13 is EOL. Switch to a supported kernel:

sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu 
sudo mhwd-kernel -i linux515

Then reboot into 5.15. Press Esc during boot to get into grub menu > advanced options and boot with 5.15. Double check your running kernel is not 5.13 then remove it:

uname -r #to check kernel version
sudo mhwd-kernel -r linux513

Thanks, updating the kernel actually fixed things. I did not realize that I was so out of date. I only installed manjaro a few weeks ago. I also did not realize that the kernel is not managed by pacman.

The step for Grub was not needed btw. It booted straight into 5.15.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.