Function keys not working in neovim keymap


Recently i tried to map keys for “Telescope browser” in neovim.

local default_opts = { noremap = true, silent = true }

keymap('n', '<S-F2>', ':Telescope file_browser<CR>', default_opts)

On macbook it’s worked as well, but on linux machine with this config:

OS: Manjaro Linux x86_64
Kernel: 5.15.78-1-MANJARO
Uptime: 18 mins
Packages: 1420 (pacman)
Shell: zsh 5.9
Resolution: 2560x1440
DE: GNOME 43.1
WM: Mutter
WM Theme: Adwaita
Theme: Adw [GTK2/3]
Icons: Papirus-Dark [GTK2/3]
Terminal: tmux
CPU: AMD Ryzen 7 3800X (16) @ 3.900GHz
GPU: AMD ATI Radeon RX 6600/6600 XT/6600M
Memory: 2672MiB / 32000Mi

keys ‘Shift+F2’ not working. Function key ‘F1’ opens neovim help.

Tmux config below:

set -g default-terminal screen-256color
set-option -sa terminal-overrides 'alacritty:RGB'
set-option -sg escape-time 1
set-option -g focus-events on
set -g activity-action other
set -g assume-paste-time 1
set -g base-index 0
set -g bell-action any
set -g set-clipboard on
set -g default-command ''
set -g default-shell /bin/zsh
set -g destroy-unattached off
set -g detach-on-destroy on
set -g display-panes-active-colour red
set -g display-panes-colour blue
set -g display-panes-time 1000
set -g display-time 750
set -g history-limit 1000
set -g key-table root
set -g lock-after-time 0
set -g lock-command "lock -np"
set -g message-command-style bg=black,fg=yellow
set -g message-style bg=yellow,fg=black
set -g mouse on
set -g prefix C-b
set -g prefix2 None
set -g renumber-windows off
set -g repeat-time 500
set -g set-titles off
set -g set-titles-string "#S:#I:#W - \"#T\" #{session_alerts}"
set -g silence-action other
set -g status on
set -g status-bg default
set -g status-fg default
set -g status-interval 1
set -g status-justify left
set -g status-keys vi
set-option -g status-left "\
#[fg=colour7, bg=colour241]#{?client_prefix,#[bg=colour167],} ❐ #S \
#[fg=colour241, bg=colour237]#{?client_prefix,#[fg=colour167],}#{?window_zoomed_flag, 🔍,}"
set -g status-left-length 50
set -g status-left-style default
set -g status-position bottom
set -g status-right "#{?window_bigger,[#{window_offset_x}#,#{window_offset_y}] ,}\"#{=21:pane_title}\" %H:%M %d-%b-%y"
set -g status-right-length 50
set -g status-right-style default
set -g status-style bg=green,fg=black
set -g update-environment[0] DISPLAY
set -g update-environment[1] KRB5CCNAME
set -g update-environment[2] SSH_ASKPASS
set -g update-environment[3] SSH_AUTH_SOCK
set -g update-environment[4] SSH_AGENT_PID
set -g update-environment[5] SSH_CONNECTION
set -g update-environment[6] WINDOWID
set -g update-environment[7] XAUTHORITY
set -g visual-bell off
set -g visual-silence off
set -g word-separators " "

# default window title colors
set-window-option -g window-status-style fg=default,bg=default,dim
# active window title colors
set-window-option -g window-status-current-style fg=default,bg=default,bright

# highlight window when it has new activity
setw -g monitor-activity on
set -g visual-activity on

# Reload config (live)
bind r source-file ~/.tmux.conf \; display "Reloaded!"
# Swap window to 0 (to the left order)
bind-key T swap-window -t 0

Btw i used alacritty for terminal emulator.
Fragment of alacritty config below:

   - { key: Paste,                                       action: Paste          }
   - { key: Copy,                                        action: Copy           }
   - { key: L,         mods: Control,                    action: ClearLogNotice }
   - { key: L,         mods: Control, mode: ~Vi|~Search, chars: "\x0c"          }
   - { key: PageUp,    mods: Shift,   mode: ~Alt,        action: ScrollPageUp   }
   - { key: PageDown,  mods: Shift,   mode: ~Alt,        action: ScrollPageDown }
   - { key: Home,      mods: Shift,   mode: ~Alt,        action: ScrollToTop    }
   - { key: End,       mods: Shift,   mode: ~Alt,        action: ScrollToBottom }

Where should i dig to solve this issue?