Function keys F7 to F12 not working since 2 weeks

After an manjaro update I found, that some function keys does not work.

I have read Function keys not working

I have use

showkey -a -s -k

to test the keys.

/etc/default/grub shows:

GRUB_CMDLINE_LINUX_DEFAULT="quiet i915.enable_psr=0 apparmor=1 security=apparmor resume=UUID=5a269cd4-90b5-4fab-aa8c-769b1a5a1d0e udev.log_priority=3"

$ uname -a
Linux ws24 5.15.49-1-MANJARO #1 SMP PREEMPT Wed Jun 22 14:15:49 UTC 2022 x86_64 GNU/Linux

$ inxi -Fx

  Host: ws24 Kernel: 5.15.49-1-MANJARO arch: x86_64 bits: 64 compiler: gcc
    v: 12.1.0 Desktop: Xfce v: 4.16.0 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: TUXEDO product: TUXEDO v: N/A
    serial: <superuser required>
  Mobo: TUXEDO model: N13_N140ZU serial: <superuser required> UEFI: INSYDE
    v: 1.07.04RTR1 date: 02/14/2019
  ID-1: BAT0 charge: 35.6 Wh (100.0%) condition: 35.6/35.3 Wh (100.6%)
    volts: 12.8 min: 11.4 model: Notebook BAT status: full
  Info: quad core model: Intel Core i7-8565U bits: 64 type: MT MCP
    arch: Whiskey Lake rev: B cache: L1: 256 KiB L2: 1024 KiB L3: 8 MiB
  Speed (MHz): avg: 670 high: 700 min/max: 400/4600 cores: 1: 700 2: 700
    3: 655 4: 700 5: 700 6: 673 7: 634 8: 600 bogomips: 32012
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel WhiskeyLake-U GT2 [UHD Graphics 620] vendor: CLEVO/KAPOK
    driver: i915 v: kernel arch: Gen9.5 bus-ID: 00:02.0
  Device-2: Chicony USB2.0 Camera type: USB driver: uvcvideo bus-ID: 1-7:4
  Display: x11 server: X.Org v: 21.1.3 driver: X: loaded: modesetting
    gpu: i915 resolution: 1: 3840x2160~30Hz 2: N/A
  Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel Cannon Point-LP High Definition Audio vendor: CLEVO/KAPOK
    driver: snd_hda_intel bus-ID: 3-4:3 v: kernel bus-ID: 00:1f.3
  Device-2: Texas Instruments PCM2912A Audio Codec type: USB
    driver: snd-usb-audio
  Sound Server-1: ALSA v: k5.15.49-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: no
  Sound Server-4: PipeWire v: 0.3.52 running: yes
  Device-1: Intel I210 Gigabit Network driver: igb v: kernel port: 4000
    bus-ID: 07:00.0
  IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: 9c:eb:e8:83:76:f6
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: CLEVO/KAPOK driver: r8169 v: kernel port: 3000 bus-ID: 39:00.1
  IF: enp57s0f1 state: down mac: 80:fa:5b:69:6c:53
  Device-3: Intel Wireless-AC 9260 driver: iwlwifi v: kernel
    bus-ID: 3a:00.0
  IF: wlp58s0 state: up mac: 18:56:80:e6:5f:64
  IF-ID-1: wwp0s20f0u2c2 state: down mac: 02:2c:80:13:92:63
  Device-1: Intel Wireless-AC 9260 Bluetooth Adapter type: USB driver: btusb
    v: 0.8 bus-ID: 1-10:5
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 476.94 GiB used: 251.81 GiB (52.8%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 PRO 512GB
    size: 476.94 GiB temp: 33.9 C
  ID-1: / size: 434.44 GiB used: 251.07 GiB (57.8%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 288 KiB (0.1%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-1: swap-1 type: partition size: 34.18 GiB used: 755.8 MiB (2.2%)
    dev: /dev/nvme0n1p3
  System Temperatures: cpu: 47.0 C pch: 45.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 424 Uptime: 2d 6h 36m Memory: 31.07 GiB used: 15.39 GiB (49.5%)
  Init: systemd Compilers: gcc: 12.1.0 clang: 13.0.1 Packages: 1436
  Shell: Bash v: 5.1.16 inxi: 3.3.19

Thank you for help in advance!

I have a clevo based device N14xWU slightly older than yours (march 2018) which does not exhibit any issue with the function keys.

I do however see a difference in bios vendor - where yours are INSYDE and mine American Megatrends

I assume the issue is only present when running Xorg.

Have you checked what configs has been applied with relation to keyboard?


I remember a topic a while ago on how special keys are default mapped.

I will try if I can look it up. I found it - not what I remembered and not of any help in this case. For the record it is Strange default configuration for F13 - F24 keys

If the system cannot register the keypress as you say showkey yields nothing - perhaps a more lowlevel issue?.

Unfortunately it is difficult to troubleshoot such lowlevel issues in a forum.

When you run showkey - you get this info, right?

# showkey
kb mode was ?UNKNOWN?
[ if you are trying this under X, it might not work
since the X server is also reading /dev/console ]

Thank you!
This is shown (hid F6):

$ showkey -a -s -k

Drücken Sie eine Taste - Strg+D beendet das Programm

^[[17~ 	 27 0033 0x1b
 	 91 0133 0x5b
 	 49 0061 0x31
 	 55 0067 0x37
 	126 0176 0x7e
$ cat /etc/X11/xorg.conf.d/00-keyboard.conf
# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "us"

I have two Manjaro computers. One is this tuxedo and the other is an IBM NUC 7.
On both machines I use a Apple Alu keyboard with US-Layout and on both machines I have the same problem.

In /etc/modprobe.d/hid_apple.conf I put the line:

options hid_apple fnmode=2

In /etc/default/keyboard I found:


In my user config with XFCE I set the ISO variant.

All have worked for a long time.

Additional note: that keys doesn’t work on Notebook keyboad too.

Does not work with another keyboard (not apple) too.

No solution found until today

Which solution did you find?

1 Like

It looks like that works.


If you mean this keyboard is not integrated with your laptop N13_N140ZU, check if it is broken?

Why did you show us F6 which presumably works? :grin:

Try again with F7-F12. :slight_smile:

showkey -s


Because it doesn’t work with F7-F12. No output from showkey

I did not found any solution. Don’t know, what to do.

I had similar issue with an old Cherry keyboard…
Little hope: install systemd250 for testing, maybe thr issue goes away.
If systemd250 works, you can go back to systemd251 and do: blacklist: eeepc_wmi
(add to: /etc/modprobe.d/blacklist.conf). Otherwise no ideas yet.

Then you should’ve said so, have you tried with evtest? Have you tried with Fn + F7 etc?

With so many keys and keyboards being affected, it seems like something is blocking/intercepting the scancodes. So presumably it’s a low level mis-configuration or bug.

The apple configuration should be checked.

udev and the hwdb could cause this. If the scancode has been mapped to ‘reserved’ it wouldn’t show in showkey but it would show in evtest. :man_shrugging: Map_scancodes_to_keycodes


Today I tried with sudo showkey -s and I got:

0x58 0xd8

Fn + F7 … F12
0x1c 0x9c
0xe0 0x10
0xe0 0x90
0xe0 0x22
0xe0 0xa2
0xe0 0x19
0xe0 0x99
0xe0 0x20
0xe0 0xa0
0xe0 0x2e
0xe0 0xae
0xe0 0x30
0xe0 0xb0

Without sudo I get “Dateideskriptor, der auf die Konsole verweist, konnte nicht gefunden werden.”

Sorry: what is systemd250 and systemd251? How to install it?

Is it possible, that system need something like a
The tree below /usr/lib/udev was updated in Juni and July.

Sorry, wer das nicht weiss sollte die Finger davon lassen :joy:

systemd251 is the actual version in the repo, old version do not know where (exept on my PC)…
Try in Terminal:
sudo nano /etc/modprobe.d/blacklist.conf and add this entry: blacklist: eeepc_wmi
and reboot to take effect…

/etc/udev/hwdb.d/50-apple-kbd.hwdb - good idea, I presume.

I found:

|/dev/input/event8:|Apple Inc. Apple Keyboard|
|/dev/input/event9:|Apple Inc. Apple Keyboard|

If I use event9, than the keys doesnt work:

Input driver version is 1.0.1
Input device ID: bus 0x3 vendor 0x5ac product 0x24f version 0x111
Input device name: "Apple Inc. Apple Keyboard"
Supported events:
  Event type 0 (EV_SYN)
  Event type 1 (EV_KEY)
    Event code 113 (KEY_MUTE)
    Event code 114 (KEY_VOLUMEDOWN)
    Event code 115 (KEY_VOLUMEUP)
    Event code 161 (KEY_EJECTCD)
    Event code 163 (KEY_NEXTSONG)
    Event code 164 (KEY_PLAYPAUSE)
    Event code 165 (KEY_PREVIOUSSONG)
  Event type 4 (EV_MSC)
    Event code 4 (MSC_SCAN)
Testing ... (interrupt to exit)

If I use event8 it shows other things:

/dev/input/event8:	Apple Inc. Apple Keyboard
/dev/input/event9:	Apple Inc. Apple Keyboard
Select the device event number [0-21]: 8
Input driver version is 1.0.1
Input device ID: bus 0x3 vendor 0x5ac product 0x24f version 0x111
Input device name: "Apple Inc. Apple Keyboard"
Supported events:
  Event type 0 (EV_SYN)
  Event type 1 (EV_KEY)
    Event code 1 (KEY_ESC)
    Event code 2 (KEY_1)
    Event code 3 (KEY_2)
    Event code 4 (KEY_3)
    Event code 5 (KEY_4)
    Event code 6 (KEY_5)
    Event code 7 (KEY_6)
    Event code 8 (KEY_7)
    Event code 9 (KEY_8)
    Event code 10 (KEY_9)
    Event code 11 (KEY_0)
    Event code 12 (KEY_MINUS)
    Event code 13 (KEY_EQUAL)
    Event code 14 (KEY_BACKSPACE)
    Event code 15 (KEY_TAB)
    Event code 16 (KEY_Q)
    Event code 17 (KEY_W)
    Event code 18 (KEY_E)
    Event code 19 (KEY_R)
    Event code 20 (KEY_T)
    Event code 21 (KEY_Y)
    Event code 22 (KEY_U)
    Event code 23 (KEY_I)
    Event code 24 (KEY_O)
    Event code 25 (KEY_P)
    Event code 26 (KEY_LEFTBRACE)
    Event code 27 (KEY_RIGHTBRACE)
    Event code 28 (KEY_ENTER)
    Event code 29 (KEY_LEFTCTRL)
    Event code 30 (KEY_A)
    Event code 31 (KEY_S)
    Event code 32 (KEY_D)
    Event code 33 (KEY_F)
    Event code 34 (KEY_G)
    Event code 35 (KEY_H)
    Event code 36 (KEY_J)
    Event code 37 (KEY_K)
    Event code 38 (KEY_L)
    Event code 39 (KEY_SEMICOLON)
    Event code 40 (KEY_APOSTROPHE)
    Event code 41 (KEY_GRAVE)
    Event code 42 (KEY_LEFTSHIFT)
    Event code 43 (KEY_BACKSLASH)
    Event code 44 (KEY_Z)
    Event code 45 (KEY_X)
    Event code 46 (KEY_C)
    Event code 47 (KEY_V)
    Event code 48 (KEY_B)
    Event code 49 (KEY_N)
    Event code 50 (KEY_M)
    Event code 51 (KEY_COMMA)
    Event code 52 (KEY_DOT)
    Event code 53 (KEY_SLASH)
    Event code 54 (KEY_RIGHTSHIFT)
    Event code 55 (KEY_KPASTERISK)
    Event code 56 (KEY_LEFTALT)
    Event code 57 (KEY_SPACE)
    Event code 58 (KEY_CAPSLOCK)
    Event code 59 (KEY_F1)
    Event code 60 (KEY_F2)
    Event code 61 (KEY_F3)
    Event code 62 (KEY_F4)
    Event code 63 (KEY_F5)
    Event code 64 (KEY_F6)
    Event code 65 (KEY_F7)
    Event code 66 (KEY_F8)
    Event code 67 (KEY_F9)
    Event code 68 (KEY_F10)
    Event code 69 (KEY_NUMLOCK)
    Event code 70 (KEY_SCROLLLOCK)
    Event code 71 (KEY_KP7)
    Event code 72 (KEY_KP8)
    Event code 73 (KEY_KP9)
    Event code 74 (KEY_KPMINUS)
    Event code 75 (KEY_KP4)
    Event code 76 (KEY_KP5)
    Event code 77 (KEY_KP6)
    Event code 78 (KEY_KPPLUS)
    Event code 79 (KEY_KP1)
    Event code 80 (KEY_KP2)
    Event code 81 (KEY_KP3)
    Event code 82 (KEY_KP0)
    Event code 83 (KEY_KPDOT)
    Event code 85 (KEY_ZENKAKUHANKAKU)
    Event code 86 (KEY_102ND)
    Event code 87 (KEY_F11)
    Event code 88 (KEY_F12)
    Event code 89 (KEY_RO)
    Event code 90 (KEY_KATAKANA)
    Event code 91 (KEY_HIRAGANA)
    Event code 92 (KEY_HENKAN)
    Event code 93 (KEY_KATAKANAHIRAGANA)
    Event code 94 (KEY_MUHENKAN)
    Event code 95 (KEY_KPJPCOMMA)
    Event code 96 (KEY_KPENTER)
    Event code 97 (KEY_RIGHTCTRL)
    Event code 98 (KEY_KPSLASH)
    Event code 99 (KEY_SYSRQ)
    Event code 100 (KEY_RIGHTALT)
    Event code 102 (KEY_HOME)
    Event code 103 (KEY_UP)
    Event code 104 (KEY_PAGEUP)
    Event code 105 (KEY_LEFT)
    Event code 106 (KEY_RIGHT)
    Event code 107 (KEY_END)
    Event code 108 (KEY_DOWN)
    Event code 109 (KEY_PAGEDOWN)
    Event code 110 (KEY_INSERT)
    Event code 111 (KEY_DELETE)
    Event code 113 (KEY_MUTE)
    Event code 114 (KEY_VOLUMEDOWN)
    Event code 115 (KEY_VOLUMEUP)
    Event code 116 (KEY_POWER)
    Event code 117 (KEY_KPEQUAL)
    Event code 119 (KEY_PAUSE)
    Event code 120 (KEY_SCALE)
    Event code 121 (KEY_KPCOMMA)
    Event code 122 (KEY_HANGUEL)
    Event code 123 (KEY_HANJA)
    Event code 124 (KEY_YEN)
    Event code 125 (KEY_LEFTMETA)
    Event code 126 (KEY_RIGHTMETA)
    Event code 127 (KEY_COMPOSE)
    Event code 128 (KEY_STOP)
    Event code 129 (KEY_AGAIN)
    Event code 130 (KEY_PROPS)
    Event code 131 (KEY_UNDO)
    Event code 132 (KEY_FRONT)
    Event code 133 (KEY_COPY)
    Event code 134 (KEY_OPEN)
    Event code 135 (KEY_PASTE)
    Event code 136 (KEY_FIND)
    Event code 137 (KEY_CUT)
    Event code 138 (KEY_HELP)
    Event code 140 (KEY_CALC)
    Event code 142 (KEY_SLEEP)
    Event code 150 (KEY_WWW)
    Event code 152 (KEY_SCREENLOCK)
    Event code 158 (KEY_BACK)
    Event code 159 (KEY_FORWARD)
    Event code 161 (KEY_EJECTCD)
    Event code 163 (KEY_NEXTSONG)
    Event code 164 (KEY_PLAYPAUSE)
    Event code 165 (KEY_PREVIOUSSONG)
    Event code 166 (KEY_STOPCD)
    Event code 173 (KEY_REFRESH)
    Event code 176 (KEY_EDIT)
    Event code 177 (KEY_SCROLLUP)
    Event code 178 (KEY_SCROLLDOWN)
    Event code 179 (KEY_KPLEFTPAREN)
    Event code 180 (KEY_KPRIGHTPAREN)
    Event code 183 (KEY_F13)
    Event code 184 (KEY_F14)
    Event code 185 (KEY_F15)
    Event code 186 (KEY_F16)
    Event code 187 (KEY_F17)
    Event code 188 (KEY_F18)
    Event code 189 (KEY_F19)
    Event code 190 (KEY_F20)
    Event code 191 (KEY_F21)
    Event code 192 (KEY_F22)
    Event code 193 (KEY_F23)
    Event code 194 (KEY_F24)
    Event code 204 (KEY_DASHBOARD)
    Event code 224 (KEY_BRIGHTNESSDOWN)
    Event code 225 (KEY_BRIGHTNESSUP)
    Event code 227 (KEY_SWITCHVIDEOMODE)
    Event code 228 (KEY_KBDILLUMTOGGLE)
    Event code 229 (KEY_KBDILLUMDOWN)
    Event code 230 (KEY_KBDILLUMUP)
    Event code 240 (KEY_UNKNOWN)
    Event code 464 (KEY_FN)
  Event type 4 (EV_MSC)
    Event code 4 (MSC_SCAN)
  Event type 17 (EV_LED)
    Event code 0 (LED_NUML) state 0
    Event code 1 (LED_CAPSL) state 0
    Event code 2 (LED_SCROLLL) state 0
    Event code 3 (LED_COMPOSE) state 0
    Event code 4 (LED_KANA) state 0
Key repeat handling:
  Repeat type 20 (EV_REP)
    Repeat code 0 (REP_DELAY)
      Value    250
    Repeat code 1 (REP_PERIOD)
      Value     33
Testing ... (interrupt to exit)
Event: time 1658945510.732823, type 4 (EV_MSC), code 4 (MSC_SCAN), value 70028
Event: time 1658945510.732823, type 1 (EV_KEY), code 28 (KEY_ENTER), value 0
Event: time 1658945510.732823, -------------- SYN_REPORT ------------
Event: time 1658945513.564460, type 4 (EV_MSC), code 4 (MSC_SCAN), value 70040
Event: time 1658945513.564460, type 1 (EV_KEY), code 65 (KEY_F7), value 1
Event: time 1658945513.564460, -------------- SYN_REPORT ------------
Event: time 1658945513.724989, type 4 (EV_MSC), code 4 (MSC_SCAN), value 70040
Event: time 1658945513.724989, type 1 (EV_KEY), code 65 (KEY_F7), value 0

Why there are two Apple Keyboard inputs?

One is for media keys and the other is for everything else. You can see them in “Supported events” .

Your F7 key works and is mapped to the correct keycode. :+1:

Check what keysyms they’re mapped to:

xev -event keyboard

F keys are application specific, it’s likely to be a DE/program configuration issue. If the keysyms are F7 etc then you need to check your keyboard shortcuts.