Function Keys (F1-F12) not working

I’ve switched to Manjaro about a month ago, and i have had this issue from the beginning, wasn’t too important but want to get on top of it. My keyboard has function abilities (volume control, play/pause) on the F keys and i have tried all i could with drivers and such. Volume buttons and such worked when pressing the fn for a few weeks but never F1-12, now neither work (i know i must have done something to change this), but all i really want to work are the Fkeys. If anyone has any idea on how i could fix this, it would be much appreciated.

  Host: allseries Kernel: 5.15.25-1-MANJARO x86_64 bits: 64 compiler: gcc
    v: 11.2.0 Desktop: Xfce 4.16.0 Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: ASUS product: All Series v: N/A
    serial: <superuser required>
  Mobo: ASUSTeK model: H81M-K v: Rev X.0x serial: <superuser required>
    BIOS: American Megatrends v: 3604 date: 03/15/2021
  Info: quad core model: Intel Core i7-4790K bits: 64 type: MT MCP
    arch: Haswell rev: 3 cache: L1: 256 KiB L2: 1024 KiB L3: 8 MiB
  Speed (MHz): avg: 4125 high: 4166 min/max: 800/4400 cores: 1: 4081
    2: 4136 3: 4157 4: 4113 5: 4102 6: 4166 7: 4129 8: 4120 bogomips: 63885
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  Device-1: NVIDIA GM204 [GeForce GTX 980] vendor: Micro-Star MSI
    driver: nvidia v: 470.103.01 bus-ID: 01:00.0
  Display: x11 server: X.Org v: driver: X: loaded: nvidia
    gpu: nvidia resolution: 3440x1440~100Hz
  OpenGL: renderer: NVIDIA GeForce GTX 980/PCIe/SSE2
    v: 4.6.0 NVIDIA 470.103.01 direct render: Yes
  Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
  Device-2: NVIDIA GM204 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel bus-ID: 01:00.1
  Sound Server-1: ALSA v: k5.15.25-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.47 running: no
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK H81M-C driver: r8169 v: kernel port: d000 bus-ID: 03:00.0
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: 9c:5c:8e:c0:47:be
  Local Storage: total: 4.88 TiB used: 2.43 TiB (49.9%)
  ID-1: /dev/sda vendor: SanDisk model: Ultra II 240GB size: 223.57 GiB
  ID-2: /dev/sdb vendor: Samsung model: SSD 840 Series size: 111.79 GiB
  ID-3: /dev/sdc vendor: Seagate model: ST4000DM004-2CV104 size: 3.64 TiB
  ID-4: /dev/sdd vendor: Seagate model: ST1000DM003-1CH162 size: 931.51 GiB
  ID-1: / size: 219 GiB used: 27.98 GiB (12.8%) fs: ext4 dev: /dev/sda1
  Alert: No swap data was found.
  System Temperatures: cpu: 61.0 C mobo: 27.8 C gpu: nvidia temp: 58 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 40%
  Processes: 297 Uptime: 4h 50m Memory: 15.57 GiB used: 10.49 GiB (67.4%)
  Init: systemd Compilers: gcc: 11.2.0 clang: 13.0.1 Packages: 1138
  Shell: Bash v: 5.1.16 inxi: 3.3.13

Have you tried changing the model in the keyboard settings?

I changed, my model to Generic 86, nothing seemed to have changed from 104. but that’s about all i have done in that.

You can start here.

Not certain, but…

Is xfce4-pulseaudio-plugin installed:

pacman -Qi xfce4-pulseaudio-plugin

If so and it is on a panel, right-click and select Properties. Is “Enable keyboard shortcuts for volume control” checked… You can also view this information with the command below and search for “pulseaudio”. There is also a GUI, “Settings Editor”.

xfconf-query -c xfce4-panel -lv | less

As an alternative to the plugin, there is xfce4-volumed-pulse.

Check the journal for warnings, errors that might be related.

journalctl -b0                          # last boot
journalctl -b0 -g pulseaudio            # grep the journal
journalctl -b0 -p0..3                   # emerg, alert, crit, warn
journalctl -b0  --identifier=pulseaudio # process identifier (journalctl -F SYSLOG_IDENTIFIER|less)

Check ~/.xsession-errors for related messages that might indicate a problem.

thanks mate, that was a good idea i didn’t try before, just tried it now and no luck with it.

Check the journal and .xsession-errors file for relevant messages that might help indicate where the problem resides. Checkout the xfce forum, maybe search for xev to get started.